gdm/0001-xorg-detect.patch

20 lines
702 B
Diff

Avoid the Xorg build-time dependency, as we already know the answers
to the questions that are trying to be determined.
diff --git a/meson.build b/meson.build
index bf0e58506..7d8f964c3 100644
--- a/meson.build
+++ b/meson.build
@@ -92,8 +92,9 @@ if find_x_server_out != ''
else
# what to do, what to do, this is wrong, but this just sets the
# defaults, perhaps this user is cross compiling or some such
- x_path = '/usr/bin/X11:/usr/X11R6/bin:/opt/X11R6/bin'
- x_bin = '/usr/bin/X'
+ x_path = '/usr/bin'
+ x_bin = '/usr/bin/Xorg'
+ xserver_has_listen = true
endif
xdmcp_dep = cc.find_library('Xdmcp', required: get_option('xdmcp'))
if xdmcp_dep.found() and get_option('tcp-wrappers')