refine hal patch

This commit is contained in:
Matthias Clasen 2009-02-25 03:56:44 +00:00
parent 8d550e8204
commit fc5e13e0af
2 changed files with 17 additions and 8 deletions

View File

@ -1,6 +1,6 @@
diff -up gdm-2.25.2/configure.ac.system-keyboard gdm-2.25.2/configure.ac
--- gdm-2.25.2/configure.ac.system-keyboard 2009-02-20 23:00:35.658319764 -0500
+++ gdm-2.25.2/configure.ac 2009-02-20 23:00:46.150086289 -0500
--- gdm-2.25.2/configure.ac.system-keyboard 2009-02-24 22:51:00.058815966 -0500
+++ gdm-2.25.2/configure.ac 2009-02-24 22:51:00.154816109 -0500
@@ -69,6 +69,7 @@ AC_SUBST(COMMON_LIBS)
PKG_CHECK_MODULES(DAEMON,
dbus-glib-1 >= $DBUS_GLIB_REQUIRED_VERSION
@ -11,7 +11,7 @@ diff -up gdm-2.25.2/configure.ac.system-keyboard gdm-2.25.2/configure.ac
AC_SUBST(DAEMON_LIBS)
diff -up gdm-2.25.2/daemon/gdm-session-direct.c.system-keyboard gdm-2.25.2/daemon/gdm-session-direct.c
--- gdm-2.25.2/daemon/gdm-session-direct.c.system-keyboard 2008-08-26 15:04:00.000000000 -0400
+++ gdm-2.25.2/daemon/gdm-session-direct.c 2009-02-20 23:01:17.830045657 -0500
+++ gdm-2.25.2/daemon/gdm-session-direct.c 2009-02-24 22:55:02.656566009 -0500
@@ -45,6 +45,8 @@
#include <dbus/dbus-glib.h>
#include <dbus/dbus-glib-lowlevel.h>
@ -21,7 +21,7 @@ diff -up gdm-2.25.2/daemon/gdm-session-direct.c.system-keyboard gdm-2.25.2/daemo
#include "gdm-session-direct.h"
#include "gdm-session.h"
#include "gdm-session-private.h"
@@ -595,14 +597,60 @@ get_default_language_name (GdmSessionDir
@@ -595,14 +597,66 @@ get_default_language_name (GdmSessionDir
return setlocale (LC_MESSAGES, NULL);
}
@ -52,8 +52,14 @@ diff -up gdm-2.25.2/daemon/gdm-session-direct.c.system-keyboard gdm-2.25.2/daemo
+ if (n_devices > 0) {
+ layout = libhal_device_get_property_string (ctx,
+ devices[0],
+ "input.xkb.layout",
+ "input.x11_options.XkbLayout",
+ NULL);
+ if (!layout) {
+ layout = libhal_device_get_property_string (ctx,
+ devices[0],
+ "input.xkb.layout",
+ NULL);
+ }
+ result = g_strdup (layout);
+ libhal_free_string (layout);
+ }
@ -85,7 +91,7 @@ diff -up gdm-2.25.2/daemon/gdm-session-direct.c.system-keyboard gdm-2.25.2/daemo
}
static char *
@@ -1971,9 +2019,10 @@ setup_session_environment (GdmSessionDir
@@ -1971,9 +2025,10 @@ setup_session_environment (GdmSessionDir
"GDM_LANG",
get_language_name (session));
@ -101,7 +107,7 @@ diff -up gdm-2.25.2/daemon/gdm-session-direct.c.system-keyboard gdm-2.25.2/daemo
"DISPLAY",
diff -up gdm-2.25.2/daemon/gdm-session-settings.c.system-keyboard gdm-2.25.2/daemon/gdm-session-settings.c
--- gdm-2.25.2/daemon/gdm-session-settings.c.system-keyboard 2008-08-26 15:04:00.000000000 -0400
+++ gdm-2.25.2/daemon/gdm-session-settings.c 2009-01-23 23:55:38.000000000 -0500
+++ gdm-2.25.2/daemon/gdm-session-settings.c 2009-02-24 22:51:00.158815919 -0500
@@ -149,8 +149,7 @@ gdm_session_settings_set_layout_name (Gd
{
g_return_if_fail (GDM_IS_SESSION_SETTINGS (settings));

View File

@ -16,7 +16,7 @@
Summary: The GNOME Display Manager
Name: gdm
Version: 2.25.2
Release: 6%{?dist}
Release: 7%{?dist}
Epoch: 1
License: GPLv2+
Group: User Interface/X
@ -328,6 +328,9 @@ fi
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
%changelog
* Tue Feb 24 2009 Matthias Clasen <mclasen@redhat.com>
- Refine the hal patch
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.25.2-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild