Add patch to fix issues with the first login after boot
Resolves: #1937308
This commit is contained in:
parent
2680723ecc
commit
fb9039f045
@ -0,0 +1,32 @@
|
|||||||
|
From 198fa5aff65b48cb2b2598522b35b3defc16c61d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Benjamin Berg <bberg@redhat.com>
|
||||||
|
Date: Wed, 10 Mar 2021 11:43:00 +0100
|
||||||
|
Subject: [PATCH] session: Initialize DBus error domain before resolving errors
|
||||||
|
|
||||||
|
We would not initialize the DBus error domain before we retrieved the
|
||||||
|
first error, but only did so to compare the error after receiving them.
|
||||||
|
This means that the first error we received will not be resolved
|
||||||
|
correctly, while all subsequent ones are resolved.
|
||||||
|
|
||||||
|
Fix this by calling GDM_SESSION_WORKER_ERROR from gdm_session_class_init.
|
||||||
|
---
|
||||||
|
daemon/gdm-session.c | 3 +++
|
||||||
|
1 file changed, 3 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/daemon/gdm-session.c b/daemon/gdm-session.c
|
||||||
|
index a6f00b66..5576639a 100644
|
||||||
|
--- a/daemon/gdm-session.c
|
||||||
|
+++ b/daemon/gdm-session.c
|
||||||
|
@@ -3998,6 +3998,9 @@ gdm_session_class_init (GdmSessionClass *session_class)
|
||||||
|
FALSE,
|
||||||
|
G_PARAM_READWRITE | G_PARAM_CONSTRUCT | G_PARAM_STATIC_STRINGS));
|
||||||
|
#endif
|
||||||
|
+
|
||||||
|
+ /* Ensure we can resolve errors */
|
||||||
|
+ GDM_SESSION_WORKER_ERROR;
|
||||||
|
}
|
||||||
|
|
||||||
|
GdmSession *
|
||||||
|
--
|
||||||
|
2.29.2
|
||||||
|
|
8
gdm.spec
8
gdm.spec
@ -11,7 +11,7 @@
|
|||||||
Name: gdm
|
Name: gdm
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 40~beta
|
Version: 40~beta
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -19,6 +19,8 @@ URL: https://wiki.gnome.org/Projects/GDM
|
|||||||
Source0: http://download.gnome.org/sources/gdm/40/gdm-%{tarball_version}.tar.xz
|
Source0: http://download.gnome.org/sources/gdm/40/gdm-%{tarball_version}.tar.xz
|
||||||
Source1: org.gnome.login-screen.gschema.override
|
Source1: org.gnome.login-screen.gschema.override
|
||||||
|
|
||||||
|
Patch00001: 0001-session-Initialize-DBus-error-domain-before-resolvin.patch
|
||||||
|
|
||||||
# Downstream patches
|
# Downstream patches
|
||||||
Patch80001: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
|
Patch80001: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
|
||||||
Patch90001: 0001-data-add-system-dconf-databases-to-gdm-profile.patch
|
Patch90001: 0001-data-add-system-dconf-databases-to-gdm-profile.patch
|
||||||
@ -308,6 +310,10 @@ fi
|
|||||||
%{_libdir}/pkgconfig/gdm-pam-extensions.pc
|
%{_libdir}/pkgconfig/gdm-pam-extensions.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 10 2021 Benjamin Berg <bberg@redhat.com> - 1:40~beta-2
|
||||||
|
- Add patch to fix issues with the first login after boot
|
||||||
|
Resolves: #1937308
|
||||||
|
|
||||||
* Fri Feb 26 2021 Kalev Lember <klember@redhat.com> - 1:40~beta-1
|
* Fri Feb 26 2021 Kalev Lember <klember@redhat.com> - 1:40~beta-1
|
||||||
- Update to 40.beta
|
- Update to 40.beta
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user