- Add upstreamed patch gdm-2.23.2-unknown-lang.patch
This commit is contained in:
parent
fd1bb61715
commit
fabca32039
55
gdm-2.23.2-unknown-lang.patch
Normal file
55
gdm-2.23.2-unknown-lang.patch
Normal file
@ -0,0 +1,55 @@
|
|||||||
|
diff -up gdm-2.23.2/gui/simple-greeter/gdm-language-chooser-widget.c.unknown-lang gdm-2.23.2/gui/simple-greeter/gdm-language-chooser-widget.c
|
||||||
|
--- gdm-2.23.2/gui/simple-greeter/gdm-language-chooser-widget.c.unknown-lang 2008-08-14 15:26:43.000000000 -0400
|
||||||
|
+++ gdm-2.23.2/gui/simple-greeter/gdm-language-chooser-widget.c 2008-08-14 15:26:50.000000000 -0400
|
||||||
|
@@ -133,6 +133,7 @@ gdm_language_chooser_widget_add_language
|
||||||
|
static gboolean
|
||||||
|
language_has_font (const char *locale)
|
||||||
|
{
|
||||||
|
+ const FcCharSet *charset;
|
||||||
|
FcPattern *pattern;
|
||||||
|
FcObjectSet *object_set;
|
||||||
|
FcFontSet *font_set;
|
||||||
|
@@ -146,22 +147,30 @@ language_has_font (const char *locale)
|
||||||
|
|
||||||
|
gdm_parse_language_name (locale, &language_code, NULL, NULL, NULL);
|
||||||
|
|
||||||
|
- pattern = FcPatternBuild (NULL, FC_LANG, FcTypeString, language_code, NULL);
|
||||||
|
+ charset = FcLangGetCharSet ((FcChar8 *) language_code);
|
||||||
|
+ if (!charset)
|
||||||
|
+ /* fontconfig does not know about this language */
|
||||||
|
+ is_displayable = TRUE;
|
||||||
|
+ else
|
||||||
|
+ {
|
||||||
|
+ /* see if any fonts support rendering it */
|
||||||
|
+ pattern = FcPatternBuild (NULL, FC_LANG, FcTypeString, language_code, NULL);
|
||||||
|
+
|
||||||
|
+ if (pattern == NULL)
|
||||||
|
+ goto done;
|
||||||
|
+
|
||||||
|
+ object_set = FcObjectSetCreate ();
|
||||||
|
+
|
||||||
|
+ if (object_set == NULL)
|
||||||
|
+ goto done;
|
||||||
|
|
||||||
|
- if (pattern == NULL)
|
||||||
|
- goto done;
|
||||||
|
+ font_set = FcFontList (NULL, pattern, object_set);
|
||||||
|
|
||||||
|
- object_set = FcObjectSetBuild (NULL, NULL);
|
||||||
|
+ if (font_set == NULL)
|
||||||
|
+ goto done;
|
||||||
|
|
||||||
|
- if (object_set == NULL)
|
||||||
|
- goto done;
|
||||||
|
-
|
||||||
|
- font_set = FcFontList (NULL, pattern, object_set);
|
||||||
|
-
|
||||||
|
- if (font_set == NULL)
|
||||||
|
- goto done;
|
||||||
|
-
|
||||||
|
- is_displayable = (font_set->nfont > 0);
|
||||||
|
+ is_displayable = (font_set->nfont > 0);
|
||||||
|
+ }
|
||||||
|
|
||||||
|
done:
|
||||||
|
|
12
gdm.spec
12
gdm.spec
@ -11,11 +11,12 @@
|
|||||||
%define polkit_version 0.7
|
%define polkit_version 0.7
|
||||||
%define consolekit_version 0.2.7
|
%define consolekit_version 0.2.7
|
||||||
%define hal_version 0.5.9
|
%define hal_version 0.5.9
|
||||||
|
%define fontconfig_version 2.6.0
|
||||||
|
|
||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.23.2
|
Version: 2.23.2
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -53,7 +54,7 @@ BuildRequires: gtk2-devel >= 0:%{gtk2_version}
|
|||||||
BuildRequires: libglade2-devel >= 0:%{libglade2_version}
|
BuildRequires: libglade2-devel >= 0:%{libglade2_version}
|
||||||
BuildRequires: libgnomeui-devel >= 0:%{libgnomeui_version}
|
BuildRequires: libgnomeui-devel >= 0:%{libgnomeui_version}
|
||||||
BuildRequires: pam-devel >= 0:%{pam_version}
|
BuildRequires: pam-devel >= 0:%{pam_version}
|
||||||
BuildRequires: fontconfig
|
BuildRequires: fontconfig >= 0:%{fontconfig_version}
|
||||||
BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
|
BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
|
||||||
BuildRequires: gail-devel >= 0:%{gail_version}
|
BuildRequires: gail-devel >= 0:%{gail_version}
|
||||||
BuildRequires: libtool automake autoconf
|
BuildRequires: libtool automake autoconf
|
||||||
@ -79,6 +80,9 @@ BuildRequires: libxklavier-devel
|
|||||||
Requires: audit-libs >= %{libauditver}
|
Requires: audit-libs >= %{libauditver}
|
||||||
Patch1: xkb-groups.patch
|
Patch1: xkb-groups.patch
|
||||||
|
|
||||||
|
# Upstreamed
|
||||||
|
Patch2: gdm-2.23.2-unknown-lang.patch
|
||||||
|
|
||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
Patch99: gdm-2.23.1-fedora-logo.patch
|
Patch99: gdm-2.23.1-fedora-logo.patch
|
||||||
|
|
||||||
@ -100,6 +104,7 @@ multiple simulanteous logged in users.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .xkb-groups
|
%patch1 -p1 -b .xkb-groups
|
||||||
|
%patch2 -p1 -b .unknown-lang
|
||||||
%patch99 -p1 -b .fedora-logo
|
%patch99 -p1 -b .fedora-logo
|
||||||
|
|
||||||
autoreconf
|
autoreconf
|
||||||
@ -299,6 +304,9 @@ fi
|
|||||||
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 14 2008 Behdad Esfahbod <besfahbo@redhat.com> - 1:2.23.2-3
|
||||||
|
- Add upstreamed patch gdm-2.23.2-unknown-lang.patch
|
||||||
|
|
||||||
* Wed Aug 13 2008 Ray Strode <rstrode@redhat.com> - 1:2.23.2-2
|
* Wed Aug 13 2008 Ray Strode <rstrode@redhat.com> - 1:2.23.2-2
|
||||||
- Require plymouth-gdm-hooks so plymouth-log-viewer gets pulled
|
- Require plymouth-gdm-hooks so plymouth-log-viewer gets pulled
|
||||||
in on upgrades
|
in on upgrades
|
||||||
|
Loading…
Reference in New Issue
Block a user