Drop patch from -2, better fix was applied to systemd
This commit is contained in:
parent
9c5d4861e8
commit
f4c8058170
@ -1,43 +0,0 @@
|
|||||||
From 499d9f74f5f512944c5ce7f48151eb8520764769 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Adam Williamson <awilliam@redhat.com>
|
|
||||||
Date: Thu, 22 Aug 2019 13:21:44 -0700
|
|
||||||
Subject: [PATCH] Revert "gdm-{wayland,x}-session: allow users to overwrite
|
|
||||||
environment"
|
|
||||||
|
|
||||||
This reverts commit 2802e92d27450d86d81b6356dd532ec80e797223,
|
|
||||||
as it causes regular users' $PATH to have /usr/sbin before
|
|
||||||
/usr/bin, which breaks consolehelper.
|
|
||||||
---
|
|
||||||
daemon/gdm-wayland-session.c | 2 +-
|
|
||||||
daemon/gdm-x-session.c | 2 +-
|
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/daemon/gdm-wayland-session.c b/daemon/gdm-wayland-session.c
|
|
||||||
index 79922664..35679b19 100644
|
|
||||||
--- a/daemon/gdm-wayland-session.c
|
|
||||||
+++ b/daemon/gdm-wayland-session.c
|
|
||||||
@@ -320,7 +320,7 @@ spawn_session (State *state,
|
|
||||||
continue;
|
|
||||||
}
|
|
||||||
|
|
||||||
- g_subprocess_launcher_setenv (launcher, environment_entry[0], environment_entry[1], TRUE);
|
|
||||||
+ g_subprocess_launcher_setenv (launcher, environment_entry[0], environment_entry[1], FALSE);
|
|
||||||
}
|
|
||||||
|
|
||||||
/* Don't allow session specific environment variables from earlier sessions to
|
|
||||||
diff --git a/daemon/gdm-x-session.c b/daemon/gdm-x-session.c
|
|
||||||
index 9714da3e..58865a6c 100644
|
|
||||||
--- a/daemon/gdm-x-session.c
|
|
||||||
+++ b/daemon/gdm-x-session.c
|
|
||||||
@@ -635,7 +635,7 @@ spawn_session (State *state,
|
|
||||||
continue;
|
|
||||||
}
|
|
||||||
|
|
||||||
- g_subprocess_launcher_setenv (launcher, environment_entry[0], environment_entry[1], TRUE);
|
|
||||||
+ g_subprocess_launcher_setenv (launcher, environment_entry[0], environment_entry[1], FALSE);
|
|
||||||
}
|
|
||||||
|
|
||||||
/* Don't allow session specific environment variables from earlier sessions to
|
|
||||||
--
|
|
||||||
2.23.0
|
|
||||||
|
|
9
gdm.spec
9
gdm.spec
@ -10,7 +10,7 @@
|
|||||||
Name: gdm
|
Name: gdm
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 3.33.90
|
Version: 3.33.90
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -18,10 +18,6 @@ URL: https://wiki.gnome.org/Projects/GDM
|
|||||||
Source0: http://download.gnome.org/sources/gdm/3.30/gdm-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/gdm/3.30/gdm-%{version}.tar.xz
|
||||||
Source1: org.gnome.login-screen.gschema.override
|
Source1: org.gnome.login-screen.gschema.override
|
||||||
Patch0: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
|
Patch0: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1744059
|
|
||||||
# This reverts https://gitlab.gnome.org/GNOME/gdm/commit/2802e92d27450d86d81b6356dd532ec80e797223
|
|
||||||
# which triggered the bug
|
|
||||||
Patch1: 0001-Revert-gdm-wayland-x-session-allow-users-to-overwrit.patch
|
|
||||||
|
|
||||||
Patch10001: 0001-data-disable-wayland-if-modesetting-is-disabled.patch
|
Patch10001: 0001-data-disable-wayland-if-modesetting-is-disabled.patch
|
||||||
|
|
||||||
@ -315,6 +311,9 @@ fi
|
|||||||
%{_libdir}/pkgconfig/gdm-pam-extensions.pc
|
%{_libdir}/pkgconfig/gdm-pam-extensions.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 26 2019 Adam Williamson <awilliam@redhat.com> - 1:3.33.90-3
|
||||||
|
- Drop patch from -2, better fix was applied to systemd
|
||||||
|
|
||||||
* Thu Aug 22 2019 Adam Williamson <awilliam@redhat.com> - 1:3.33.90-2
|
* Thu Aug 22 2019 Adam Williamson <awilliam@redhat.com> - 1:3.33.90-2
|
||||||
- Revert upstream commit that gives sbin priority in non-root $PATH
|
- Revert upstream commit that gives sbin priority in non-root $PATH
|
||||||
- Resolves: #1744059
|
- Resolves: #1744059
|
||||||
|
Loading…
Reference in New Issue
Block a user