Update to 40.rc
This commit is contained in:
parent
fb9039f045
commit
f0263e4d96
1
.gitignore
vendored
1
.gitignore
vendored
@ -135,3 +135,4 @@ gdm-2.30.2.tar.bz2
|
||||
/gdm-3.38.2.tar.xz
|
||||
/gdm-3.38.2.1.tar.xz
|
||||
/gdm-40.beta.tar.xz
|
||||
/gdm-40.rc.tar.xz
|
||||
|
@ -1,32 +0,0 @@
|
||||
From 198fa5aff65b48cb2b2598522b35b3defc16c61d Mon Sep 17 00:00:00 2001
|
||||
From: Benjamin Berg <bberg@redhat.com>
|
||||
Date: Wed, 10 Mar 2021 11:43:00 +0100
|
||||
Subject: [PATCH] session: Initialize DBus error domain before resolving errors
|
||||
|
||||
We would not initialize the DBus error domain before we retrieved the
|
||||
first error, but only did so to compare the error after receiving them.
|
||||
This means that the first error we received will not be resolved
|
||||
correctly, while all subsequent ones are resolved.
|
||||
|
||||
Fix this by calling GDM_SESSION_WORKER_ERROR from gdm_session_class_init.
|
||||
---
|
||||
daemon/gdm-session.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/daemon/gdm-session.c b/daemon/gdm-session.c
|
||||
index a6f00b66..5576639a 100644
|
||||
--- a/daemon/gdm-session.c
|
||||
+++ b/daemon/gdm-session.c
|
||||
@@ -3998,6 +3998,9 @@ gdm_session_class_init (GdmSessionClass *session_class)
|
||||
FALSE,
|
||||
G_PARAM_READWRITE | G_PARAM_CONSTRUCT | G_PARAM_STATIC_STRINGS));
|
||||
#endif
|
||||
+
|
||||
+ /* Ensure we can resolve errors */
|
||||
+ GDM_SESSION_WORKER_ERROR;
|
||||
}
|
||||
|
||||
GdmSession *
|
||||
--
|
||||
2.29.2
|
||||
|
9
gdm.spec
9
gdm.spec
@ -10,8 +10,8 @@
|
||||
|
||||
Name: gdm
|
||||
Epoch: 1
|
||||
Version: 40~beta
|
||||
Release: 2%{?dist}
|
||||
Version: 40~rc
|
||||
Release: 1%{?dist}
|
||||
Summary: The GNOME Display Manager
|
||||
|
||||
License: GPLv2+
|
||||
@ -19,8 +19,6 @@ URL: https://wiki.gnome.org/Projects/GDM
|
||||
Source0: http://download.gnome.org/sources/gdm/40/gdm-%{tarball_version}.tar.xz
|
||||
Source1: org.gnome.login-screen.gschema.override
|
||||
|
||||
Patch00001: 0001-session-Initialize-DBus-error-domain-before-resolvin.patch
|
||||
|
||||
# Downstream patches
|
||||
Patch80001: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
|
||||
Patch90001: 0001-data-add-system-dconf-databases-to-gdm-profile.patch
|
||||
@ -310,6 +308,9 @@ fi
|
||||
%{_libdir}/pkgconfig/gdm-pam-extensions.pc
|
||||
|
||||
%changelog
|
||||
* Tue Mar 16 2021 Kalev Lember <klember@redhat.com> - 1:40~rc-1
|
||||
- Update to 40.rc
|
||||
|
||||
* Wed Mar 10 2021 Benjamin Berg <bberg@redhat.com> - 1:40~beta-2
|
||||
- Add patch to fix issues with the first login after boot
|
||||
Resolves: #1937308
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gdm-40.beta.tar.xz) = 37574e231e842374955be29b1a1c9a5c37bb64b880263478f649f1650e3535d00e70f871cebcc0739e9ff767db66a20948d3de8412376fb30f7665e42c75e538
|
||||
SHA512 (gdm-40.rc.tar.xz) = b0b9582734f241612b4d4125ad77dd53723f1d69ff7c486f28b5a1597eb2ae3b66bcd0a4dbc20e3e6fecae7e593a5ff48bf2289b25d4fde23844d0aa7425fd98
|
||||
|
Loading…
Reference in New Issue
Block a user