Check for a null filesystem type
This commit is contained in:
parent
6745e3d36e
commit
ecc120f517
23
gdm-null-fs.patch
Normal file
23
gdm-null-fs.patch
Normal file
@ -0,0 +1,23 @@
|
||||
Index: gdm/gui/simple-greeter/gdm-user.c
|
||||
===================================================================
|
||||
--- gdm/gui/simple-greeter/gdm-user.c (revision 6253)
|
||||
+++ gdm/gui/simple-greeter/gdm-user.c (working copy)
|
||||
@@ -750,11 +750,13 @@ render_icon_from_home (GdmUser *user,
|
||||
}
|
||||
filesystem_type = g_file_info_get_attribute_string (file_info,
|
||||
G_FILE_ATTRIBUTE_FILESYSTEM_TYPE);
|
||||
- is_local = ((strcmp (filesystem_type, "nfs") != 0) &&
|
||||
- (strcmp (filesystem_type, "afs") != 0) &&
|
||||
- (strcmp (filesystem_type, "autofs") != 0) &&
|
||||
- (strcmp (filesystem_type, "unknown") != 0) &&
|
||||
- (strcmp (filesystem_type, "ncpfs") != 0));
|
||||
+ if (filesystem_type != NULL) {
|
||||
+ is_local = ((strcmp (filesystem_type, "nfs") != 0) &&
|
||||
+ (strcmp (filesystem_type, "afs") != 0) &&
|
||||
+ (strcmp (filesystem_type, "autofs") != 0) &&
|
||||
+ (strcmp (filesystem_type, "unknown") != 0) &&
|
||||
+ (strcmp (filesystem_type, "ncpfs") != 0));
|
||||
+ }
|
||||
g_object_unref (file_info);
|
||||
g_object_unref (file);
|
||||
}
|
8
gdm.spec
8
gdm.spec
@ -15,7 +15,7 @@
|
||||
Summary: The GNOME Display Manager
|
||||
Name: gdm
|
||||
Version: 2.22.0
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv2+
|
||||
Group: User Interface/X
|
||||
@ -85,6 +85,8 @@ Patch3: show-users.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=446672
|
||||
Patch4: gdm-2.22.0-enable-tcp.patch
|
||||
|
||||
Patch9: gdm-null-fs.patch
|
||||
|
||||
# Fedora-specific
|
||||
Patch99: gdm-2.21.8-fedora-logo.patch
|
||||
|
||||
@ -109,6 +111,7 @@ multiple simulanteous logged in users.
|
||||
%patch2 -p1 -b .keyboard-chooser
|
||||
%patch3 -p1 -b .show-users
|
||||
%patch4 -p1 -b .enable-tcp
|
||||
%patch9 -p1 -b .null-fs
|
||||
%patch99 -p1 -b .fedora-logo
|
||||
|
||||
autoreconf
|
||||
@ -308,6 +311,9 @@ fi
|
||||
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
||||
|
||||
%changelog
|
||||
* Thu Jul 3 2008 Jon McCann <jmccann@redhat.com> - 1:2.22.0-9
|
||||
- Check for a null filesystem type
|
||||
|
||||
* Wed Jun 25 2008 Ray Strode <rstrode@redhat.com> - 1:2.22.0-8
|
||||
- After discussion with X team, turn tcp connections off by default,
|
||||
but add back option to toggle on (bug 446672)
|
||||
|
Loading…
Reference in New Issue
Block a user