Update to 41.3
This commit is contained in:
parent
b701d21608
commit
e55022583f
1
.gitignore
vendored
1
.gitignore
vendored
@ -140,3 +140,4 @@ gdm-2.30.2.tar.bz2
|
|||||||
/gdm-41.alpha.tar.xz
|
/gdm-41.alpha.tar.xz
|
||||||
/gdm-41.rc.tar.xz
|
/gdm-41.rc.tar.xz
|
||||||
/gdm-41.0.tar.xz
|
/gdm-41.0.tar.xz
|
||||||
|
/gdm-41.3.tar.xz
|
||||||
|
@ -1,87 +0,0 @@
|
|||||||
From ef71c6330dde267f2fda9d58631bafac652fc8e3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ray Strode <rstrode@redhat.com>
|
|
||||||
Date: Wed, 29 Sep 2021 11:03:41 -0400
|
|
||||||
Subject: [PATCH] daemon: Infer session type from desktop file if user has no
|
|
||||||
saved session type
|
|
||||||
|
|
||||||
The accountsservice user cache file can specify a session type
|
|
||||||
associated with the saved session. This is optional though. If one
|
|
||||||
isn't specified GDM needs to figure out the session type based on the
|
|
||||||
list of preferred session types for the system and the session file
|
|
||||||
itself.
|
|
||||||
|
|
||||||
It was failing to do the latter, though. This commit fixes that.
|
|
||||||
---
|
|
||||||
daemon/gdm-session.c | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/daemon/gdm-session.c b/daemon/gdm-session.c
|
|
||||||
index c1e2be00..4b709731 100644
|
|
||||||
--- a/daemon/gdm-session.c
|
|
||||||
+++ b/daemon/gdm-session.c
|
|
||||||
@@ -1009,60 +1009,62 @@ worker_on_saved_language_name_read (GdmDBusWorker *worker,
|
|
||||||
}
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
static void
|
|
||||||
worker_on_saved_session_name_read (GdmDBusWorker *worker,
|
|
||||||
const char *session_name,
|
|
||||||
GdmSessionConversation *conversation)
|
|
||||||
{
|
|
||||||
GdmSession *self = conversation->session;
|
|
||||||
|
|
||||||
if (! get_session_command_for_name (self, session_name, self->saved_session_type, NULL)) {
|
|
||||||
/* ignore sessions that don't exist */
|
|
||||||
g_debug ("GdmSession: not using invalid .dmrc session: %s", session_name);
|
|
||||||
g_free (self->saved_session);
|
|
||||||
self->saved_session = NULL;
|
|
||||||
update_session_type (self);
|
|
||||||
} else {
|
|
||||||
if (strcmp (session_name,
|
|
||||||
get_default_session_name (self)) != 0) {
|
|
||||||
g_free (self->saved_session);
|
|
||||||
self->saved_session = g_strdup (session_name);
|
|
||||||
|
|
||||||
if (self->greeter_interface != NULL) {
|
|
||||||
gdm_dbus_greeter_emit_default_session_name_changed (self->greeter_interface,
|
|
||||||
session_name);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
if (self->saved_session_type != NULL)
|
|
||||||
set_session_type (self, self->saved_session_type);
|
|
||||||
+ else
|
|
||||||
+ update_session_type (self);
|
|
||||||
}
|
|
||||||
|
|
||||||
}
|
|
||||||
|
|
||||||
static void
|
|
||||||
worker_on_saved_session_type_read (GdmDBusWorker *worker,
|
|
||||||
const char *session_type,
|
|
||||||
GdmSessionConversation *conversation)
|
|
||||||
{
|
|
||||||
GdmSession *self = conversation->session;
|
|
||||||
|
|
||||||
g_free (self->saved_session_type);
|
|
||||||
self->saved_session_type = g_strdup (session_type);
|
|
||||||
}
|
|
||||||
|
|
||||||
static GdmSessionConversation *
|
|
||||||
find_conversation_by_pid (GdmSession *self,
|
|
||||||
GPid pid)
|
|
||||||
{
|
|
||||||
GHashTableIter iter;
|
|
||||||
gpointer key, value;
|
|
||||||
|
|
||||||
g_hash_table_iter_init (&iter, self->conversations);
|
|
||||||
while (g_hash_table_iter_next (&iter, &key, &value)) {
|
|
||||||
GdmSessionConversation *conversation;
|
|
||||||
|
|
||||||
conversation = (GdmSessionConversation *) value;
|
|
||||||
|
|
||||||
if (conversation->worker_pid == pid) {
|
|
||||||
return conversation;
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
11
gdm.spec
11
gdm.spec
@ -10,8 +10,8 @@
|
|||||||
|
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 41.0
|
Version: 41.3
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -24,9 +24,6 @@ Source5: default.pa-for-gdm
|
|||||||
|
|
||||||
Source6: gdm.sysusers
|
Source6: gdm.sysusers
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2007742
|
|
||||||
Patch10001: 0001-daemon-Infer-session-type-from-desktop-file-if-user-.patch
|
|
||||||
|
|
||||||
# Downstream patches
|
# Downstream patches
|
||||||
Patch80001: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
|
Patch80001: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
|
||||||
Patch90001: 0001-data-add-system-dconf-databases-to-gdm-profile.patch
|
Patch90001: 0001-data-add-system-dconf-databases-to-gdm-profile.patch
|
||||||
@ -280,7 +277,6 @@ fi
|
|||||||
%attr(0700, gdm, gdm) %dir %{_localstatedir}/lib/gdm/.config/pulse
|
%attr(0700, gdm, gdm) %dir %{_localstatedir}/lib/gdm/.config/pulse
|
||||||
%attr(0600, gdm, gdm) %{_localstatedir}/lib/gdm/.config/pulse/default.pa
|
%attr(0600, gdm, gdm) %{_localstatedir}/lib/gdm/.config/pulse/default.pa
|
||||||
%attr(0711, root, gdm) %dir /run/gdm
|
%attr(0711, root, gdm) %dir /run/gdm
|
||||||
%config %{_sysconfdir}/pam.d/gdm-pin
|
|
||||||
%config %{_sysconfdir}/pam.d/gdm-smartcard
|
%config %{_sysconfdir}/pam.d/gdm-smartcard
|
||||||
%config %{_sysconfdir}/pam.d/gdm-fingerprint
|
%config %{_sysconfdir}/pam.d/gdm-fingerprint
|
||||||
%{_sysconfdir}/pam.d/gdm-launch-environment
|
%{_sysconfdir}/pam.d/gdm-launch-environment
|
||||||
@ -303,6 +299,9 @@ fi
|
|||||||
%{_libdir}/pkgconfig/gdm-pam-extensions.pc
|
%{_libdir}/pkgconfig/gdm-pam-extensions.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 12 2022 David King <amigadave@amigadave.com> - 1:41.3-1
|
||||||
|
- Update to 41.3
|
||||||
|
|
||||||
* Wed Nov 17 2021 Kevin Fenzi <kevin@scrye.com> - 41.0-4
|
* Wed Nov 17 2021 Kevin Fenzi <kevin@scrye.com> - 41.0-4
|
||||||
- Typo fix from Timothée Ravier
|
- Typo fix from Timothée Ravier
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gdm-41.0.tar.xz) = b1dd99beb8339c6cf93f10e0aec1c946c615b4efaf1724392585985fb32cee156a9e44fd3041ab87ab9ba6a6bd6c9a9d0ecf8b40dc9c098b3c7ee47f7a7e9a97
|
SHA512 (gdm-41.3.tar.xz) = 71a93eef02fccee22ca4f90e3217431923da2b1ac4f5995ff7b64c9b4cac839f4695f4122d255407b570635d34e86e233fa7e4d5d22a8d8185ccfa8ad20f83aa
|
||||||
|
Loading…
Reference in New Issue
Block a user