fix crash in liveimage
This commit is contained in:
parent
bc2b1f08a6
commit
d9fb4f74ad
37
fix-crash.patch
Normal file
37
fix-crash.patch
Normal file
@ -0,0 +1,37 @@
|
||||
From 59f883f28a4b176cb821e4ee2aaec4f024e22213 Mon Sep 17 00:00:00 2001
|
||||
From: Ray Strode <rstrode@redhat.com>
|
||||
Date: Mon, 9 Apr 2012 14:01:22 -0400
|
||||
Subject: [PATCH] Only strip CK goo from seat prefix, if there's CK goo in
|
||||
seat prefix
|
||||
|
||||
Now that we can use logind for seat management, there' may not be
|
||||
/org/freedesktop/ConsoleKit in the seat identifier.
|
||||
|
||||
This commit makes sure the GDM_SEAT_ID environment variable doesn't
|
||||
show gunk in the case the system is configured to use logind.
|
||||
|
||||
Related downstream report:
|
||||
|
||||
http://bugzilla.redhat.com/810451
|
||||
---
|
||||
daemon/gdm-welcome-session.c | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/daemon/gdm-welcome-session.c b/daemon/gdm-welcome-session.c
|
||||
index 01df365..d0ca4e6 100644
|
||||
--- a/daemon/gdm-welcome-session.c
|
||||
+++ b/daemon/gdm-welcome-session.c
|
||||
@@ -308,8 +308,9 @@ build_welcome_environment (GdmWelcomeSession *welcome_session,
|
||||
if (start_session && welcome_session->priv->x11_display_seat_id != NULL) {
|
||||
char *seat_id;
|
||||
|
||||
- seat_id = welcome_session->priv->x11_display_seat_id +
|
||||
- strlen ("/org/freedesktop/ConsoleKit/");
|
||||
+ if (g_str_has_prefix (welcome_session->priv->x11_display_seat_id, "/org/freedesktop/ConsoleKit/")) {
|
||||
+ seat_id = welcome_session->priv->x11_display_seat_id + strlen ("/org/freedesktop/ConsoleKit/");
|
||||
+ }
|
||||
|
||||
g_hash_table_insert (hash, g_strdup ("GDM_SEAT_ID"), g_strdup (seat_id));
|
||||
}
|
||||
--
|
||||
1.7.9.3
|
12
gdm.spec
12
gdm.spec
@ -14,7 +14,7 @@
|
||||
Summary: The GNOME Display Manager
|
||||
Name: gdm
|
||||
Version: 3.4.0.1
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv2+
|
||||
Group: User Interface/X
|
||||
@ -32,7 +32,9 @@ Source8: gdm-fingerprint-16.png
|
||||
Source9: gdm-fingerprint-48.png
|
||||
Source10: org.gnome.login-screen.gschema.override
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=673620
|
||||
# already upstream
|
||||
Patch0: fix-crash.patch
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=673620
|
||||
Patch1: 0001-Fix-a-problem-in-the-systemd-code.patch
|
||||
Requires(pre): /usr/sbin/useradd
|
||||
|
||||
@ -132,7 +134,9 @@ Development files and headers for writing GDM greeters.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .fix-crash
|
||||
%patch1 -p1 -b .systemd
|
||||
|
||||
%patch98 -p1 -b .plymouth
|
||||
|
||||
autoreconf -i -f
|
||||
@ -377,6 +381,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
|
||||
%{_libdir}/girepository-1.0/GdmGreeter-1.0.typelib
|
||||
|
||||
%changelog
|
||||
* Mon Apr 09 2012 Ray Strode <rstrode@redhat.com> 3.4.0.1-4
|
||||
- Fix crash
|
||||
Resolves: #810451
|
||||
|
||||
* Thu Apr 5 2012 Matthias Clasen <mclasen@redhat.com> 3.4.0.1-3
|
||||
- Make session unlocking after user switching work
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user