fix session unlock
This commit is contained in:
parent
7701f51d56
commit
c512f2fe4d
29
0001-Fix-a-problem-in-the-systemd-code.patch
Normal file
29
0001-Fix-a-problem-in-the-systemd-code.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From 97f0b7a36e4a99a1ddf88c69aab38e816e13c70c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Matthias Clasen <mclasen@redhat.com>
|
||||||
|
Date: Thu, 5 Apr 2012 22:54:48 -0400
|
||||||
|
Subject: [PATCH] Fix a problem in the systemd code
|
||||||
|
|
||||||
|
Make session unlock work with logind.
|
||||||
|
This was not working due to a typo in the bus name of logind.
|
||||||
|
|
||||||
|
https://bugzilla.gnome.org/show_bug.cgi?id=673620
|
||||||
|
---
|
||||||
|
daemon/gdm-slave.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/daemon/gdm-slave.c b/daemon/gdm-slave.c
|
||||||
|
index 6e1b45c..06abc91 100644
|
||||||
|
--- a/daemon/gdm-slave.c
|
||||||
|
+++ b/daemon/gdm-slave.c
|
||||||
|
@@ -1658,7 +1658,7 @@ session_unlock_for_systemd (GdmSlave *slave,
|
||||||
|
|
||||||
|
dbus_error_init (&error);
|
||||||
|
|
||||||
|
- message = dbus_message_new_method_call ("org.freedesktop.login",
|
||||||
|
+ message = dbus_message_new_method_call ("org.freedesktop.login1",
|
||||||
|
"/org/freedesktop/login1",
|
||||||
|
"org.freedesktop.login1.Manager",
|
||||||
|
"UnlockSession");
|
||||||
|
--
|
||||||
|
1.7.9.3
|
||||||
|
|
8
gdm.spec
8
gdm.spec
@ -14,7 +14,7 @@
|
|||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 3.4.0.1
|
Version: 3.4.0.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -32,6 +32,8 @@ Source8: gdm-fingerprint-16.png
|
|||||||
Source9: gdm-fingerprint-48.png
|
Source9: gdm-fingerprint-48.png
|
||||||
Source10: org.gnome.login-screen.gschema.override
|
Source10: org.gnome.login-screen.gschema.override
|
||||||
|
|
||||||
|
# https://bugzilla.gnome.org/show_bug.cgi?id=673620
|
||||||
|
Patch1: 0001-Fix-a-problem-in-the-systemd-code.patch
|
||||||
Requires(pre): /usr/sbin/useradd
|
Requires(pre): /usr/sbin/useradd
|
||||||
|
|
||||||
Requires: pam >= 0:%{pam_version}
|
Requires: pam >= 0:%{pam_version}
|
||||||
@ -130,6 +132,7 @@ Development files and headers for writing GDM greeters.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1 -b .systemd
|
||||||
%patch98 -p1 -b .plymouth
|
%patch98 -p1 -b .plymouth
|
||||||
|
|
||||||
autoreconf -i -f
|
autoreconf -i -f
|
||||||
@ -372,6 +375,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
|
|||||||
%{_libdir}/girepository-1.0/GdmGreeter-1.0.typelib
|
%{_libdir}/girepository-1.0/GdmGreeter-1.0.typelib
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 5 2012 Matthias Clasen <mclasen@redhat.com> 3.4.0.1-3
|
||||||
|
- Make session unlocking after user switching work
|
||||||
|
|
||||||
* Mon Apr 02 2012 Ray Strode <rstrode@redhat.com> 3.4.0.1-2
|
* Mon Apr 02 2012 Ray Strode <rstrode@redhat.com> 3.4.0.1-2
|
||||||
- Move pam_gnome_keyring after XDG_RUNTIME_DIR is setup
|
- Move pam_gnome_keyring after XDG_RUNTIME_DIR is setup
|
||||||
Resolves: #809152
|
Resolves: #809152
|
||||||
|
Loading…
Reference in New Issue
Block a user