Fix empty user list.
This commit is contained in:
parent
e9a3329054
commit
c2e00d9e5e
35
fix-empty-userlist.patch
Normal file
35
fix-empty-userlist.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
From 4f63038e588f334ec062a38c620fcf8f8c0fa222 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ray Strode <rstrode@redhat.com>
|
||||||
|
Date: Tue, 22 Feb 2011 17:42:35 -0500
|
||||||
|
Subject: [PATCH] user-chooser-widget: zero idle id when done with it
|
||||||
|
|
||||||
|
Because we weren't zeroing it, it could never get queued
|
||||||
|
after it finished its first run.
|
||||||
|
|
||||||
|
This fixes a bug that prevents the users from showing up
|
||||||
|
in the user list.
|
||||||
|
---
|
||||||
|
gui/simple-greeter/gdm-user-chooser-widget.c | 7 ++++++-
|
||||||
|
1 files changed, 6 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/gui/simple-greeter/gdm-user-chooser-widget.c b/gui/simple-greeter/gdm-user-chooser-widget.c
|
||||||
|
index 7b0445c..be756a6 100644
|
||||||
|
--- a/gui/simple-greeter/gdm-user-chooser-widget.c
|
||||||
|
+++ b/gui/simple-greeter/gdm-user-chooser-widget.c
|
||||||
|
@@ -873,7 +873,12 @@ add_users (GdmUserChooserWidget *widget)
|
||||||
|
gdm_chooser_widget_loaded (GDM_CHOOSER_WIDGET (widget));
|
||||||
|
}
|
||||||
|
|
||||||
|
- return (widget->priv->users_to_add != NULL);
|
||||||
|
+ if (widget->priv->users_to_add == NULL) {
|
||||||
|
+ widget->priv->add_users_idle_id = 0;
|
||||||
|
+ return FALSE;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ return TRUE;
|
||||||
|
}
|
||||||
|
|
||||||
|
static void
|
||||||
|
--
|
||||||
|
1.7.4.1
|
||||||
|
|
8
gdm.spec
8
gdm.spec
@ -15,7 +15,7 @@
|
|||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.91.6
|
Version: 2.91.6
|
||||||
Release: 10%{?dist}
|
Release: 11%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -95,6 +95,7 @@ Patch3: fix-theme-related-crash.patch
|
|||||||
Patch4: fix-crasher.patch
|
Patch4: fix-crasher.patch
|
||||||
Patch5: add-session-chooser.patch
|
Patch5: add-session-chooser.patch
|
||||||
Patch6: move-to-accounts-library.patch
|
Patch6: move-to-accounts-library.patch
|
||||||
|
Patch7: fix-empty-user-list.patch
|
||||||
|
|
||||||
Patch96: gdm-multistack.patch
|
Patch96: gdm-multistack.patch
|
||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
@ -130,6 +131,7 @@ The GDM fingerprint plugin provides functionality necessary to use a fingerprint
|
|||||||
%patch4 -p1 -b .fix-crasher
|
%patch4 -p1 -b .fix-crasher
|
||||||
%patch5 -p1 -b .add-session-chooser
|
%patch5 -p1 -b .add-session-chooser
|
||||||
%patch6 -p1 -b .move-to-accounts-library
|
%patch6 -p1 -b .move-to-accounts-library
|
||||||
|
%patch7 -p1 -b .fix-empty-user-list
|
||||||
%patch96 -p1 -b .multistack
|
%patch96 -p1 -b .multistack
|
||||||
%patch99 -p1 -b .fedora-logo
|
%patch99 -p1 -b .fedora-logo
|
||||||
|
|
||||||
@ -369,6 +371,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/ull || :
|
|||||||
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 22 2011 Ray Strode <rstrode@redhat.com> 2.91.6-11
|
||||||
|
- Dropping async code didn't work. The bug was still
|
||||||
|
around. This commit should fix it.
|
||||||
|
|
||||||
* Fri Feb 18 2011 Ray Strode <rstrode@redhat.com> 2.91.6-10
|
* Fri Feb 18 2011 Ray Strode <rstrode@redhat.com> 2.91.6-10
|
||||||
- Fix user list async bugs by dropping async code and
|
- Fix user list async bugs by dropping async code and
|
||||||
moving to accounts service library
|
moving to accounts service library
|
||||||
|
Loading…
Reference in New Issue
Block a user