Add patch to fix environment setup
https://gitlab.gnome.org/GNOME/gdm/merge_requests/82 See also #1746563
This commit is contained in:
parent
f4c8058170
commit
c28d9cf8b0
@ -0,0 +1,41 @@
|
|||||||
|
From b7ba3700aa9e04c4c550ae99af1c4a1b0cdb412d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Benjamin Berg <bberg@redhat.com>
|
||||||
|
Date: Wed, 4 Sep 2019 14:34:28 +0200
|
||||||
|
Subject: [PATCH] Revert "gdm-{wayland,x}-session: allow users to overwrite
|
||||||
|
environment"
|
||||||
|
|
||||||
|
This reverts commit 2802e92d27450d86d81b6356dd532ec80e797223.
|
||||||
|
---
|
||||||
|
daemon/gdm-wayland-session.c | 2 +-
|
||||||
|
daemon/gdm-x-session.c | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/daemon/gdm-wayland-session.c b/daemon/gdm-wayland-session.c
|
||||||
|
index 79922664..35679b19 100644
|
||||||
|
--- a/daemon/gdm-wayland-session.c
|
||||||
|
+++ b/daemon/gdm-wayland-session.c
|
||||||
|
@@ -320,7 +320,7 @@ spawn_session (State *state,
|
||||||
|
continue;
|
||||||
|
}
|
||||||
|
|
||||||
|
- g_subprocess_launcher_setenv (launcher, environment_entry[0], environment_entry[1], TRUE);
|
||||||
|
+ g_subprocess_launcher_setenv (launcher, environment_entry[0], environment_entry[1], FALSE);
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Don't allow session specific environment variables from earlier sessions to
|
||||||
|
diff --git a/daemon/gdm-x-session.c b/daemon/gdm-x-session.c
|
||||||
|
index 9714da3e..58865a6c 100644
|
||||||
|
--- a/daemon/gdm-x-session.c
|
||||||
|
+++ b/daemon/gdm-x-session.c
|
||||||
|
@@ -635,7 +635,7 @@ spawn_session (State *state,
|
||||||
|
continue;
|
||||||
|
}
|
||||||
|
|
||||||
|
- g_subprocess_launcher_setenv (launcher, environment_entry[0], environment_entry[1], TRUE);
|
||||||
|
+ g_subprocess_launcher_setenv (launcher, environment_entry[0], environment_entry[1], FALSE);
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Don't allow session specific environment variables from earlier sessions to
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
8
gdm.spec
8
gdm.spec
@ -10,7 +10,7 @@
|
|||||||
Name: gdm
|
Name: gdm
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 3.33.90
|
Version: 3.33.90
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -20,6 +20,7 @@ Source1: org.gnome.login-screen.gschema.override
|
|||||||
Patch0: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
|
Patch0: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
|
||||||
|
|
||||||
Patch10001: 0001-data-disable-wayland-if-modesetting-is-disabled.patch
|
Patch10001: 0001-data-disable-wayland-if-modesetting-is-disabled.patch
|
||||||
|
Patch10002: 0001-Revert-gdm-wayland-x-session-allow-users-to-overwrit.patch
|
||||||
|
|
||||||
Patch99: system-dconf.patch
|
Patch99: system-dconf.patch
|
||||||
|
|
||||||
@ -311,6 +312,11 @@ fi
|
|||||||
%{_libdir}/pkgconfig/gdm-pam-extensions.pc
|
%{_libdir}/pkgconfig/gdm-pam-extensions.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 04 2019 Benjamin Berg <bberg@redhat.com> - 1:3.33.90-4
|
||||||
|
- Add patch to fix environment setup
|
||||||
|
https://gitlab.gnome.org/GNOME/gdm/merge_requests/82
|
||||||
|
See also #1746563
|
||||||
|
|
||||||
* Mon Aug 26 2019 Adam Williamson <awilliam@redhat.com> - 1:3.33.90-3
|
* Mon Aug 26 2019 Adam Williamson <awilliam@redhat.com> - 1:3.33.90-3
|
||||||
- Drop patch from -2, better fix was applied to systemd
|
- Drop patch from -2, better fix was applied to systemd
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user