Fix autologin crash
This commit is contained in:
parent
2139ff72ed
commit
bf0ae7e803
29
fix-autologin.patch
Normal file
29
fix-autologin.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From fb47acb592e7e201e5ccedbfbae7d32d8cf254f2 Mon Sep 17 00:00:00 2001
|
||||
From: Ray Strode <rstrode@redhat.com>
|
||||
Date: Wed, 9 Mar 2011 15:52:26 -0500
|
||||
Subject: [PATCH] daemon: fix crash with autologin
|
||||
|
||||
We were using the wrong function prototype which was leading
|
||||
to crashes.
|
||||
---
|
||||
daemon/gdm-session-worker.c | 4 +++-
|
||||
1 files changed, 3 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/daemon/gdm-session-worker.c b/daemon/gdm-session-worker.c
|
||||
index 299c8be..15ec0e9 100644
|
||||
--- a/daemon/gdm-session-worker.c
|
||||
+++ b/daemon/gdm-session-worker.c
|
||||
@@ -2094,7 +2094,9 @@ save_account_details_now (GdmSessionWorker *worker)
|
||||
}
|
||||
|
||||
static void
|
||||
-on_settings_is_loaded_changed (GdmSessionWorker *worker)
|
||||
+on_settings_is_loaded_changed (GdmSessionSettings *user_settings,
|
||||
+ GParamSpec *pspec,
|
||||
+ GdmSessionWorker *worker)
|
||||
{
|
||||
if (!gdm_session_settings_is_loaded (worker->priv->user_settings)) {
|
||||
return;
|
||||
--
|
||||
1.7.4.1
|
||||
|
7
gdm.spec
7
gdm.spec
@ -15,7 +15,7 @@
|
||||
Summary: The GNOME Display Manager
|
||||
Name: gdm
|
||||
Version: 2.91.93
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv2+
|
||||
Group: User Interface/X
|
||||
@ -87,6 +87,7 @@ Provides: service(graphical-login) = %{name}
|
||||
Requires: audit-libs >= %{libauditver}
|
||||
|
||||
Patch2: plymouth.patch
|
||||
Patch3: fix-autologin.patch
|
||||
|
||||
Patch96: gdm-multistack.patch
|
||||
# Fedora-specific
|
||||
@ -117,6 +118,7 @@ The GDM fingerprint plugin provides functionality necessary to use a fingerprint
|
||||
%prep
|
||||
%setup -q
|
||||
%patch2 -p1 -b .plymouth
|
||||
%patch3 -p1 -b .fix-autologin
|
||||
%patch96 -p1 -b .multistack
|
||||
%patch99 -p1 -b .fedora-logo
|
||||
|
||||
@ -356,6 +358,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/ull || :
|
||||
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
||||
|
||||
%changelog
|
||||
* Wed Mar 09 2011 Ray Strode <rstrode@redhat.com> 2.91.93-2
|
||||
- Fix autologin crash
|
||||
|
||||
* Tue Mar 08 2011 Ray Strode <rstrode@redhat.com> 2.91.93-1
|
||||
- Update to 2.91.93
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user