don't call render_frame if there's no frame
If the theme lacks a frame gtk_render_frame will throw a fit and make the greeter nose dive.
This commit is contained in:
parent
99a446b427
commit
b9e0d7554b
31
fix-theme-related-crash.patch
Normal file
31
fix-theme-related-crash.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From 6bb88258c9ce7c9b2a0477c697d64e2a36f42dfd Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ray Strode <rstrode@redhat.com>
|
||||||
|
Date: Fri, 4 Feb 2011 15:06:11 -0500
|
||||||
|
Subject: [PATCH] greeter: don't call render_frame if there's no frame
|
||||||
|
|
||||||
|
If the theme lacks a frame gtk_render_frame will throw
|
||||||
|
a fit and make the greeter nose dive.
|
||||||
|
---
|
||||||
|
gui/simple-greeter/gdm-scrollable-widget.c | 6 ++++--
|
||||||
|
1 files changed, 4 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/gui/simple-greeter/gdm-scrollable-widget.c b/gui/simple-greeter/gdm-scrollable-widget.c
|
||||||
|
index 8a9ea25..1f8e807 100644
|
||||||
|
--- a/gui/simple-greeter/gdm-scrollable-widget.c
|
||||||
|
+++ b/gui/simple-greeter/gdm-scrollable-widget.c
|
||||||
|
@@ -598,8 +598,10 @@ gdm_scrollable_widget_draw (GtkWidget *widget,
|
||||||
|
height = widget_allocation.height;
|
||||||
|
height -= padding.top + padding.bottom;
|
||||||
|
|
||||||
|
- gtk_render_frame (context, cr,
|
||||||
|
- x, y, width, height);
|
||||||
|
+ if (width > 0 && height > 0) {
|
||||||
|
+ gtk_render_frame (context, cr,
|
||||||
|
+ x, y, width, height);
|
||||||
|
+ }
|
||||||
|
|
||||||
|
return GTK_WIDGET_CLASS (gdm_scrollable_widget_parent_class)->draw (widget, cr);
|
||||||
|
}
|
||||||
|
--
|
||||||
|
1.7.4
|
||||||
|
|
@ -1,15 +0,0 @@
|
|||||||
diff -up gdm-2.28.0/data/session-setup.entries.bubble-location gdm-2.28.0/data/session-setup.entries
|
|
||||||
--- gdm-2.28.0/data/session-setup.entries.bubble-location 2009-10-09 09:38:01.315620045 -0400
|
|
||||||
+++ gdm-2.28.0/data/session-setup.entries 2009-10-09 09:39:11.354874396 -0400
|
|
||||||
@@ -755,5 +755,11 @@
|
|
||||||
<string>/bin/true</string>
|
|
||||||
</value>
|
|
||||||
</entry>
|
|
||||||
+ <entry>
|
|
||||||
+ <key>/apps/notification-daemon/popup_location</key>
|
|
||||||
+ <value>
|
|
||||||
+ <string>bottom_right</string>
|
|
||||||
+ </value>
|
|
||||||
+ </entry>
|
|
||||||
</entrylist>
|
|
||||||
</gconfentryfile>
|
|
12
gdm.spec
12
gdm.spec
@ -15,7 +15,7 @@
|
|||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.91.6
|
Version: 2.91.6
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -90,11 +90,10 @@ Provides: service(graphical-login) = %{name}
|
|||||||
Requires: audit-libs >= %{libauditver}
|
Requires: audit-libs >= %{libauditver}
|
||||||
|
|
||||||
Patch2: plymouth.patch
|
Patch2: plymouth.patch
|
||||||
|
Patch3: fix-theme-related-crash.patch
|
||||||
|
|
||||||
Patch96: gdm-multistack.patch
|
Patch96: gdm-multistack.patch
|
||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
Patch97: gdm-bubble-location.patch
|
|
||||||
Patch98: tray-padding.patch
|
|
||||||
Patch99: gdm-2.23.1-fedora-logo.patch
|
Patch99: gdm-2.23.1-fedora-logo.patch
|
||||||
|
|
||||||
%package plugin-smartcard
|
%package plugin-smartcard
|
||||||
@ -122,9 +121,8 @@ The GDM fingerprint plugin provides functionality necessary to use a fingerprint
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch2 -p1 -b .plymouth
|
%patch2 -p1 -b .plymouth
|
||||||
|
%patch3 -p1 -b .fix-theme-related-crash
|
||||||
%patch96 -p1 -b .multistack
|
%patch96 -p1 -b .multistack
|
||||||
%patch97 -p1 -b .bubble-location
|
|
||||||
%patch98 -p1 -b .tray-padding
|
|
||||||
%patch99 -p1 -b .fedora-logo
|
%patch99 -p1 -b .fedora-logo
|
||||||
|
|
||||||
autoreconf -i -f
|
autoreconf -i -f
|
||||||
@ -363,6 +361,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/ull || :
|
|||||||
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 04 2011 Ray Strode <rstrode@redhat.com> 2.91.6-2
|
||||||
|
- Drop some unimportant patches
|
||||||
|
- Attempt to fix bug 674978 (theme related crash)
|
||||||
|
|
||||||
* Wed Feb 02 2011 Ray Strode <rstrode@redhat.com> 2.91.6-1
|
* Wed Feb 02 2011 Ray Strode <rstrode@redhat.com> 2.91.6-1
|
||||||
- Update to 2.91.6
|
- Update to 2.91.6
|
||||||
|
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
diff -up gdm-2.28.1/data/session-setup.entries.tray-padding gdm-2.28.1/data/session-setup.entries
|
|
||||||
--- gdm-2.28.1/data/session-setup.entries.tray-padding 2009-10-31 18:07:29.437799765 -0400
|
|
||||||
+++ gdm-2.28.1/data/session-setup.entries 2009-10-31 18:08:20.758793871 -0400
|
|
||||||
@@ -761,5 +761,11 @@
|
|
||||||
<string>bottom_right</string>
|
|
||||||
</value>
|
|
||||||
</entry>
|
|
||||||
+ <entry>
|
|
||||||
+ <key>/apps/notification_area_applet/prefs/padding</key>
|
|
||||||
+ <value>
|
|
||||||
+ <int>3</int>
|
|
||||||
+ </value>
|
|
||||||
+ </entry>
|
|
||||||
</entrylist>
|
|
||||||
</gconfentryfile>
|
|
Loading…
Reference in New Issue
Block a user