- Fix crash from language dialog
This commit is contained in:
parent
e1ea6b93ab
commit
b71ee620ec
12
gdm-2.23.92-fix-crash.patch
Normal file
12
gdm-2.23.92-fix-crash.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
--- gdm-2.23.92/gui/simple-greeter/gdm-option-widget.c 2008-08-26 15:03:59.000000000 -0400
|
||||||
|
+++ foo/gui/simple-greeter/gdm-option-widget.c 2008-09-19 09:57:30.000000000 -0400
|
||||||
|
@@ -148,7 +148,8 @@
|
||||||
|
model = GTK_TREE_MODEL (widget->priv->list_store);
|
||||||
|
item_id = NULL;
|
||||||
|
|
||||||
|
- if (widget->priv->active_row == NULL) {
|
||||||
|
+ if (widget->priv->active_row == NULL ||
|
||||||
|
+ !gtk_tree_row_reference_valid (widget->priv->active_row)) {
|
||||||
|
return NULL;
|
||||||
|
}
|
||||||
|
|
7
gdm.spec
7
gdm.spec
@ -16,7 +16,7 @@
|
|||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.23.92
|
Version: 2.23.92
|
||||||
Release: 8%{?dist}
|
Release: 9%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -89,6 +89,7 @@ Patch5: data-leak.patch
|
|||||||
Patch6: ssid-leak.patch
|
Patch6: ssid-leak.patch
|
||||||
Patch7: gdm-2.23.92-filter-dupes-from-lang-list.patch
|
Patch7: gdm-2.23.92-filter-dupes-from-lang-list.patch
|
||||||
Patch8: gdm-2.23.92-another-locale-fixup.patch
|
Patch8: gdm-2.23.92-another-locale-fixup.patch
|
||||||
|
Patch9: gdm-2.23.92-fix-crash.patch
|
||||||
|
|
||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
Patch99: gdm-2.23.1-fedora-logo.patch
|
Patch99: gdm-2.23.1-fedora-logo.patch
|
||||||
@ -118,6 +119,7 @@ multiple simulanteous logged in users.
|
|||||||
%patch6 -p1 -b .ssid-leak
|
%patch6 -p1 -b .ssid-leak
|
||||||
%patch7 -p1 -b .filter-dupes-from-lang-list
|
%patch7 -p1 -b .filter-dupes-from-lang-list
|
||||||
%patch8 -p1 -b .another-locale-fixup
|
%patch8 -p1 -b .another-locale-fixup
|
||||||
|
%patch9 -p1 -b .fix-crash
|
||||||
|
|
||||||
%patch99 -p1 -b .fedora-logo
|
%patch99 -p1 -b .fedora-logo
|
||||||
|
|
||||||
@ -320,6 +322,9 @@ fi
|
|||||||
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 19 2008 Ray Strode <rstrode@redhat.com> - 1:2.23.92-9
|
||||||
|
- Fix crash from language dialog
|
||||||
|
|
||||||
* Wed Sep 17 2008 Ray Strode <rstrode@redhat.com> - 1:2.23.92-8
|
* Wed Sep 17 2008 Ray Strode <rstrode@redhat.com> - 1:2.23.92-8
|
||||||
- canonicalize codeset to match output of locale -m
|
- canonicalize codeset to match output of locale -m
|
||||||
- filter duplicates from language list
|
- filter duplicates from language list
|
||||||
|
Loading…
Reference in New Issue
Block a user