- Load session and language settings when username is read on Other user
This commit is contained in:
parent
bb6bd7d2f4
commit
939ff0135d
38
gdm-2.26.0-load-settings-for-other-user.patch
Normal file
38
gdm-2.26.0-load-settings-for-other-user.patch
Normal file
@ -0,0 +1,38 @@
|
||||
Index: daemon/gdm-session-worker.c
|
||||
===================================================================
|
||||
--- a/daemon/gdm-session-worker.c (revision 6793)
|
||||
+++ b/daemon/gdm-session-worker.c (working copy)
|
||||
@@ -637,16 +637,6 @@ gdm_session_worker_update_username (GdmS
|
||||
|
||||
gdm_session_auditor_set_username (worker->priv->auditor, worker->priv->username);
|
||||
|
||||
- /* We have a new username to try. If we haven't been able to
|
||||
- * read user settings up until now, then give it a go now
|
||||
- * (see the comment in do_setup for rationale on why it's useful
|
||||
- * to keep trying to read settings)
|
||||
- */
|
||||
- if (username != NULL &&
|
||||
- !gdm_session_settings_is_loaded (worker->priv->user_settings)) {
|
||||
- attempt_to_load_user_settings (worker, username);
|
||||
- }
|
||||
-
|
||||
if ((worker->priv->username == username) ||
|
||||
((worker->priv->username != NULL) && (username != NULL) &&
|
||||
(strcmp (worker->priv->username, username) == 0)))
|
||||
@@ -661,6 +651,16 @@ gdm_session_worker_update_username (GdmS
|
||||
send_dbus_string_method (worker->priv->connection,
|
||||
"UsernameChanged",
|
||||
worker->priv->username);
|
||||
+
|
||||
+ /* We have a new username to try. If we haven't been able to
|
||||
+ * read user settings up until now, then give it a go now
|
||||
+ * (see the comment in do_setup for rationale on why it's useful
|
||||
+ * to keep trying to read settings)
|
||||
+ */
|
||||
+ if (worker->priv->username != NULL &&
|
||||
+ !gdm_session_settings_is_loaded (worker->priv->user_settings)) {
|
||||
+ attempt_to_load_user_settings (worker, worker->priv->username);
|
||||
+ }
|
||||
}
|
||||
|
||||
out:
|
9
gdm.spec
9
gdm.spec
@ -15,7 +15,7 @@
|
||||
Summary: The GNOME Display Manager
|
||||
Name: gdm
|
||||
Version: 2.26.0
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv2+
|
||||
Group: User Interface/X
|
||||
@ -98,6 +98,8 @@ Patch16: gdm-2.25.2-dont-depend-on-hostname.patch
|
||||
# http://bugzilla.redhat.com/show_bug.cgi?id=485974
|
||||
Patch17: gdm-2.26.0-clean-up-auth-entries.patch
|
||||
|
||||
Patch18: gdm-2.26.0-load-settings-for-other-user.patch
|
||||
|
||||
# Fedora-specific
|
||||
Patch99: gdm-2.23.1-fedora-logo.patch
|
||||
|
||||
@ -127,6 +129,7 @@ multiple simulanteous logged in users.
|
||||
%patch15 -p1 -b .start-faster
|
||||
%patch16 -p1 -b .dont-depend-on-hostname
|
||||
%patch17 -p1 -b .clean-up-auth-entries
|
||||
%patch18 -p1 -b .load-settings-for-other-user
|
||||
|
||||
%patch99 -p1 -b .fedora-logo
|
||||
|
||||
@ -350,6 +353,10 @@ fi
|
||||
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
||||
|
||||
%changelog
|
||||
* Mon Mar 23 2009 Ray Strode <rstrode@redhat.com> - 1:2.26.0-7
|
||||
- Load session and language settings when username is read on
|
||||
Other user
|
||||
|
||||
* Fri Mar 20 2009 Ray Strode <rstrode@redhat.com> - 1:2.26.0-6
|
||||
- Fix problem in keyboard layout selector (483195)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user