Update previous patch to handle NULL better
This commit is contained in:
parent
9df0c520a1
commit
8fa37622c1
10
gdm.spec
10
gdm.spec
@ -15,7 +15,7 @@
|
|||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.91.4
|
Version: 2.91.4
|
||||||
Release: 2%{?dist}
|
Release: 4%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -90,6 +90,7 @@ Requires: audit-libs >= %{libauditver}
|
|||||||
|
|
||||||
Patch2: plymouth.patch
|
Patch2: plymouth.patch
|
||||||
Patch3: icon-fix.patch
|
Patch3: icon-fix.patch
|
||||||
|
Patch4: icon-ref-issue.patch
|
||||||
|
|
||||||
Patch96: gdm-multistack.patch
|
Patch96: gdm-multistack.patch
|
||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
@ -134,6 +135,7 @@ The GDM fingerprint plugin provides functionality necessary to use a fingerprint
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch2 -p1 -b .plymouth
|
%patch2 -p1 -b .plymouth
|
||||||
%patch3 -p1 -b .icon-fix
|
%patch3 -p1 -b .icon-fix
|
||||||
|
%patch4 -p1 -b .icon-ref-issue
|
||||||
%patch96 -p1 -b .multistack
|
%patch96 -p1 -b .multistack
|
||||||
%patch97 -p1 -b .bubble-location
|
%patch97 -p1 -b .bubble-location
|
||||||
%patch98 -p1 -b .tray-padding
|
%patch98 -p1 -b .tray-padding
|
||||||
@ -375,6 +377,12 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/ull || :
|
|||||||
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 19 2011 Ray Strode <rstrode@redhat.com> 2.91.4-4
|
||||||
|
- Update previous patch to handle NULL better
|
||||||
|
|
||||||
|
* Wed Jan 19 2011 Ray Strode <rstrode@redhat.com> 2.91.4-3
|
||||||
|
- Fix icon ref counting issue
|
||||||
|
|
||||||
* Wed Jan 19 2011 Ray Strode <rstrode@redhat.com> 2.91.4-2
|
* Wed Jan 19 2011 Ray Strode <rstrode@redhat.com> 2.91.4-2
|
||||||
- Be more aggresive about loading icons
|
- Be more aggresive about loading icons
|
||||||
(right now we fail, which combined with fatal criticals
|
(right now we fail, which combined with fatal criticals
|
||||||
|
@ -1,23 +1,28 @@
|
|||||||
From 9663f0e3a47231aa95d076f9177b1e9460715372 Mon Sep 17 00:00:00 2001
|
From 1eb1f09bcfa3f7c3c33da0ef24c5a528e53528cd Mon Sep 17 00:00:00 2001
|
||||||
From: Ray Strode <rstrode@redhat.com>
|
From: Ray Strode <rstrode@redhat.com>
|
||||||
Date: Wed, 19 Jan 2011 13:32:28 -0500
|
Date: Wed, 19 Jan 2011 13:32:28 -0500
|
||||||
Subject: [PATCH] user-chooser-widget: fix ref counting issue on user pixbuf
|
Subject: [PATCH] user-chooser-widget: fix ref counting issue on user pixbuf
|
||||||
|
|
||||||
---
|
---
|
||||||
gui/simple-greeter/gdm-user-chooser-widget.c | 3 ++-
|
gui/simple-greeter/gdm-user-chooser-widget.c | 7 +++++++
|
||||||
1 files changed, 2 insertions(+), 1 deletions(-)
|
1 files changed, 7 insertions(+), 0 deletions(-)
|
||||||
|
|
||||||
diff --git a/gui/simple-greeter/gdm-user-chooser-widget.c b/gui/simple-greeter/gdm-user-chooser-widget.c
|
diff --git a/gui/simple-greeter/gdm-user-chooser-widget.c b/gui/simple-greeter/gdm-user-chooser-widget.c
|
||||||
index 6d03c38..bd2d070 100644
|
index 6d03c38..9447e59 100644
|
||||||
--- a/gui/simple-greeter/gdm-user-chooser-widget.c
|
--- a/gui/simple-greeter/gdm-user-chooser-widget.c
|
||||||
+++ b/gui/simple-greeter/gdm-user-chooser-widget.c
|
+++ b/gui/simple-greeter/gdm-user-chooser-widget.c
|
||||||
@@ -949,7 +949,8 @@ update_icons (GdmChooserWidget *widget,
|
@@ -949,7 +949,14 @@ update_icons (GdmChooserWidget *widget,
|
||||||
IconUpdateData *data)
|
IconUpdateData *data)
|
||||||
{
|
{
|
||||||
if (data->old_icon == *image) {
|
if (data->old_icon == *image) {
|
||||||
- *image = data->new_icon;
|
+ if (*image != NULL) {
|
||||||
+ g_object_unref (*image);
|
+ g_object_unref (*image);
|
||||||
+ *image = g_object_ref (data->new_icon);
|
+ }
|
||||||
|
*image = data->new_icon;
|
||||||
|
+
|
||||||
|
+ if (*image != NULL) {
|
||||||
|
+ g_object_ref (*image);
|
||||||
|
+ }
|
||||||
return TRUE;
|
return TRUE;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user