- Use gethostname() instead of g_get_host_name() when writing out xauth
files, because the hostname may change out from under us and glib caches it.
This commit is contained in:
parent
212f3caa18
commit
8cc3037d7e
@ -210,3 +210,16 @@ index 19432dc..a241f73 100644
|
|||||||
|
|
||||||
G_OBJECT_CLASS (gdm_slave_parent_class)->finalize (object);
|
G_OBJECT_CLASS (gdm_slave_parent_class)->finalize (object);
|
||||||
}
|
}
|
||||||
|
--- a/daemon/gdm-display-access-file.c (revision 6790)
|
||||||
|
+++ b/daemon/gdm-display-access-file.c (working copy)
|
||||||
|
@@ -438,8 +438,9 @@ _get_auth_info_for_display (GdmDisplayAc
|
||||||
|
gdm_display_is_local (display, &is_local, NULL);
|
||||||
|
|
||||||
|
if (is_local) {
|
||||||
|
+ char localhost[HOST_NAME_MAX + 1] = "";
|
||||||
|
*family = FamilyLocal;
|
||||||
|
- *address = g_strdup (g_get_host_name ());
|
||||||
|
+ *address = g_strdup (gethostname (localhost, HOST_NAME_MAX));
|
||||||
|
} else {
|
||||||
|
*family = FamilyWild;
|
||||||
|
gdm_display_get_remote_hostname (display, address, NULL);
|
||||||
|
7
gdm.spec
7
gdm.spec
@ -15,7 +15,7 @@
|
|||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.26.0
|
Version: 2.26.0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -350,6 +350,11 @@ fi
|
|||||||
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 19 2009 Ray Strode <rstrode@redhat.com> - 1:2.26.0-4
|
||||||
|
- Use gethostname() instead of g_get_host_name() when writing
|
||||||
|
out xauth files, because the hostname may change out from
|
||||||
|
under us and glib caches it.
|
||||||
|
|
||||||
* Wed Mar 18 2009 Ray Strode <rstrode@redhat.com> - 1:2.26.0-3
|
* Wed Mar 18 2009 Ray Strode <rstrode@redhat.com> - 1:2.26.0-3
|
||||||
- emit "user-selected" signal for non-user items in the list
|
- emit "user-selected" signal for non-user items in the list
|
||||||
as well.
|
as well.
|
||||||
|
Loading…
Reference in New Issue
Block a user