- Fix language parsing code (bug 502778)
This commit is contained in:
parent
9330658965
commit
8b861d3ebc
22
gdm-2.26.0-fix-lang-regex.patch
Normal file
22
gdm-2.26.0-fix-lang-regex.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
commit 74cdbc6d71120f2d9c91965ead989f68cadb4bac
|
||||||
|
Author: Ray Strode <rstrode@redhat.com>
|
||||||
|
Date: Wed Jun 3 23:52:06 2009 -0400
|
||||||
|
|
||||||
|
Fix language name parsing regex
|
||||||
|
|
||||||
|
It didn't properly escape the "." character so it was allowing
|
||||||
|
any character to be matched instead of just periods.
|
||||||
|
|
||||||
|
diff --git a/gui/simple-greeter/gdm-languages.c b/gui/simple-greeter/gdm-languages.c
|
||||||
|
index 2d862b2..429ba28 100644
|
||||||
|
--- a/gui/simple-greeter/gdm-languages.c
|
||||||
|
+++ b/gui/simple-greeter/gdm-languages.c
|
||||||
|
@@ -123,7 +123,7 @@ gdm_parse_language_name (const char *name,
|
||||||
|
error = NULL;
|
||||||
|
re = g_regex_new ("^(?P<language>[^_.@[:space:]]+)"
|
||||||
|
"(_(?P<territory>[[:upper:]]+))?"
|
||||||
|
- "(.(?P<codeset>[-_0-9a-zA-Z]+))?"
|
||||||
|
+ "(\\.(?P<codeset>[-_0-9a-zA-Z]+))?"
|
||||||
|
"(@(?P<modifier>[[:ascii:]]+))?$",
|
||||||
|
0, 0, &error);
|
||||||
|
if (re == NULL) {
|
9
gdm.spec
9
gdm.spec
@ -16,7 +16,7 @@
|
|||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.26.1
|
Version: 2.26.1
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -98,6 +98,9 @@ Patch13: gdm-system-keyboard.patch
|
|||||||
|
|
||||||
Patch19: gdm-2.26.1-multistack.patch
|
Patch19: gdm-2.26.1-multistack.patch
|
||||||
|
|
||||||
|
# fixed upstream, rh 502778•
|
||||||
|
Patch22: gdm-2.26.0-fix-lang-regex.patch•
|
||||||
|
|
||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
Patch99: gdm-2.23.1-fedora-logo.patch
|
Patch99: gdm-2.23.1-fedora-logo.patch
|
||||||
|
|
||||||
@ -141,6 +144,7 @@ The GDM fingerprint plugin provides functionality necessary to use a fingerprint
|
|||||||
%patch13 -p1 -b .system-keyboard
|
%patch13 -p1 -b .system-keyboard
|
||||||
|
|
||||||
%patch19 -p1 -b .multistack
|
%patch19 -p1 -b .multistack
|
||||||
|
%patch22 -p1 -b .fix-lang-regex
|
||||||
|
|
||||||
%patch99 -p1 -b .fedora-logo
|
%patch99 -p1 -b .fedora-logo
|
||||||
|
|
||||||
@ -382,6 +386,9 @@ fi
|
|||||||
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 03 2009 Ray Strode <rstrode@redhat.com> - 1:2.26.1-5
|
||||||
|
- Fix language parsing code (bug 502778)
|
||||||
|
|
||||||
* Mon Apr 27 2009 Matthias Clasen <mclasen@redhat.com> - 1:2.26.1-4
|
* Mon Apr 27 2009 Matthias Clasen <mclasen@redhat.com> - 1:2.26.1-4
|
||||||
- Don't drop schemas translations from po files
|
- Don't drop schemas translations from po files
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user