- Add a lame patch in the off chance it might work around a gcc bug on ppc:
unable to find register to spill in class 'LINK_OR_CTR_REGS' Probably won't work.
This commit is contained in:
parent
bf128e376a
commit
8aac46388e
27
gdm-2.25.2-maybe-work-around-gcc-bug.patch
Normal file
27
gdm-2.25.2-maybe-work-around-gcc-bug.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
diff -up gdm-2.25.2/gui/simple-greeter/gdm-chooser-widget.c.maybe-work-around-gcc-bug gdm-2.25.2/gui/simple-greeter/gdm-chooser-widget.c
|
||||||
|
--- gdm-2.25.2/gui/simple-greeter/gdm-chooser-widget.c.maybe-work-around-gcc-bug 2009-03-12 15:19:51.102176587 -0400
|
||||||
|
+++ gdm-2.25.2/gui/simple-greeter/gdm-chooser-widget.c 2009-03-12 15:20:57.411172890 -0400
|
||||||
|
@@ -2311,6 +2311,7 @@ stop_timer (GdmChooserWidget *widget,
|
||||||
|
GtkTreeModel *model;
|
||||||
|
GtkTreePath *path;
|
||||||
|
GtkTreeIter iter;
|
||||||
|
+ volatile double zero = 0.0;
|
||||||
|
|
||||||
|
model = GTK_TREE_MODEL (widget->priv->list_store);
|
||||||
|
|
||||||
|
@@ -2320,12 +2321,12 @@ stop_timer (GdmChooserWidget *widget,
|
||||||
|
|
||||||
|
gtk_list_store_set (widget->priv->list_store, &iter,
|
||||||
|
CHOOSER_TIMER_START_TIME_COLUMN,
|
||||||
|
- 0.0, -1);
|
||||||
|
+ zero, -1);
|
||||||
|
gtk_list_store_set (widget->priv->list_store, &iter,
|
||||||
|
CHOOSER_TIMER_DURATION_COLUMN,
|
||||||
|
- 0.0, -1);
|
||||||
|
+ zero, -1);
|
||||||
|
gtk_list_store_set (widget->priv->list_store, &iter,
|
||||||
|
- CHOOSER_TIMER_VALUE_COLUMN, 0.0, -1);
|
||||||
|
+ CHOOSER_TIMER_VALUE_COLUMN, zero, -1);
|
||||||
|
|
||||||
|
widget->priv->number_of_active_timers--;
|
||||||
|
if (widget->priv->number_of_active_timers == 0) {
|
10
gdm.spec
10
gdm.spec
@ -15,7 +15,7 @@
|
|||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.25.2
|
Version: 2.25.2
|
||||||
Release: 18%{?dist}
|
Release: 19%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -94,6 +94,7 @@ Patch14: gdm-2.25.2-multistack-but-boring.patch
|
|||||||
Patch15: gdm-2.25.2-start-faster.patch
|
Patch15: gdm-2.25.2-start-faster.patch
|
||||||
|
|
||||||
Patch16: gdm-2.25.2-use-resolvable-hostname.patch
|
Patch16: gdm-2.25.2-use-resolvable-hostname.patch
|
||||||
|
Patch17: gdm-2.25.2-maybe-work-around-gcc-bug.patch
|
||||||
|
|
||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
Patch99: gdm-2.23.1-fedora-logo.patch
|
Patch99: gdm-2.23.1-fedora-logo.patch
|
||||||
@ -123,6 +124,7 @@ multiple simulanteous logged in users.
|
|||||||
%patch14 -p1 -b .multistack-but-boring
|
%patch14 -p1 -b .multistack-but-boring
|
||||||
%patch15 -p1 -b .start-faster
|
%patch15 -p1 -b .start-faster
|
||||||
%patch16 -p1 -b .use-resolvable-hostname
|
%patch16 -p1 -b .use-resolvable-hostname
|
||||||
|
%patch17 -p1 -b .maybe-work-around-gcc-bug
|
||||||
|
|
||||||
%patch99 -p1 -b .fedora-logo
|
%patch99 -p1 -b .fedora-logo
|
||||||
|
|
||||||
@ -346,6 +348,12 @@ fi
|
|||||||
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 12 2009 Ray Strode <rstrode@redhat.com> - 1:2.25.2-19
|
||||||
|
- Add a lame patch in the off chance it might work around a
|
||||||
|
gcc bug on ppc:
|
||||||
|
unable to find register to spill in class 'LINK_OR_CTR_REGS'
|
||||||
|
Probably won't work.
|
||||||
|
|
||||||
* Thu Mar 12 2009 Ray Strode <rstrode@redhat.com> - 1:2.25.2-18
|
* Thu Mar 12 2009 Ray Strode <rstrode@redhat.com> - 1:2.25.2-18
|
||||||
- Add Requires: libXau >= 1.0.4-4 to use localhost in xauth cookies
|
- Add Requires: libXau >= 1.0.4-4 to use localhost in xauth cookies
|
||||||
- Use localhost instead of g_get_host_name ()
|
- Use localhost instead of g_get_host_name ()
|
||||||
|
Loading…
Reference in New Issue
Block a user