Fix autologin
This commit is contained in:
parent
481eda291a
commit
860c18d9bb
35
fix-auto-login.patch
Normal file
35
fix-auto-login.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From aafa4070f2905c4848091a78422210951775cd9a Mon Sep 17 00:00:00 2001
|
||||
From: Ray Strode <rstrode@redhat.com>
|
||||
Date: Thu, 6 Sep 2012 18:20:05 -0400
|
||||
Subject: [PATCH] slave: fix autologin
|
||||
|
||||
An inverted condition in the wants_autologin function means we tried
|
||||
to start greeter when autologin is runnings.
|
||||
|
||||
Since autologin is usually much faster than loading GL/gnome-shell, this bug
|
||||
is sort of spotty to reproduce.
|
||||
|
||||
This commit changes the "delay > 0" check to "delay == 0" which is a
|
||||
correct indicator of autologin.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=682465
|
||||
---
|
||||
daemon/gdm-simple-slave.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/daemon/gdm-simple-slave.c b/daemon/gdm-simple-slave.c
|
||||
index b646b78..563f6ed 100644
|
||||
--- a/daemon/gdm-simple-slave.c
|
||||
+++ b/daemon/gdm-simple-slave.c
|
||||
@@ -1215,7 +1215,7 @@ wants_autologin (GdmSimpleSlave *slave)
|
||||
/* FIXME: handle wait-for-go */
|
||||
|
||||
gdm_slave_get_timed_login_details (GDM_SLAVE (slave), &enabled, NULL, &delay);
|
||||
- return enabled && delay > 0;
|
||||
+ return enabled && delay == 0;
|
||||
}
|
||||
|
||||
#define INITIAL_SETUP_TRIGGER_FILE LOCALSTATEDIR "/lib/gdm/run-initial-setup"
|
||||
--
|
||||
1.7.12
|
||||
|
6
gdm.spec
6
gdm.spec
@ -97,6 +97,8 @@ Provides: gdm-plugin-smartcard = %{epoch}:%{version}-%{release}
|
||||
Obsoletes: gdm-plugin-fingerprint < 1:3.2.1
|
||||
Provides: gdm-plugin-fingerprint = %{epoch}:%{version}-%{release}
|
||||
|
||||
Patch0: fix-auto-login.patch
|
||||
|
||||
%package libs
|
||||
Summary: Client-side library to talk to gdm
|
||||
Group: Development/Libraries
|
||||
@ -124,6 +126,7 @@ Development files and headers for writing GDM greeters.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .fix-autologin
|
||||
|
||||
autoreconf -i -f
|
||||
intltoolize -f
|
||||
@ -354,6 +357,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
|
||||
%{_libdir}/girepository-1.0/Gdm-1.0.typelib
|
||||
|
||||
%changelog
|
||||
* Fri Sep 07 2012 Ray Strode <rstrode@redhat.com> 1:3.5.91-1
|
||||
- Fix autologin
|
||||
|
||||
* Thu Sep 06 2012 Richard Hughes <hughsient@gmail.com> - 1:3.5.91-1
|
||||
- Update to 3.5.91
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user