- hide users from userlist that have disabled shells (bug 240148)
This commit is contained in:
parent
6ffaeb1d63
commit
5b62ac2d96
15
gdm-2.18.0-hide-disabled-users.patch
Normal file
15
gdm-2.18.0-hide-disabled-users.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- gdm-2.18.0/gui/gdmuser.c.hide-disabled-users 2007-05-15 11:44:45.000000000 -0400
|
||||||
|
+++ gdm-2.18.0/gui/gdmuser.c 2007-05-15 11:45:34.000000000 -0400
|
||||||
|
@@ -206,6 +206,12 @@
|
||||||
|
gint found = 0;
|
||||||
|
gchar *csh;
|
||||||
|
|
||||||
|
+ if (strcmp (usersh, "/sbin/nologin") == 0 ||
|
||||||
|
+ strcmp (usersh, "/bin/true") == 0 ||
|
||||||
|
+ strcmp (usersh, "/bin/false") == 0) {
|
||||||
|
+ return 0;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
setusershell ();
|
||||||
|
|
||||||
|
while ((csh = getusershell ()) != NULL)
|
9
gdm.spec
9
gdm.spec
@ -17,7 +17,7 @@
|
|||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.18.0
|
Version: 2.18.0
|
||||||
Release: 13%{?dist}
|
Release: 14%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: LGPL/GPL
|
License: LGPL/GPL
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -76,6 +76,8 @@ Patch35: gdm-2.18.0-dont-strcpy-overlapping-strings.patch
|
|||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=426647
|
# http://bugzilla.gnome.org/show_bug.cgi?id=426647
|
||||||
Patch36: gdm-2.18.0-dont-expect-utf8.patch
|
Patch36: gdm-2.18.0-dont-expect-utf8.patch
|
||||||
|
|
||||||
|
Patch37: gdm-2.18.0-hide-disabled-users.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=234567
|
# https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=234567
|
||||||
Patch99: gdm-2.18.0-be-more-verbose.patch
|
Patch99: gdm-2.18.0-be-more-verbose.patch
|
||||||
|
|
||||||
@ -170,6 +172,7 @@ Extra icons / faces for the GNOME Display Manager.
|
|||||||
%patch34 -p1 -b .add-lowres-fix
|
%patch34 -p1 -b .add-lowres-fix
|
||||||
%patch35 -p1 -b .dont-strcpy-overlapping-strings
|
%patch35 -p1 -b .dont-strcpy-overlapping-strings
|
||||||
%patch36 -p1 -b .dont-expect-utf8
|
%patch36 -p1 -b .dont-expect-utf8
|
||||||
|
%patch37 -p1 -b hide-disabled-users
|
||||||
%patch99 -p1 -b .be-more-verbose
|
%patch99 -p1 -b .be-more-verbose
|
||||||
%patch100 -p1 -b .keyboard
|
%patch100 -p1 -b .keyboard
|
||||||
|
|
||||||
@ -394,6 +397,10 @@ fi
|
|||||||
%{_datadir}/pixmaps/faces/extras/*.jpg
|
%{_datadir}/pixmaps/faces/extras/*.jpg
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 15 2007 Ray Strode <rstrode@redhat.com> - 1:2.18.0-14
|
||||||
|
- hide users from userlist that have disabled shells
|
||||||
|
(bug 240148)
|
||||||
|
|
||||||
* Thu May 10 2007 Matthias Clasen <mclasen@redhat.com> - 1:2.18.0-13
|
* Thu May 10 2007 Matthias Clasen <mclasen@redhat.com> - 1:2.18.0-13
|
||||||
- Follow packaging guidelines for scrollkeeper dependencies
|
- Follow packaging guidelines for scrollkeeper dependencies
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user