grr, syslog missing
This commit is contained in:
parent
81bc226e49
commit
4e26291f0f
@ -1,5 +1,5 @@
|
|||||||
--- gdm-2.19.1/configure.ac.security-tokens 2007-05-21 15:52:58.000000000 -0400
|
--- gdm-2.19.1/configure.ac.security-tokens 2007-05-21 16:04:51.000000000 -0400
|
||||||
+++ gdm-2.19.1/configure.ac 2007-05-21 15:52:58.000000000 -0400
|
+++ gdm-2.19.1/configure.ac 2007-05-21 16:04:51.000000000 -0400
|
||||||
@@ -20,6 +20,7 @@ LIBRSVG_REQUIRED=1.1.1
|
@@ -20,6 +20,7 @@ LIBRSVG_REQUIRED=1.1.1
|
||||||
LIBXML_REQUIRED=2.4.12
|
LIBXML_REQUIRED=2.4.12
|
||||||
LIBART_REQUIRED=2.3.11
|
LIBART_REQUIRED=2.3.11
|
||||||
@ -18,13 +18,13 @@
|
|||||||
AC_SUBST(DAEMON_LIBS)
|
AC_SUBST(DAEMON_LIBS)
|
||||||
|
|
||||||
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
|
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
|
||||||
+++ gdm-2.19.1/config/securitytokens.conf.in 2007-05-21 15:52:58.000000000 -0400
|
+++ gdm-2.19.1/config/securitytokens.conf.in 2007-05-21 16:04:51.000000000 -0400
|
||||||
@@ -0,0 +1,3 @@
|
@@ -0,0 +1,3 @@
|
||||||
+[SecurityTokens]
|
+[SecurityTokens]
|
||||||
+Enable=true
|
+Enable=true
|
||||||
+#Driver=@libdir@/pkcs11/libcoolkeypk11.so
|
+#Driver=@libdir@/pkcs11/libcoolkeypk11.so
|
||||||
--- gdm-2.19.1/config/Makefile.am.security-tokens 2007-05-13 22:08:25.000000000 -0400
|
--- gdm-2.19.1/config/Makefile.am.security-tokens 2007-05-13 22:08:25.000000000 -0400
|
||||||
+++ gdm-2.19.1/config/Makefile.am 2007-05-21 15:52:58.000000000 -0400
|
+++ gdm-2.19.1/config/Makefile.am 2007-05-21 16:04:51.000000000 -0400
|
||||||
@@ -34,9 +34,11 @@ EXTRA_DIST = \
|
@@ -34,9 +34,11 @@ EXTRA_DIST = \
|
||||||
XKeepsCrashing \
|
XKeepsCrashing \
|
||||||
gettextfoo.h \
|
gettextfoo.h \
|
||||||
@ -87,8 +87,8 @@
|
|||||||
|
|
||||||
$(INSTALL_SCRIPT) $(srcdir)/XKeepsCrashing $(DESTDIR)$(confdir)/XKeepsCrashing
|
$(INSTALL_SCRIPT) $(srcdir)/XKeepsCrashing $(DESTDIR)$(confdir)/XKeepsCrashing
|
||||||
$(INSTALL_SCRIPT) Xsession $(DESTDIR)$(confdir)/Xsession
|
$(INSTALL_SCRIPT) Xsession $(DESTDIR)$(confdir)/Xsession
|
||||||
--- gdm-2.19.1/config/gdm.conf.in.security-tokens 2007-05-21 15:52:58.000000000 -0400
|
--- gdm-2.19.1/config/gdm.conf.in.security-tokens 2007-05-21 16:04:51.000000000 -0400
|
||||||
+++ gdm-2.19.1/config/gdm.conf.in 2007-05-21 15:52:58.000000000 -0400
|
+++ gdm-2.19.1/config/gdm.conf.in 2007-05-21 16:04:51.000000000 -0400
|
||||||
@@ -239,6 +239,10 @@ AlwaysLoginCurrentSession=true
|
@@ -239,6 +239,10 @@ AlwaysLoginCurrentSession=true
|
||||||
# kills it. 10 seconds should be long enough for X, but Xgl may need 20 or 25.
|
# kills it. 10 seconds should be long enough for X, but Xgl may need 20 or 25.
|
||||||
GdmXserverTimeout=10
|
GdmXserverTimeout=10
|
||||||
@ -100,9 +100,17 @@
|
|||||||
[security]
|
[security]
|
||||||
# Allow root to login. It makes sense to turn this off for kiosk use, when
|
# Allow root to login. It makes sense to turn this off for kiosk use, when
|
||||||
# you want to minimize the possibility of break in.
|
# you want to minimize the possibility of break in.
|
||||||
--- gdm-2.19.1/daemon/gdm.c.security-tokens 2007-05-21 15:52:58.000000000 -0400
|
--- gdm-2.19.1/daemon/gdm.c.security-tokens 2007-05-21 16:04:51.000000000 -0400
|
||||||
+++ gdm-2.19.1/daemon/gdm.c 2007-05-21 15:53:26.000000000 -0400
|
+++ gdm-2.19.1/daemon/gdm.c 2007-05-21 16:07:29.000000000 -0400
|
||||||
@@ -71,6 +71,8 @@
|
@@ -42,6 +42,7 @@
|
||||||
|
#include <errno.h>
|
||||||
|
#include <locale.h>
|
||||||
|
#include <dirent.h>
|
||||||
|
+#include <syslog.h>
|
||||||
|
|
||||||
|
#ifdef HAVE_CHKAUTHATTR
|
||||||
|
#include <auth_attr.h>
|
||||||
|
@@ -71,6 +72,8 @@
|
||||||
#include "cookie.h"
|
#include "cookie.h"
|
||||||
#include "filecheck.h"
|
#include "filecheck.h"
|
||||||
#include "errorgui.h"
|
#include "errorgui.h"
|
||||||
@ -111,7 +119,7 @@
|
|||||||
|
|
||||||
#include "gdm-socket-protocol.h"
|
#include "gdm-socket-protocol.h"
|
||||||
#include "gdm-daemon-config.h"
|
#include "gdm-daemon-config.h"
|
||||||
@@ -93,6 +95,10 @@ static void gdm_handle_message (GdmConne
|
@@ -93,6 +96,10 @@ static void gdm_handle_message (GdmConne
|
||||||
static void gdm_handle_user_message (GdmConnection *conn,
|
static void gdm_handle_user_message (GdmConnection *conn,
|
||||||
const gchar *msg,
|
const gchar *msg,
|
||||||
gpointer data);
|
gpointer data);
|
||||||
@ -122,7 +130,7 @@
|
|||||||
static void gdm_daemonify (void);
|
static void gdm_daemonify (void);
|
||||||
static void gdm_safe_restart (void);
|
static void gdm_safe_restart (void);
|
||||||
static void gdm_try_logout_action (GdmDisplay *disp);
|
static void gdm_try_logout_action (GdmDisplay *disp);
|
||||||
@@ -1787,6 +1793,8 @@ main (int argc, char *argv[])
|
@@ -1787,6 +1794,8 @@ main (int argc, char *argv[])
|
||||||
gdm_xdmcp_run ();
|
gdm_xdmcp_run ();
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -131,7 +139,7 @@
|
|||||||
/* We always exit via exit (), and sadly we need to g_main_quit ()
|
/* We always exit via exit (), and sadly we need to g_main_quit ()
|
||||||
* at times not knowing if it's this main or a recursive one we're
|
* at times not knowing if it's this main or a recursive one we're
|
||||||
* quitting.
|
* quitting.
|
||||||
@@ -4342,3 +4350,91 @@ gdm_handle_user_message (GdmConnection *
|
@@ -4342,3 +4351,91 @@ gdm_handle_user_message (GdmConnection *
|
||||||
gdm_connection_close (conn);
|
gdm_connection_close (conn);
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
@ -224,7 +232,7 @@
|
|||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
|
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
|
||||||
+++ gdm-2.19.1/daemon/securitytokenmonitor.h 2007-05-21 15:52:58.000000000 -0400
|
+++ gdm-2.19.1/daemon/securitytokenmonitor.h 2007-05-21 16:04:51.000000000 -0400
|
||||||
@@ -0,0 +1,84 @@
|
@@ -0,0 +1,84 @@
|
||||||
+/* securitytokenmonitor.h - monitor for security token insertion and
|
+/* securitytokenmonitor.h - monitor for security token insertion and
|
||||||
+ * removal events
|
+ * removal events
|
||||||
@ -311,7 +319,7 @@
|
|||||||
+G_END_DECLS
|
+G_END_DECLS
|
||||||
+#endif /* SC_SECURITY_TOKEN_MONITOR_H */
|
+#endif /* SC_SECURITY_TOKEN_MONITOR_H */
|
||||||
--- gdm-2.19.1/daemon/Makefile.am.security-tokens 2007-05-13 22:08:25.000000000 -0400
|
--- gdm-2.19.1/daemon/Makefile.am.security-tokens 2007-05-13 22:08:25.000000000 -0400
|
||||||
+++ gdm-2.19.1/daemon/Makefile.am 2007-05-21 15:52:58.000000000 -0400
|
+++ gdm-2.19.1/daemon/Makefile.am 2007-05-21 16:04:51.000000000 -0400
|
||||||
@@ -9,6 +9,7 @@ INCLUDES = \
|
@@ -9,6 +9,7 @@ INCLUDES = \
|
||||||
-DAUTHDIR=\"$(authdir)\" \
|
-DAUTHDIR=\"$(authdir)\" \
|
||||||
-DBINDIR=\"$(bindir)\" \
|
-DBINDIR=\"$(bindir)\" \
|
||||||
@ -332,7 +340,7 @@
|
|||||||
|
|
||||||
XDMCP_SOURCES = \
|
XDMCP_SOURCES = \
|
||||||
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
|
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
|
||||||
+++ gdm-2.19.1/daemon/securitytoken.h 2007-05-21 15:52:58.000000000 -0400
|
+++ gdm-2.19.1/daemon/securitytoken.h 2007-05-21 16:04:51.000000000 -0400
|
||||||
@@ -0,0 +1,94 @@
|
@@ -0,0 +1,94 @@
|
||||||
+/* securitytoken.h - api for reading and writing data to a security token
|
+/* securitytoken.h - api for reading and writing data to a security token
|
||||||
+ *
|
+ *
|
||||||
@ -429,7 +437,7 @@
|
|||||||
+G_END_DECLS
|
+G_END_DECLS
|
||||||
+#endif /* SC_SECURITY_TOKEN_H */
|
+#endif /* SC_SECURITY_TOKEN_H */
|
||||||
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
|
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
|
||||||
+++ gdm-2.19.1/daemon/securitytokenmonitor.c 2007-05-21 15:52:58.000000000 -0400
|
+++ gdm-2.19.1/daemon/securitytokenmonitor.c 2007-05-21 16:04:51.000000000 -0400
|
||||||
@@ -0,0 +1,1743 @@
|
@@ -0,0 +1,1743 @@
|
||||||
+/* securitytokenmonitor.c - monitor for security token insertion and
|
+/* securitytokenmonitor.c - monitor for security token insertion and
|
||||||
+ * removal events
|
+ * removal events
|
||||||
@ -2175,7 +2183,7 @@
|
|||||||
+}
|
+}
|
||||||
+#endif
|
+#endif
|
||||||
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
|
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
|
||||||
+++ gdm-2.19.1/daemon/securitytoken.c 2007-05-21 15:52:58.000000000 -0400
|
+++ gdm-2.19.1/daemon/securitytoken.c 2007-05-21 16:04:51.000000000 -0400
|
||||||
@@ -0,0 +1,680 @@
|
@@ -0,0 +1,680 @@
|
||||||
+/* securitytoken.c - security token
|
+/* securitytoken.c - security token
|
||||||
+ *
|
+ *
|
||||||
|
Loading…
Reference in New Issue
Block a user