- Fix autologin
This commit is contained in:
parent
8bfe35d074
commit
4af82f0ff1
35
0001-Fix-gdm_slave_get_timed_login_details.patch
Normal file
35
0001-Fix-gdm_slave_get_timed_login_details.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
From 9fd603874caa65791cd74aa88daf61f9f196d5c3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ray Strode <rstrode@redhat.com>
|
||||||
|
Date: Fri, 25 Sep 2009 15:07:54 -0400
|
||||||
|
Subject: [PATCH] Fix gdm_slave_get_timed_login_details
|
||||||
|
|
||||||
|
Before it would fail if a NULL username was passed in,
|
||||||
|
breaking autologin on the multi-stack branch.
|
||||||
|
---
|
||||||
|
daemon/gdm-slave.c | 10 ++++++++++
|
||||||
|
1 files changed, 10 insertions(+), 0 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/daemon/gdm-slave.c b/daemon/gdm-slave.c
|
||||||
|
index 7bc98c5..94a32ee 100644
|
||||||
|
--- a/daemon/gdm-slave.c
|
||||||
|
+++ b/daemon/gdm-slave.c
|
||||||
|
@@ -881,6 +881,16 @@ gdm_slave_get_timed_login_details (GdmSlave *slave,
|
||||||
|
if (usernamep != NULL) {
|
||||||
|
*usernamep = gdm_slave_parse_enriched_login (slave,
|
||||||
|
username, slave->priv->display_name);
|
||||||
|
+ } else {
|
||||||
|
+ g_free (username);
|
||||||
|
+
|
||||||
|
+ if (enabledp != NULL) {
|
||||||
|
+ *enabledp = enabled;
|
||||||
|
+ }
|
||||||
|
+ if (delayp != NULL) {
|
||||||
|
+ *delayp = delay;
|
||||||
|
+ }
|
||||||
|
+ return TRUE;
|
||||||
|
}
|
||||||
|
g_free (username);
|
||||||
|
|
||||||
|
--
|
||||||
|
1.6.4.2
|
||||||
|
|
7
gdm.spec
7
gdm.spec
@ -16,7 +16,7 @@
|
|||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.28.0
|
Version: 2.28.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -99,6 +99,7 @@ Patch3: gdm-2.23.92-save-root-window.patch
|
|||||||
Patch13: gdm-system-keyboard.patch
|
Patch13: gdm-system-keyboard.patch
|
||||||
|
|
||||||
Patch19: gdm-multistack.patch
|
Patch19: gdm-multistack.patch
|
||||||
|
Patch20: 0001-Fix-gdm_slave_get_timed_login_details.patch
|
||||||
|
|
||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
Patch99: gdm-2.23.1-fedora-logo.patch
|
Patch99: gdm-2.23.1-fedora-logo.patch
|
||||||
@ -143,6 +144,7 @@ The GDM fingerprint plugin provides functionality necessary to use a fingerprint
|
|||||||
%patch13 -p1 -b .system-keyboard
|
%patch13 -p1 -b .system-keyboard
|
||||||
|
|
||||||
%patch19 -p1 -b .multistack
|
%patch19 -p1 -b .multistack
|
||||||
|
%patch20 -p1 -b .autologin
|
||||||
|
|
||||||
%patch99 -p1 -b .fedora-logo
|
%patch99 -p1 -b .fedora-logo
|
||||||
|
|
||||||
@ -392,6 +394,9 @@ fi
|
|||||||
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 25 2009 Ray Strode <rstrode@redhat.com> 1:2.28.0-2
|
||||||
|
- Fix autologin
|
||||||
|
|
||||||
* Wed Sep 23 2009 Matthias Clasen <mclasen@redhat.com> 1:2.28.0-1
|
* Wed Sep 23 2009 Matthias Clasen <mclasen@redhat.com> 1:2.28.0-1
|
||||||
- Update to 2.28.0
|
- Update to 2.28.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user