fix another patch

This commit is contained in:
Matthias Clasen 2007-05-21 19:46:02 +00:00
parent a61189ea57
commit 37c718552f

View File

@ -1,5 +1,5 @@
--- gdm-2.19.1/configure.ac.security-tokens 2007-05-21 14:52:10.000000000 -0400
+++ gdm-2.19.1/configure.ac 2007-05-21 14:52:10.000000000 -0400
--- gdm-2.19.1/configure.ac.security-tokens 2007-05-21 15:34:16.000000000 -0400
+++ gdm-2.19.1/configure.ac 2007-05-21 15:34:16.000000000 -0400
@@ -20,6 +20,7 @@ LIBRSVG_REQUIRED=1.1.1
LIBXML_REQUIRED=2.4.12
LIBART_REQUIRED=2.3.11
@ -18,13 +18,13 @@
AC_SUBST(DAEMON_LIBS)
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
+++ gdm-2.19.1/config/securitytokens.conf.in 2007-05-21 14:52:10.000000000 -0400
+++ gdm-2.19.1/config/securitytokens.conf.in 2007-05-21 15:34:16.000000000 -0400
@@ -0,0 +1,3 @@
+[SecurityTokens]
+Enable=true
+#Driver=@libdir@/pkcs11/libcoolkeypk11.so
--- gdm-2.19.1/config/Makefile.am.security-tokens 2007-05-13 22:08:25.000000000 -0400
+++ gdm-2.19.1/config/Makefile.am 2007-05-21 14:52:10.000000000 -0400
+++ gdm-2.19.1/config/Makefile.am 2007-05-21 15:34:16.000000000 -0400
@@ -34,9 +34,11 @@ EXTRA_DIST = \
XKeepsCrashing \
gettextfoo.h \
@ -87,8 +87,8 @@
$(INSTALL_SCRIPT) $(srcdir)/XKeepsCrashing $(DESTDIR)$(confdir)/XKeepsCrashing
$(INSTALL_SCRIPT) Xsession $(DESTDIR)$(confdir)/Xsession
--- gdm-2.19.1/config/gdm.conf.in.security-tokens 2007-05-21 14:52:10.000000000 -0400
+++ gdm-2.19.1/config/gdm.conf.in 2007-05-21 14:52:10.000000000 -0400
--- gdm-2.19.1/config/gdm.conf.in.security-tokens 2007-05-21 15:34:16.000000000 -0400
+++ gdm-2.19.1/config/gdm.conf.in 2007-05-21 15:34:16.000000000 -0400
@@ -239,6 +239,10 @@ AlwaysLoginCurrentSession=true
# kills it. 10 seconds should be long enough for X, but Xgl may need 20 or 25.
GdmXserverTimeout=10
@ -100,8 +100,8 @@
[security]
# Allow root to login. It makes sense to turn this off for kiosk use, when
# you want to minimize the possibility of break in.
--- gdm-2.19.1/daemon/gdm.c.security-tokens 2007-05-21 14:52:10.000000000 -0400
+++ gdm-2.19.1/daemon/gdm.c 2007-05-21 14:52:45.000000000 -0400
--- gdm-2.19.1/daemon/gdm.c.security-tokens 2007-05-21 15:34:16.000000000 -0400
+++ gdm-2.19.1/daemon/gdm.c 2007-05-21 15:41:24.000000000 -0400
@@ -71,6 +71,8 @@
#include "cookie.h"
#include "filecheck.h"
@ -131,7 +131,7 @@
/* We always exit via exit (), and sadly we need to g_main_quit ()
* at times not knowing if it's this main or a recursive one we're
* quitting.
@@ -4342,3 +4350,83 @@ gdm_handle_user_message (GdmConnection *
@@ -4342,3 +4350,89 @@ gdm_handle_user_message (GdmConnection *
gdm_connection_close (conn);
}
}
@ -156,12 +156,14 @@
+#define GDM_SECURITY_TOKENS_CONF GDMCONFDIR "/securitytokens.conf"
+#endif
+
+#ifndef GDM_SECURITY_TOKENS_GROUP "SecurityTokens"
+
+#ifndef GDM_SECURITY_TOKENS_KEY_ENABLED
+#define GDM_SECURITY_TOKENS_KEY_ENABLED "SecurityTokens/Enabled=true"
+#define GDM_SECURITY_TOKENS_KEY_ENABLED "Enabled"
+#endif
+
+#ifndef GDM_SECURITY_TOKENS_KEY_DRIVER
+#define GDM_SECURITY_TOKENS_KEY_DRIVER "SecurityTokens/Driver"
+#define GDM_SECURITY_TOKENS_KEY_DRIVER "Driver"
+#endif
+
+static void
@ -170,18 +172,22 @@
+ GError *error;
+ ScSecurityTokenMonitor *monitor;
+ gchar *driver;
+ VeConfig *cfg;
+ GKeyFile *cfg;
+
+ cfg = ve_config_new (GDM_SECURITY_TOKENS_CONF);
+ cfg = g_key_file_new ();
+ if (!g_key_file_load_from_file (cfg, GDM_SECURITY_TOKENS_CONF, 0, NULL)) {
+ goto out;
+ }
+
+ if (!g_key_file_get_boolean (cfg, GDM_SECURITY_TOKENS_GROUP, GDM_SECURITY_TOKENS_KEY_ENABLED, NULL)) {
+
+ if (!ve_config_get_bool (cfg, GDM_SECURITY_TOKENS_KEY_ENABLED)) {
+ gdm_debug ("security token support is not enabled");
+ goto out;
+ }
+
+ gdm_debug ("watching for security token insertion and removal events");
+
+ driver = ve_config_get_string (cfg, GDM_SECURITY_TOKENS_KEY_DRIVER);
+ driver = g_key_file_get_string (cfg, GDM_SECURITY_TOKENS_GROUP, GDM_SECURITY_TOKENS_KEY_DRIVER, NULL);
+ gdm_debug ("security tokens driver is set to '%s'",
+ ve_string_empty (driver)? "<automatic>" : driver);
+ monitor = sc_security_token_monitor_new (driver);
@ -212,11 +218,11 @@
+ goto out;
+ }
+out:
+ ve_config_destroy (cfg);
+ g_key_file_free (cfg);
+}
+
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
+++ gdm-2.19.1/daemon/securitytokenmonitor.h 2007-05-21 14:52:10.000000000 -0400
+++ gdm-2.19.1/daemon/securitytokenmonitor.h 2007-05-21 15:34:16.000000000 -0400
@@ -0,0 +1,84 @@
+/* securitytokenmonitor.h - monitor for security token insertion and
+ * removal events
@ -303,7 +309,7 @@
+G_END_DECLS
+#endif /* SC_SECURITY_TOKEN_MONITOR_H */
--- gdm-2.19.1/daemon/Makefile.am.security-tokens 2007-05-13 22:08:25.000000000 -0400
+++ gdm-2.19.1/daemon/Makefile.am 2007-05-21 14:52:10.000000000 -0400
+++ gdm-2.19.1/daemon/Makefile.am 2007-05-21 15:34:16.000000000 -0400
@@ -9,6 +9,7 @@ INCLUDES = \
-DAUTHDIR=\"$(authdir)\" \
-DBINDIR=\"$(bindir)\" \
@ -324,7 +330,7 @@
XDMCP_SOURCES = \
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
+++ gdm-2.19.1/daemon/securitytoken.h 2007-05-21 14:52:10.000000000 -0400
+++ gdm-2.19.1/daemon/securitytoken.h 2007-05-21 15:34:16.000000000 -0400
@@ -0,0 +1,94 @@
+/* securitytoken.h - api for reading and writing data to a security token
+ *
@ -421,7 +427,7 @@
+G_END_DECLS
+#endif /* SC_SECURITY_TOKEN_H */
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
+++ gdm-2.19.1/daemon/securitytokenmonitor.c 2007-05-21 14:52:10.000000000 -0400
+++ gdm-2.19.1/daemon/securitytokenmonitor.c 2007-05-21 15:34:16.000000000 -0400
@@ -0,0 +1,1743 @@
+/* securitytokenmonitor.c - monitor for security token insertion and
+ * removal events
@ -2167,7 +2173,7 @@
+}
+#endif
--- /dev/null 2007-05-21 09:34:56.803421964 -0400
+++ gdm-2.19.1/daemon/securitytoken.c 2007-05-21 14:52:10.000000000 -0400
+++ gdm-2.19.1/daemon/securitytoken.c 2007-05-21 15:34:16.000000000 -0400
@@ -0,0 +1,680 @@
+/* securitytoken.c - security token
+ *