- Update to 3.37.1
This commit is contained in:
parent
994a0d9d69
commit
3561251d3c
@ -18,18 +18,6 @@ https://bugzilla.gnome.org/show_bug.cgi?id=777708
|
|||||||
daemon/gdm-display.c | 29 +++++++++++++++++++++++++++++
|
daemon/gdm-display.c | 29 +++++++++++++++++++++++++++++
|
||||||
2 files changed, 30 insertions(+)
|
2 files changed, 30 insertions(+)
|
||||||
|
|
||||||
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
|
|
||||||
index 5e9eb5e..3b1b151 100644
|
|
||||||
--- a/daemon/Makefile.am
|
|
||||||
+++ b/daemon/Makefile.am
|
|
||||||
@@ -15,6 +15,7 @@ AM_CPPFLAGS = \
|
|
||||||
-DLOCALSTATEDIR=\"$(localstatedir)\" \
|
|
||||||
-DLOGDIR=\"$(logdir)\" \
|
|
||||||
-DSBINDIR=\"$(sbindir)\" \
|
|
||||||
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
|
|
||||||
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
|
|
||||||
-DGDM_RUN_DIR=\"$(GDM_RUN_DIR)\" \
|
|
||||||
-DGDM_XAUTH_DIR=\"$(GDM_XAUTH_DIR)\" \
|
|
||||||
diff --git a/daemon/gdm-display.c b/daemon/gdm-display.c
|
diff --git a/daemon/gdm-display.c b/daemon/gdm-display.c
|
||||||
index 5e193f2..878be88 100644
|
index 5e193f2..878be88 100644
|
||||||
--- a/daemon/gdm-display.c
|
--- a/daemon/gdm-display.c
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From a0f3d7108f688d48ad8653c380dba575fcd2fc3f Mon Sep 17 00:00:00 2001
|
From 07e4fb92c76839ee61cfa311381c63b772067377 Mon Sep 17 00:00:00 2001
|
||||||
From: Ray Strode <rstrode@redhat.com>
|
From: Ray Strode <rstrode@redhat.com>
|
||||||
Date: Mon, 15 Apr 2019 10:53:25 -0400
|
Date: Mon, 15 Apr 2019 10:53:25 -0400
|
||||||
Subject: [PATCH] data: disable wayland if modesetting is disabled
|
Subject: [PATCH] data: disable wayland if modesetting is disabled
|
||||||
@ -13,12 +13,10 @@ logic if start up is unreasonably slow.
|
|||||||
1 file changed, 2 insertions(+)
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
diff --git a/data/61-gdm.rules.in b/data/61-gdm.rules.in
|
diff --git a/data/61-gdm.rules.in b/data/61-gdm.rules.in
|
||||||
index ad5b87d4c..ebdbfe9c1 100644
|
index ba0b697a2..984fdd447 100644
|
||||||
--- a/data/61-gdm.rules.in
|
--- a/data/61-gdm.rules.in
|
||||||
+++ b/data/61-gdm.rules.in
|
+++ b/data/61-gdm.rules.in
|
||||||
@@ -1,6 +1,8 @@
|
@@ -1,4 +1,6 @@
|
||||||
# disable Wayland on Cirrus chipsets
|
|
||||||
ATTR{vendor}=="0x1013", ATTR{device}=="0x00b8", ATTR{subsystem_vendor}=="0x1af4", ATTR{subsystem_device}=="0x1100", RUN+="@libexecdir@/gdm-disable-wayland"
|
|
||||||
# disable Wayland on Hi1710 chipsets
|
# disable Wayland on Hi1710 chipsets
|
||||||
ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", RUN+="@libexecdir@/gdm-disable-wayland"
|
ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", RUN+="@libexecdir@/gdm-disable-wayland"
|
||||||
# disable Wayland when using the proprietary nvidia driver
|
# disable Wayland when using the proprietary nvidia driver
|
||||||
@ -26,5 +24,5 @@ index ad5b87d4c..ebdbfe9c1 100644
|
|||||||
+# disable Wayland if modesetting is disabled
|
+# disable Wayland if modesetting is disabled
|
||||||
+IMPORT{cmdline}="nomodeset", RUN+="@libexecdir@/gdm-disable-wayland"
|
+IMPORT{cmdline}="nomodeset", RUN+="@libexecdir@/gdm-disable-wayland"
|
||||||
--
|
--
|
||||||
2.20.1
|
2.26.0
|
||||||
|
|
||||||
|
7
gdm.spec
7
gdm.spec
@ -9,7 +9,7 @@
|
|||||||
|
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 3.35.1
|
Version: 3.37.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
|
|
||||||
@ -19,7 +19,7 @@ Source0: http://download.gnome.org/sources/gdm/3.34/gdm-%{version}.tar.xz
|
|||||||
Source1: org.gnome.login-screen.gschema.override
|
Source1: org.gnome.login-screen.gschema.override
|
||||||
Patch0: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
|
Patch0: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
|
||||||
|
|
||||||
#Patch10001: 0001-data-disable-wayland-if-modesetting-is-disabled.patch
|
Patch10001: 0001-data-disable-wayland-if-modesetting-is-disabled.patch
|
||||||
|
|
||||||
Patch99: system-dconf.patch
|
Patch99: system-dconf.patch
|
||||||
|
|
||||||
@ -298,6 +298,9 @@ fi
|
|||||||
%{_libdir}/pkgconfig/gdm-pam-extensions.pc
|
%{_libdir}/pkgconfig/gdm-pam-extensions.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 04 2020 Ray Strode <rstrode@redhat.com> - 3.37.1-1
|
||||||
|
- Update to 3.37.1
|
||||||
|
|
||||||
* Tue Apr 07 2020 Ray Strode <rstrode@redhat.com> - 3.34.1-3
|
* Tue Apr 07 2020 Ray Strode <rstrode@redhat.com> - 3.34.1-3
|
||||||
- Fix autologin when gdm is started from VT other than VT 1
|
- Fix autologin when gdm is started from VT other than VT 1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user