- Update to 2.29.5
This commit is contained in:
parent
d230de45bf
commit
1df2df1b70
@ -1,6 +1,7 @@
|
|||||||
diff -up gdm-2.29.4/daemon/gdm-simple-slave.c.fix-boot gdm-2.29.4/daemon/gdm-simple-slave.c
|
|
||||||
--- gdm-2.29.4/daemon/gdm-simple-slave.c.fix-boot 2010-01-14 16:10:58.507800165 -0500
|
diff -up gdm-2.29.5/daemon/gdm-simple-slave.c.fix-boot gdm-2.29.5/daemon/gdm-simple-slave.c
|
||||||
+++ gdm-2.29.4/daemon/gdm-simple-slave.c 2010-01-14 16:10:58.543800532 -0500
|
--- gdm-2.29.5/daemon/gdm-simple-slave.c.fix-boot 2010-01-26 17:34:33.980834884 -0500
|
||||||
|
+++ gdm-2.29.5/daemon/gdm-simple-slave.c 2010-01-26 17:34:34.027782630 -0500
|
||||||
@@ -91,6 +91,7 @@ struct GdmSimpleSlavePrivate
|
@@ -91,6 +91,7 @@ struct GdmSimpleSlavePrivate
|
||||||
|
|
||||||
enum {
|
enum {
|
||||||
@ -9,7 +10,7 @@ diff -up gdm-2.29.4/daemon/gdm-simple-slave.c.fix-boot gdm-2.29.4/daemon/gdm-sim
|
|||||||
};
|
};
|
||||||
|
|
||||||
static void gdm_simple_slave_class_init (GdmSimpleSlaveClass *klass);
|
static void gdm_simple_slave_class_init (GdmSimpleSlaveClass *klass);
|
||||||
@@ -1321,11 +1322,13 @@ gdm_simple_slave_run (GdmSimpleSlave *sl
|
@@ -1327,11 +1328,13 @@ gdm_simple_slave_run (GdmSimpleSlave *sl
|
||||||
char *display_name;
|
char *display_name;
|
||||||
char *auth_file;
|
char *auth_file;
|
||||||
gboolean display_is_local;
|
gboolean display_is_local;
|
||||||
@ -23,7 +24,7 @@ diff -up gdm-2.29.4/daemon/gdm-simple-slave.c.fix-boot gdm-2.29.4/daemon/gdm-sim
|
|||||||
NULL);
|
NULL);
|
||||||
|
|
||||||
/* if this is local display start a server if one doesn't
|
/* if this is local display start a server if one doesn't
|
||||||
@@ -1363,7 +1366,11 @@ gdm_simple_slave_run (GdmSimpleSlave *sl
|
@@ -1369,7 +1372,11 @@ gdm_simple_slave_run (GdmSimpleSlave *sl
|
||||||
plymouth_prepare_for_transition (slave);
|
plymouth_prepare_for_transition (slave);
|
||||||
res = gdm_server_start_on_active_vt (slave->priv->server);
|
res = gdm_server_start_on_active_vt (slave->priv->server);
|
||||||
} else {
|
} else {
|
||||||
@ -36,7 +37,7 @@ diff -up gdm-2.29.4/daemon/gdm-simple-slave.c.fix-boot gdm-2.29.4/daemon/gdm-sim
|
|||||||
}
|
}
|
||||||
if (! res) {
|
if (! res) {
|
||||||
g_warning (_("Could not start the X "
|
g_warning (_("Could not start the X "
|
||||||
@@ -1515,12 +1522,14 @@ gdm_simple_slave_finalize (GObject *obje
|
@@ -1521,12 +1528,14 @@ gdm_simple_slave_finalize (GObject *obje
|
||||||
}
|
}
|
||||||
|
|
||||||
GdmSlave *
|
GdmSlave *
|
||||||
@ -52,9 +53,9 @@ diff -up gdm-2.29.4/daemon/gdm-simple-slave.c.fix-boot gdm-2.29.4/daemon/gdm-sim
|
|||||||
NULL);
|
NULL);
|
||||||
|
|
||||||
return GDM_SLAVE (object);
|
return GDM_SLAVE (object);
|
||||||
diff -up gdm-2.29.4/daemon/gdm-simple-slave.h.fix-boot gdm-2.29.4/daemon/gdm-simple-slave.h
|
diff -up gdm-2.29.5/daemon/gdm-simple-slave.h.fix-boot gdm-2.29.5/daemon/gdm-simple-slave.h
|
||||||
--- gdm-2.29.4/daemon/gdm-simple-slave.h.fix-boot 2009-12-08 10:20:18.000000000 -0500
|
--- gdm-2.29.5/daemon/gdm-simple-slave.h.fix-boot 2009-12-08 10:20:18.000000000 -0500
|
||||||
+++ gdm-2.29.4/daemon/gdm-simple-slave.h 2010-01-14 16:10:58.543800532 -0500
|
+++ gdm-2.29.5/daemon/gdm-simple-slave.h 2010-01-26 17:34:34.027782630 -0500
|
||||||
@@ -48,7 +48,8 @@ typedef struct
|
@@ -48,7 +48,8 @@ typedef struct
|
||||||
} GdmSimpleSlaveClass;
|
} GdmSimpleSlaveClass;
|
||||||
|
|
||||||
@ -65,9 +66,9 @@ diff -up gdm-2.29.4/daemon/gdm-simple-slave.h.fix-boot gdm-2.29.4/daemon/gdm-sim
|
|||||||
|
|
||||||
G_END_DECLS
|
G_END_DECLS
|
||||||
|
|
||||||
diff -up gdm-2.29.4/daemon/gdm-slave.c.fix-boot gdm-2.29.4/daemon/gdm-slave.c
|
diff -up gdm-2.29.5/daemon/gdm-slave.c.fix-boot gdm-2.29.5/daemon/gdm-slave.c
|
||||||
--- gdm-2.29.4/daemon/gdm-slave.c.fix-boot 2010-01-14 16:10:58.280770006 -0500
|
--- gdm-2.29.5/daemon/gdm-slave.c.fix-boot 2010-01-26 17:34:33.777750861 -0500
|
||||||
+++ gdm-2.29.4/daemon/gdm-slave.c 2010-01-14 16:10:58.544770030 -0500
|
+++ gdm-2.29.5/daemon/gdm-slave.c 2010-01-26 17:46:49.256752923 -0500
|
||||||
@@ -84,6 +84,7 @@ struct GdmSlavePrivate
|
@@ -84,6 +84,7 @@ struct GdmSlavePrivate
|
||||||
char *display_hostname;
|
char *display_hostname;
|
||||||
gboolean display_is_local;
|
gboolean display_is_local;
|
||||||
@ -84,7 +85,7 @@ diff -up gdm-2.29.4/daemon/gdm-slave.c.fix-boot gdm-2.29.4/daemon/gdm-slave.c
|
|||||||
PROP_DISPLAY_SEAT_ID,
|
PROP_DISPLAY_SEAT_ID,
|
||||||
PROP_DISPLAY_X11_AUTHORITY_FILE
|
PROP_DISPLAY_X11_AUTHORITY_FILE
|
||||||
};
|
};
|
||||||
@@ -1404,6 +1406,13 @@ _gdm_slave_set_display_is_local (GdmSlav
|
@@ -1402,6 +1404,13 @@ _gdm_slave_set_display_is_local (GdmSlav
|
||||||
}
|
}
|
||||||
|
|
||||||
static void
|
static void
|
||||||
@ -98,7 +99,7 @@ diff -up gdm-2.29.4/daemon/gdm-slave.c.fix-boot gdm-2.29.4/daemon/gdm-slave.c
|
|||||||
gdm_slave_set_property (GObject *object,
|
gdm_slave_set_property (GObject *object,
|
||||||
guint prop_id,
|
guint prop_id,
|
||||||
const GValue *value,
|
const GValue *value,
|
||||||
@@ -1435,6 +1444,9 @@ gdm_slave_set_property (GObject *ob
|
@@ -1433,6 +1442,9 @@ gdm_slave_set_property (GObject *ob
|
||||||
case PROP_DISPLAY_IS_LOCAL:
|
case PROP_DISPLAY_IS_LOCAL:
|
||||||
_gdm_slave_set_display_is_local (self, g_value_get_boolean (value));
|
_gdm_slave_set_display_is_local (self, g_value_get_boolean (value));
|
||||||
break;
|
break;
|
||||||
@ -108,7 +109,7 @@ diff -up gdm-2.29.4/daemon/gdm-slave.c.fix-boot gdm-2.29.4/daemon/gdm-slave.c
|
|||||||
default:
|
default:
|
||||||
G_OBJECT_WARN_INVALID_PROPERTY_ID (object, prop_id, pspec);
|
G_OBJECT_WARN_INVALID_PROPERTY_ID (object, prop_id, pspec);
|
||||||
break;
|
break;
|
||||||
@@ -1473,6 +1485,9 @@ gdm_slave_get_property (GObject *obje
|
@@ -1471,6 +1483,9 @@ gdm_slave_get_property (GObject *obje
|
||||||
case PROP_DISPLAY_IS_LOCAL:
|
case PROP_DISPLAY_IS_LOCAL:
|
||||||
g_value_set_boolean (value, self->priv->display_is_local);
|
g_value_set_boolean (value, self->priv->display_is_local);
|
||||||
break;
|
break;
|
||||||
@ -118,9 +119,24 @@ diff -up gdm-2.29.4/daemon/gdm-slave.c.fix-boot gdm-2.29.4/daemon/gdm-slave.c
|
|||||||
default:
|
default:
|
||||||
G_OBJECT_WARN_INVALID_PROPERTY_ID (object, prop_id, pspec);
|
G_OBJECT_WARN_INVALID_PROPERTY_ID (object, prop_id, pspec);
|
||||||
break;
|
break;
|
||||||
diff -up gdm-2.29.4/daemon/gdm-static-display.c.fix-boot gdm-2.29.4/daemon/gdm-static-display.c
|
@@ -1595,6 +1610,14 @@ gdm_slave_class_init (GdmSlaveClass *kla
|
||||||
--- gdm-2.29.4/daemon/gdm-static-display.c.fix-boot 2009-12-17 09:20:42.000000000 -0500
|
"display is local",
|
||||||
+++ gdm-2.29.4/daemon/gdm-static-display.c 2010-01-14 16:10:58.545800295 -0500
|
TRUE,
|
||||||
|
G_PARAM_READWRITE | G_PARAM_CONSTRUCT_ONLY));
|
||||||
|
+ g_object_class_install_property (object_class,
|
||||||
|
+ PROP_FORCE_ACTIVE_VT,
|
||||||
|
+ g_param_spec_boolean ("force-active-vt",
|
||||||
|
+ "Force Active VT",
|
||||||
|
+ "Force display to active VT",
|
||||||
|
+ TRUE,
|
||||||
|
+ G_PARAM_READWRITE | G_PARAM_CONSTRUCT_ONLY));
|
||||||
|
+
|
||||||
|
|
||||||
|
signals [STOPPED] =
|
||||||
|
g_signal_new ("stopped",
|
||||||
|
diff -up gdm-2.29.5/daemon/gdm-static-display.c.fix-boot gdm-2.29.5/daemon/gdm-static-display.c
|
||||||
|
--- gdm-2.29.5/daemon/gdm-static-display.c.fix-boot 2009-12-17 09:20:42.000000000 -0500
|
||||||
|
+++ gdm-2.29.5/daemon/gdm-static-display.c 2010-01-26 17:34:34.029750726 -0500
|
||||||
@@ -86,10 +86,27 @@ gdm_static_display_remove_user_authoriza
|
@@ -86,10 +86,27 @@ gdm_static_display_remove_user_authoriza
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -149,9 +165,9 @@ diff -up gdm-2.29.4/daemon/gdm-static-display.c.fix-boot gdm-2.29.4/daemon/gdm-s
|
|||||||
GDM_DISPLAY_CLASS (gdm_static_display_parent_class)->manage (display);
|
GDM_DISPLAY_CLASS (gdm_static_display_parent_class)->manage (display);
|
||||||
|
|
||||||
return TRUE;
|
return TRUE;
|
||||||
diff -up gdm-2.29.4/daemon/Makefile.am.fix-boot gdm-2.29.4/daemon/Makefile.am
|
diff -up gdm-2.29.5/daemon/Makefile.am.fix-boot gdm-2.29.5/daemon/Makefile.am
|
||||||
--- gdm-2.29.4/daemon/Makefile.am.fix-boot 2010-01-14 16:16:26.262770051 -0500
|
--- gdm-2.29.5/daemon/Makefile.am.fix-boot 2010-01-12 15:30:45.000000000 -0500
|
||||||
+++ gdm-2.29.4/daemon/Makefile.am 2010-01-14 16:17:35.998771692 -0500
|
+++ gdm-2.29.5/daemon/Makefile.am 2010-01-26 17:34:34.029750726 -0500
|
||||||
@@ -14,6 +14,7 @@ AM_CPPFLAGS = \
|
@@ -14,6 +14,7 @@ AM_CPPFLAGS = \
|
||||||
-DLOGDIR=\"$(logdir)\" \
|
-DLOGDIR=\"$(logdir)\" \
|
||||||
-DSBINDIR=\"$(sbindir)\" \
|
-DSBINDIR=\"$(sbindir)\" \
|
||||||
@ -160,9 +176,9 @@ diff -up gdm-2.29.4/daemon/Makefile.am.fix-boot gdm-2.29.4/daemon/Makefile.am
|
|||||||
-DGDM_XAUTH_DIR=\"$(GDM_XAUTH_DIR)\" \
|
-DGDM_XAUTH_DIR=\"$(GDM_XAUTH_DIR)\" \
|
||||||
-DGDM_SCREENSHOT_DIR=\"$(GDM_SCREENSHOT_DIR)\" \
|
-DGDM_SCREENSHOT_DIR=\"$(GDM_SCREENSHOT_DIR)\" \
|
||||||
-DGDM_CACHE_DIR=\""$(localstatedir)/cache/gdm"\" \
|
-DGDM_CACHE_DIR=\""$(localstatedir)/cache/gdm"\" \
|
||||||
diff -up gdm-2.29.4/daemon/simple-slave-main.c.fix-boot gdm-2.29.4/daemon/simple-slave-main.c
|
diff -up gdm-2.29.5/daemon/simple-slave-main.c.fix-boot gdm-2.29.5/daemon/simple-slave-main.c
|
||||||
--- gdm-2.29.4/daemon/simple-slave-main.c.fix-boot 2009-12-21 11:36:30.000000000 -0500
|
--- gdm-2.29.5/daemon/simple-slave-main.c.fix-boot 2010-01-12 11:36:37.000000000 -0500
|
||||||
+++ gdm-2.29.4/daemon/simple-slave-main.c 2010-01-14 16:10:58.545800295 -0500
|
+++ gdm-2.29.5/daemon/simple-slave-main.c 2010-01-26 17:34:34.029750726 -0500
|
||||||
@@ -178,9 +178,11 @@ main (int argc,
|
@@ -178,9 +178,11 @@ main (int argc,
|
||||||
DBusGConnection *connection;
|
DBusGConnection *connection;
|
||||||
GdmSlave *slave;
|
GdmSlave *slave;
|
||||||
@ -184,9 +200,9 @@ diff -up gdm-2.29.4/daemon/simple-slave-main.c.fix-boot gdm-2.29.4/daemon/simple
|
|||||||
if (slave == NULL) {
|
if (slave == NULL) {
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
diff -up gdm-2.29.4/data/Makefile.am.fix-boot gdm-2.29.4/data/Makefile.am
|
diff -up gdm-2.29.5/data/Makefile.am.fix-boot gdm-2.29.5/data/Makefile.am
|
||||||
--- gdm-2.29.4/data/Makefile.am.fix-boot 2009-12-21 11:36:30.000000000 -0500
|
--- gdm-2.29.5/data/Makefile.am.fix-boot 2010-01-13 09:44:40.000000000 -0500
|
||||||
+++ gdm-2.29.4/data/Makefile.am 2010-01-14 16:10:58.546769600 -0500
|
+++ gdm-2.29.5/data/Makefile.am 2010-01-26 17:34:34.030752200 -0500
|
||||||
@@ -13,6 +13,7 @@ predir = $(gdmconfdir)/PreSession
|
@@ -13,6 +13,7 @@ predir = $(gdmconfdir)/PreSession
|
||||||
postlogindir = $(gdmconfdir)/PostLogin
|
postlogindir = $(gdmconfdir)/PostLogin
|
||||||
workingdir = $(GDM_WORKING_DIR)
|
workingdir = $(GDM_WORKING_DIR)
|
||||||
@ -195,7 +211,7 @@ diff -up gdm-2.29.4/data/Makefile.am.fix-boot gdm-2.29.4/data/Makefile.am
|
|||||||
screenshotdir = $(GDM_SCREENSHOT_DIR)
|
screenshotdir = $(GDM_SCREENSHOT_DIR)
|
||||||
cachedir = $(localstatedir)/cache/gdm
|
cachedir = $(localstatedir)/cache/gdm
|
||||||
|
|
||||||
@@ -125,6 +126,7 @@ uninstall-hook:
|
@@ -129,6 +130,7 @@ uninstall-hook:
|
||||||
$(DESTDIR)$(workingdir)/.gconf.mandatory \
|
$(DESTDIR)$(workingdir)/.gconf.mandatory \
|
||||||
$(DESTDIR)$(screenshotdir) \
|
$(DESTDIR)$(screenshotdir) \
|
||||||
$(DESTDIR)$(xauthdir)
|
$(DESTDIR)$(xauthdir)
|
||||||
@ -203,7 +219,7 @@ diff -up gdm-2.29.4/data/Makefile.am.fix-boot gdm-2.29.4/data/Makefile.am
|
|||||||
|
|
||||||
install-data-hook: gdm.conf-custom Xsession Init PostSession PreSession gconf.path
|
install-data-hook: gdm.conf-custom Xsession Init PostSession PreSession gconf.path
|
||||||
if test '!' -d $(DESTDIR)$(gdmconfdir); then \
|
if test '!' -d $(DESTDIR)$(gdmconfdir); then \
|
||||||
@@ -217,6 +219,11 @@ install-data-hook: gdm.conf-custom Xsess
|
@@ -221,6 +223,11 @@ install-data-hook: gdm.conf-custom Xsess
|
||||||
chmod 1770 $(DESTDIR)$(workingdir); \
|
chmod 1770 $(DESTDIR)$(workingdir); \
|
||||||
chown root:gdm $(DESTDIR)$(workingdir) || : ; \
|
chown root:gdm $(DESTDIR)$(workingdir) || : ; \
|
||||||
fi
|
fi
|
||||||
|
2100
gdm-multistack.patch
2100
gdm-multistack.patch
File diff suppressed because it is too large
Load Diff
20
gdm.spec
20
gdm.spec
@ -15,8 +15,8 @@
|
|||||||
|
|
||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.29.4
|
Version: 2.29.5
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -94,11 +94,8 @@ Provides: service(graphical-login)
|
|||||||
|
|
||||||
Requires: audit-libs >= %{libauditver}
|
Requires: audit-libs >= %{libauditver}
|
||||||
Patch2: plymouth.patch
|
Patch2: plymouth.patch
|
||||||
|
Patch3: add-locale-alias.patch
|
||||||
# uses /etc/sysconfig/keyboard and is thus not directly upstreamable
|
Patch4: xklavier-fix.patch
|
||||||
# should probably be changed to get the system layout from the X server
|
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=572765
|
|
||||||
Patch13: gdm-system-keyboard.patch
|
|
||||||
|
|
||||||
Patch96: gdm-multistack.patch
|
Patch96: gdm-multistack.patch
|
||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
@ -143,7 +140,8 @@ The GDM fingerprint plugin provides functionality necessary to use a fingerprint
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch2 -p1 -b .plymouth
|
%patch2 -p1 -b .plymouth
|
||||||
%patch13 -p1 -b .system-keyboard
|
%patch3 -p1 -b .add-locale-alias
|
||||||
|
%patch4 -p1 -b .xklavier-fix
|
||||||
%patch96 -p1 -b .multistack
|
%patch96 -p1 -b .multistack
|
||||||
%patch97 -p1 -b .bubble-location
|
%patch97 -p1 -b .bubble-location
|
||||||
%patch98 -p1 -b .tray-padding
|
%patch98 -p1 -b .tray-padding
|
||||||
@ -361,7 +359,8 @@ fi
|
|||||||
%{_sbindir}/gdm-stop
|
%{_sbindir}/gdm-stop
|
||||||
%{_bindir}/gdmflexiserver
|
%{_bindir}/gdmflexiserver
|
||||||
%{_bindir}/gdm-screenshot
|
%{_bindir}/gdm-screenshot
|
||||||
%{_datadir}/gdm/*.glade
|
%{_datadir}/gdm/*.ui
|
||||||
|
%{_datadir}/gdm/locale.alias
|
||||||
%{_sysconfdir}/gconf/schemas/*.schemas
|
%{_sysconfdir}/gconf/schemas/*.schemas
|
||||||
%{_datadir}/gdm/gdb-cmd
|
%{_datadir}/gdm/gdb-cmd
|
||||||
%{_libexecdir}/gdm-crash-logger
|
%{_libexecdir}/gdm-crash-logger
|
||||||
@ -404,6 +403,9 @@ fi
|
|||||||
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
%{_libdir}/gdm/simple-greeter/plugins/fingerprint.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 26 2010 Ray Strode <rstrode@redhat.com> 2.29.5-1
|
||||||
|
- Update to 2.29.5
|
||||||
|
|
||||||
* Sun Jan 17 2010 Matthias Clasen <mclasen@redhat.com> - 2.29.4-3
|
* Sun Jan 17 2010 Matthias Clasen <mclasen@redhat.com> - 2.29.4-3
|
||||||
- Rebuild
|
- Rebuild
|
||||||
|
|
||||||
|
62
xklavier-fix.patch
Normal file
62
xklavier-fix.patch
Normal file
@ -0,0 +1,62 @@
|
|||||||
|
From 51669cb03613b36b0b1798b1f8d2bba85b3e2a49 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Martin Pitt <martin.pitt@ubuntu.com>
|
||||||
|
Date: Mon, 18 Jan 2010 16:09:58 +0100
|
||||||
|
Subject: [PATCH] Fix crash in getting system keyboard layout
|
||||||
|
|
||||||
|
In get_system_default_layout(), use a static variable for
|
||||||
|
xkl_engine_get_instance() result, and don't close the X Display.
|
||||||
|
|
||||||
|
This fixes the crash that happens at the second call of
|
||||||
|
get_system_default_layout(): xkl_engine_get_instance() returns a singleton
|
||||||
|
which saves the passed X Display instance, so we must never close it.
|
||||||
|
|
||||||
|
https://launchpad.net/bugs/505972
|
||||||
|
---
|
||||||
|
daemon/gdm-session-direct.c | 23 ++++++++++++-----------
|
||||||
|
1 files changed, 12 insertions(+), 11 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/daemon/gdm-session-direct.c b/daemon/gdm-session-direct.c
|
||||||
|
index 011a919..d2e1a83 100644
|
||||||
|
--- a/daemon/gdm-session-direct.c
|
||||||
|
+++ b/daemon/gdm-session-direct.c
|
||||||
|
@@ -601,16 +601,19 @@ get_default_language_name (GdmSessionDirect *session)
|
||||||
|
static char *
|
||||||
|
get_system_default_layout (GdmSessionDirect *session)
|
||||||
|
{
|
||||||
|
- char *result;
|
||||||
|
- Display *display;
|
||||||
|
+ char *result = NULL;
|
||||||
|
+ static XklEngine *engine = NULL;
|
||||||
|
|
||||||
|
- result = NULL;
|
||||||
|
- display = XOpenDisplay (session->priv->display_name);
|
||||||
|
- if (display) {
|
||||||
|
- XklConfigRec *config;
|
||||||
|
- XklEngine *engine = xkl_engine_get_instance (display);
|
||||||
|
- if (engine)
|
||||||
|
- {
|
||||||
|
+ if (engine == NULL) {
|
||||||
|
+ Display *display = XOpenDisplay (session->priv->display_name);
|
||||||
|
+ if (display != NULL) {
|
||||||
|
+ engine = xkl_engine_get_instance (display);
|
||||||
|
+ }
|
||||||
|
+ /* do NOT call XCloseDisplay (display) here;
|
||||||
|
+ * xkl_engine_get_instance() is a singleton which saves the display */
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ if (engine != NULL) {
|
||||||
|
XklConfigRec *config = xkl_config_rec_new ();
|
||||||
|
if (xkl_config_rec_get_from_server (config, engine) && config->layouts && config->layouts[0]) {
|
||||||
|
if (config->variants && config->variants[0] && config->variants[0][0])
|
||||||
|
@@ -619,8 +622,6 @@ get_system_default_layout (GdmSessionDirect *session)
|
||||||
|
result = g_strdup (config->layouts[0]);
|
||||||
|
}
|
||||||
|
g_object_unref (config);
|
||||||
|
- }
|
||||||
|
- XCloseDisplay (display);
|
||||||
|
}
|
||||||
|
|
||||||
|
if (!result)
|
||||||
|
--
|
||||||
|
1.6.6
|
||||||
|
|
Loading…
Reference in New Issue
Block a user