Avoid Xorg build dependency

The only purpose of this dependency is to determine the location and
version of the X server.  Ideally there would be configuration options
for this, but for lack thereof, set our values in the fallback handler.
This commit is contained in:
Yaakov Selkowitz 2023-12-07 19:49:31 -05:00 committed by catanzaro
parent 4823e1b213
commit 1cff906bfa
2 changed files with 20 additions and 2 deletions

19
0001-xorg-detect.patch Normal file
View File

@ -0,0 +1,19 @@
Avoid the Xorg build-time dependency, as we already know the answers
to the questions that are trying to be determined.
diff --git a/meson.build b/meson.build
index bf0e58506..7d8f964c3 100644
--- a/meson.build
+++ b/meson.build
@@ -92,8 +92,9 @@ if find_x_server_out != ''
else
# what to do, what to do, this is wrong, but this just sets the
# defaults, perhaps this user is cross compiling or some such
- x_path = '/usr/bin/X11:/usr/X11R6/bin:/opt/X11R6/bin'
- x_bin = '/usr/bin/X'
+ x_path = '/usr/bin'
+ x_bin = '/usr/bin/Xorg'
+ xserver_has_listen = true
endif
xdmcp_dep = cc.find_library('Xdmcp', required: get_option('xdmcp'))
if xdmcp_dep.found() and get_option('tcp-wrappers')

View File

@ -24,6 +24,7 @@ Source6: gdm.sysusers
Patch: 0001-udev-Stick-with-wayland-on-hybrid-nvidia-with-vendor.patch
Patch: 0001-Honor-initial-setup-being-disabled-by-distro-install.patch
Patch: 0001-data-add-system-dconf-databases-to-gdm-profile.patch
Patch: 0001-xorg-detect.patch
BuildRequires: dconf
BuildRequires: desktop-file-utils
@ -46,10 +47,8 @@ BuildRequires: pkgconfig(ply-boot-client)
BuildRequires: pkgconfig(systemd)
BuildRequires: pkgconfig(x11)
BuildRequires: pkgconfig(xau)
BuildRequires: pkgconfig(xorg-server)
BuildRequires: systemd-rpm-macros
BuildRequires: which
BuildRequires: xorg-x11-server-Xorg
BuildRequires: yelp-tools
Provides: service(graphical-login) = %{name}