- Don't force X server on active vt more than once
This commit is contained in:
parent
530d12fd4a
commit
19bf2ed724
@ -335,7 +335,7 @@ diff -ur gdm-2.24.0/daemon/gdm-slave.c new/daemon/gdm-slave.c
|
|||||||
diff -ur gdm-2.24.0/daemon/gdm-static-display.c new/daemon/gdm-static-display.c
|
diff -ur gdm-2.24.0/daemon/gdm-static-display.c new/daemon/gdm-static-display.c
|
||||||
--- gdm-2.24.0/daemon/gdm-static-display.c 2008-07-10 11:07:42.000000000 -0400
|
--- gdm-2.24.0/daemon/gdm-static-display.c 2008-07-10 11:07:42.000000000 -0400
|
||||||
+++ new/daemon/gdm-static-display.c 2008-10-15 16:24:38.000000000 -0400
|
+++ new/daemon/gdm-static-display.c 2008-10-15 16:24:38.000000000 -0400
|
||||||
@@ -86,10 +86,26 @@
|
@@ -86,10 +86,27 @@
|
||||||
}
|
}
|
||||||
|
|
||||||
static gboolean
|
static gboolean
|
||||||
@ -357,8 +357,9 @@ diff -ur gdm-2.24.0/daemon/gdm-static-display.c new/daemon/gdm-static-display.c
|
|||||||
|
|
||||||
+ if (triggered_to_force_display_on_active_vt ()) {
|
+ if (triggered_to_force_display_on_active_vt ()) {
|
||||||
+ g_object_set (display, "force-active-vt", TRUE, NULL);
|
+ g_object_set (display, "force-active-vt", TRUE, NULL);
|
||||||
|
+ } else {
|
||||||
|
+ g_object_set (display, "force-active-vt", FALSE, NULL);
|
||||||
+ }
|
+ }
|
||||||
+
|
|
||||||
GDM_DISPLAY_CLASS (gdm_static_display_parent_class)->manage (display);
|
GDM_DISPLAY_CLASS (gdm_static_display_parent_class)->manage (display);
|
||||||
|
|
||||||
return TRUE;
|
return TRUE;
|
||||||
|
13
gdm.spec
13
gdm.spec
@ -15,7 +15,7 @@
|
|||||||
Summary: The GNOME Display Manager
|
Summary: The GNOME Display Manager
|
||||||
Name: gdm
|
Name: gdm
|
||||||
Version: 2.25.2
|
Version: 2.25.2
|
||||||
Release: 15%{?dist}
|
Release: 17%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -91,6 +91,8 @@ Patch13: gdm-system-keyboard.patch
|
|||||||
Patch14: gdm-2.25.2-multistack-but-boring.patch
|
Patch14: gdm-2.25.2-multistack-but-boring.patch
|
||||||
Patch15: gdm-2.25.2-start-faster.patch
|
Patch15: gdm-2.25.2-start-faster.patch
|
||||||
|
|
||||||
|
Patch16: gdm-2.25.2-use-resolvable-hostname.patch
|
||||||
|
|
||||||
# Fedora-specific
|
# Fedora-specific
|
||||||
Patch99: gdm-2.23.1-fedora-logo.patch
|
Patch99: gdm-2.23.1-fedora-logo.patch
|
||||||
|
|
||||||
@ -118,6 +120,7 @@ multiple simulanteous logged in users.
|
|||||||
|
|
||||||
%patch14 -p1 -b .multistack-but-boring
|
%patch14 -p1 -b .multistack-but-boring
|
||||||
%patch15 -p1 -b .start-faster
|
%patch15 -p1 -b .start-faster
|
||||||
|
%patch16 -p1 -b .use-resolvable-hostname
|
||||||
|
|
||||||
%patch99 -p1 -b .fedora-logo
|
%patch99 -p1 -b .fedora-logo
|
||||||
|
|
||||||
@ -341,6 +344,14 @@ fi
|
|||||||
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
%{_datadir}/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 12 2009 Ray Strode <rstrode@redhat.com> - 1:2.25.2-17
|
||||||
|
- Don't force X server on active vt more than once
|
||||||
|
|
||||||
|
* Tue Mar 10 2009 Ray Strode <rstrode@redhat.com> - 1:2.25.2-16
|
||||||
|
- Store greeter's auth cookie under "localhost" instead
|
||||||
|
of g_get_host_name() since NetworkManager tries to synchronize
|
||||||
|
the internal hostname with the externally resolvable one.
|
||||||
|
|
||||||
* Mon Mar 9 2009 Ray Strode <rstrode@redhat.com> - 1:2.25.2-15
|
* Mon Mar 9 2009 Ray Strode <rstrode@redhat.com> - 1:2.25.2-15
|
||||||
- Don't race with PAM modules that ask questions during
|
- Don't race with PAM modules that ask questions during
|
||||||
pam_open_session (and don't subsequently go bonkers when
|
pam_open_session (and don't subsequently go bonkers when
|
||||||
|
Loading…
Reference in New Issue
Block a user