gdbm/gdbm-1.8.0-fhs.patch
Štěpán Kasal a58c436b55 - drop *-cflags.patch, move all makefile fixes to *-fhs.patch
- propagate libdir to Makefile; no need to set it on cmdline
2009-02-27 18:21:25 +00:00

97 lines
2.7 KiB
Diff

2009-02-27 Stepan Kasal <skasal@redhat.com>
* Makefile.in: respect the *dir variables as set by configure;
clean up.
--- gdbm-1.8.0/Makefile.in.fhs 1999-05-19 05:16:06.000000000 +0200
+++ gdbm-1.8.0/Makefile.in 2009-02-27 18:52:19.000000000 +0100
@@ -1,7 +1,7 @@
#### Start of system configuration section. ####
srcdir = @srcdir@
-top_builddir = @srcdir@
+top_builddir = @top_builddir@
VPATH = @srcdir@
CC = @CC@
@@ -14,36 +14,29 @@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_DATA = @INSTALL_DATA@
-# File ownership and group
-BINOWN = bin
-BINGRP = bin
-
MAKEINFO = makeinfo
TEXI2DVI = texi2dvi
-DEFS =
+DEFS = @DEFS@
# Where the system [n]dbm routines are...
-LIBS = @LIBS@ -lc
+LIBS = @LIBS@
# SunOS 4 users might wish to add '-fpcc-struct-return' to CFLAGS. see INSTALL.
-CFLAGS = -O
-LDFLAGS =
+CPPFLAGS = @CPPFLAGS@
+CFLAGS = @CFLAGS@
+LDFLAGS = @LDFLAGS@
# Common prefix for installation directories
-prefix = /usr/local
-exec_prefix = $(prefix)
-binprefix = $(exec_prefix)
-manprefix = $(prefix)
-
-# Directory in which to put libgdbm.a.
-libdir = $(exec_prefix)/lib
-# The include directory for gdbm.h and dbm.h.
-includedir = $(prefix)/include
-# Info and man directories.
-infodir = $(prefix)/info
-man3dir = $(prefix)/man/man3
-manext = 3
+prefix = @prefix@
+exec_prefix = @exec_prefix@
+datarootdir = @datarootdir@
+mandir = @mandir@
+libdir = @libdir@
+includedir = @includedir@
+pkgincludedir = $(includedir)/gdbm
+infodir = @infodir@
+man3dir = $(mandir)/man3
#### End of system configuration section. ####
@@ -120,20 +113,16 @@
progs: $(PROGS)
install: libgdbm.la gdbm.h gdbm.info
- $(srcdir)/mkinstalldirs $(libdir) $(includedir) $(man3dir) $(infodir)
- $(LIBTOOL) install -c libgdbm.la $(libdir)/libgdbm.la
- $(INSTALL_DATA) -o $(BINOWN) -g $(BINGRP) gdbm.h $(includedir)/gdbm.h
- $(INSTALL_DATA) -o $(BINOWN) -g $(BINGRP) $(srcdir)/gdbm.3 \
- $(man3dir)/gdbm.3
- $(INSTALL_DATA) -o $(BINOWN) -g $(BINGRP) $(srcdir)/gdbm.info \
- $(infodir)/gdbm.info
+ $(srcdir)/mkinstalldirs $(libdir) $(pkgincludedir) $(man3dir) $(infodir)
+ $(LIBTOOL) install install libgdbm.la $(libdir)/libgdbm.la
+ $(INSTALL_DATA) gdbm.h $(pkgincludedir)/gdbm.h
+ $(INSTALL_DATA) $(srcdir)/gdbm.3 $(man3dir)/gdbm.3
+ $(INSTALL_DATA) $(srcdir)/gdbm.info $(infodir)/gdbm.info
install-compat:
- $(srcdir)/mkinstalldirs $(includedir)
- $(INSTALL_DATA) -o $(BINOWN) -g $(BINGRP) $(srcdir)/dbm.h \
- $(includedir)/dbm.h
- $(INSTALL_DATA) -o $(BINOWN) -g $(BINGRP) $(srcdir)/ndbm.h \
- $(includedir)/ndbm.h
+ $(srcdir)/mkinstalldirs $(pkgincludedir)
+ $(INSTALL_DATA) $(srcdir)/dbm.h $(pkgincludedir)/dbm.h
+ $(INSTALL_DATA) $(srcdir)/ndbm.h $(pkgincludedir)/ndbm.h
#libgdbm.a: $(OBJS) gdbm.h
# rm -f libgdbm.a