re-import sources as agreed with the maintainer

This commit is contained in:
Adam Samalik 2023-06-29 17:16:20 +02:00
parent acbfd0b6de
commit 27941272a0
7 changed files with 187 additions and 1 deletions

5
.gitignore vendored
View File

@ -1,2 +1,5 @@
SOURCES/gdbm-1.18.tar.gz
/gdbm-1.14.tar.gz
/gdbm-1.14.1.tar.gz
/gdbm-1.16.tar.gz
/gdbm-1.17.tar.gz
/gdbm-1.18.tar.gz

11
STAGE2-gdbm Normal file
View File

@ -0,0 +1,11 @@
# awful hack to prevent running aclocal ... FIXME
(cd $SRC/gdbm-*/m4 && [ -f libtool.m4.orig ] && rm -f libtool.m4 && mv libtool.m4.orig libtool.m4) || echo ""
mcd $BUILDDIR/gdbm
echo "Current in: $PWD"
$SRC/gdbm-*/configure $TCONFIGARGS
make $J
make $J install

14
gdbm-1.10-fedora.patch Normal file
View File

@ -0,0 +1,14 @@
diff -up gdbm-1.10/NOTE-WARNING.fedora gdbm-1.10/NOTE-WARNING
--- gdbm-1.10/NOTE-WARNING.fedora 2011-11-14 17:43:41.267566501 +0100
+++ gdbm-1.10/NOTE-WARNING 2011-11-14 17:47:53.312549265 +0100
@@ -12,8 +12,8 @@ systems where it is not the default. `L
when a system uses 64bit file offsets. Gdbm has, of course, supported `large
files' on systems where it was the default for a very long time.
-On some systems, such as Solaris, this functionality is not enabled by
-default. Gdbm will now enable it. THIS MEANS THAT GDBM 1.9 MAY NOT BE
+On some systems this functionality is not enabled by default. To enable it,
+build rpm with option --with=largefile. THIS MEANS THAT GDBM 1.9 MAY NOT BE
ABLE TO ACCESS DATABASES CREATED BY PREVIOUS VERIONS ON THE SAME SYSTEM.
Running the `configure' script with the `--disable-largefile' flag should

18
tests/tests.yml Normal file
View File

@ -0,0 +1,18 @@
---
# Tests that run in classic and container contexts
- hosts: localhost
roles:
- role: standard-test-beakerlib
tags:
- classic
- container
tests:
- testsuite
required_packages:
- gcc # testsuite needs this package
- gettext # testsuite needs this package
- libtool # testsuite needs this package
- make # testsuite needs this package
- readline-devel # testsuite needs this package
- rpm-build # testsuite needs this package
- wget # rlFetchSrcForInstalled needs this package

63
tests/testsuite/Makefile Normal file
View File

@ -0,0 +1,63 @@
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
#
# Makefile of testsuite
# Description: runs test suite from src package
# Author: Vaclav Danek <vdanek@redhat.com>
#
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
#
# Copyright (c) 2017 Red Hat, Inc.
#
# This program is free software: you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
# published by the Free Software Foundation, either version 2 of
# the License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be
# useful, but WITHOUT ANY WARRANTY; without even the implied
# warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
# PURPOSE. See the GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program. If not, see http://www.gnu.org/licenses/.
#
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
export TEST=testsuite
export TESTVERSION=1.0
BUILT_FILES=
FILES=$(METADATA) runtest.sh Makefile PURPOSE
.PHONY: all install download clean
run: $(FILES) build
./runtest.sh
build: $(BUILT_FILES)
test -x runtest.sh || chmod a+x runtest.sh
clean:
rm -f *~ $(BUILT_FILES)
include /usr/share/rhts/lib/rhts-make.include
$(METADATA): Makefile
@echo "Owner: Vaclav Danek <vdanek@redhat.com>" > $(METADATA)
@echo "Name: $(TEST)" >> $(METADATA)
@echo "TestVersion: $(TESTVERSION)" >> $(METADATA)
@echo "Path: $(TEST_DIR)" >> $(METADATA)
@echo "Description: runs test suite from src package" >> $(METADATA)
@echo "Type: Sanity" >> $(METADATA)
@echo "TestTime: 5m" >> $(METADATA)
@echo "RunFor: gdbm" >> $(METADATA)
@echo "Requires: gdbm libtool readline-devel" >> $(METADATA)
@echo "Priority: Normal" >> $(METADATA)
@echo "License: GPLv2+" >> $(METADATA)
@echo "Confidential: no" >> $(METADATA)
@echo "Destructive: no" >> $(METADATA)
@echo "Releases: -RHEL4 -RHELClient5 -RHELServer5 -RHEL6" >> $(METADATA)
rhts-lint $(METADATA)

3
tests/testsuite/PURPOSE Normal file
View File

@ -0,0 +1,3 @@
PURPOSE of testsuite
Description: runs test suite from src package
Author: Vaclav Danek <vdanek@redhat.com>

View File

@ -0,0 +1,74 @@
#!/bin/bash
# vim: dict+=/usr/share/beakerlib/dictionary.vim cpt=.,w,b,u,t,i,k
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
#
# runtest.sh of testsuite
# Description: runs test suite from src package
# Author: Vaclav Danek <vdanek@redhat.com>
#
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
#
# Copyright (c) 2017 Red Hat, Inc.
#
# This program is free software: you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
# published by the Free Software Foundation, either version 2 of
# the License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be
# useful, but WITHOUT ANY WARRANTY; without even the implied
# warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
# PURPOSE. See the GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program. If not, see http://www.gnu.org/licenses/.
#
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# Include Beaker environment
[ -e /usr/bin/rhts-environment.sh ] && . /usr/bin/rhts-environment.sh
. /usr/share/beakerlib/beakerlib.sh || exit 1
PACKAGE="gdbm"
rlJournalStart
rlPhaseStartSetup
rlAssertRpm $PACKAGE
rlRun "TmpDir=\$(mktemp -d)" 0 "Creating tmp directory"
rlRun "pushd $TmpDir"
# fetch srpm
rlRun "rlFetchSrcForInstalled $PACKAGE || yumdownloader --enablerepo='*' --source $PACKAGE" \
0 "Fetching the source rpm"
package=`rpm -q --qf "%{SOURCERPM}" $PACKAGE`
installlog=`mktemp /tmp/install.log.XXXXXX`
rlLog "Using $installlog as installation log"
rlRun "rpm -ivh $TmpDir/$package &> $installlog"
BUILDDIR="$HOME/rpmbuild/BUILD"
SPECDIR="$HOME/rpmbuild/SPECS"
rlPhaseEnd
rlPhaseStartTest
rlRun "cd /root/rpmbuild"
rlRun "rpmbuild -bp $SPECDIR/$PACKAGE.spec"
rlRun "cd $BUILDDIR"
rlRun "cd gdbm-*"
if rlGetPrimaryArch == 'ppc64le'; then
rlRun "./configure --disable-static --enable-libgdbm-compat --build=ppc64le-redhat-linux-gnu --host=ppc64le-redhat-linux-gnu"
else
rlRun "./configure --disable-static --enable-libgdbm-compat"
fi
rlRun "make check"
rlRun "ls | grep -v tests | xargs rm -rf"
rlRun "cd tests"
rlRun "rm -f testsuite.log"
rlRun "./testsuite"
rlAssertGrep "All .* tests were successful." testsuite.log
rlPhaseEnd
rlPhaseStartCleanup
rlRun "popd"
rlRun "rm -r $TmpDir" 0 "Removing tmp directory"
rlRun "rm -rf /root/rpmbuild"
rlPhaseEnd
rlJournalPrintText
rlJournalEnd