auto-import changelog data from gdbm-1.8.0-5.src.rpm
Thu Jul 13 2000 Prospector <bugzilla@redhat.com> - automatic rebuild Mon Jun 05 2000 Jeff Johnson <jbj@redhat.com> - FHS packaging. Mon Feb 07 2000 Bill Nottingham <notting@redhat.com> - handle compressed manpages Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com> - make sure created database header is initialized (#4457). Tue Jun 01 1999 Jeff Johnson <jbj@redhat.com> - update to 1.8.0. - repackage to include /usr/include/gdbm/*dbm.h compatibility includes. Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> - auto rebuild in the new build environment (release 19) Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com> - build against glibc 2.1 Thu May 07 1998 Prospector System <bugs@redhat.com> - translations modified for de, fr, tr Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com> - gdbm-devel moved to Development/Libraries Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com> - buildroot and built for Manhattan Tue Oct 14 1997 Donnie Barnes <djb@redhat.com> - spec file cleanups Thu Jun 12 1997 Erik Troan <ewt@redhat.com> - built against glibc
This commit is contained in:
parent
f4b7cb8da1
commit
26a6efeaa1
@ -0,0 +1 @@
|
|||||||
|
gdbm-1.8.0.tar.gz
|
56
gdbm-1.8.0-fhs.patch
Normal file
56
gdbm-1.8.0-fhs.patch
Normal file
@ -0,0 +1,56 @@
|
|||||||
|
--- gdbm-1.8.0/Makefile.in.fhs Mon Jun 5 15:12:15 2000
|
||||||
|
+++ gdbm-1.8.0/Makefile.in Mon Jun 5 15:16:34 2000
|
||||||
|
@@ -14,10 +14,6 @@
|
||||||
|
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||||
|
INSTALL_DATA = @INSTALL_DATA@
|
||||||
|
|
||||||
|
-# File ownership and group
|
||||||
|
-BINOWN = bin
|
||||||
|
-BINGRP = bin
|
||||||
|
-
|
||||||
|
MAKEINFO = makeinfo
|
||||||
|
TEXI2DVI = texi2dvi
|
||||||
|
|
||||||
|
@@ -33,8 +29,7 @@
|
||||||
|
# Common prefix for installation directories
|
||||||
|
prefix = /usr/local
|
||||||
|
exec_prefix = $(prefix)
|
||||||
|
-binprefix = $(exec_prefix)
|
||||||
|
-manprefix = $(prefix)
|
||||||
|
+mandir = $(prefix)/man
|
||||||
|
|
||||||
|
# Directory in which to put libgdbm.a.
|
||||||
|
libdir = $(exec_prefix)/lib
|
||||||
|
@@ -42,7 +37,7 @@
|
||||||
|
includedir = $(prefix)/include
|
||||||
|
# Info and man directories.
|
||||||
|
infodir = $(prefix)/info
|
||||||
|
-man3dir = $(prefix)/man/man3
|
||||||
|
+man3dir = $(mandir)/man3
|
||||||
|
manext = 3
|
||||||
|
|
||||||
|
#### End of system configuration section. ####
|
||||||
|
@@ -122,18 +117,14 @@
|
||||||
|
install: libgdbm.la gdbm.h gdbm.info
|
||||||
|
$(srcdir)/mkinstalldirs $(libdir) $(includedir) $(man3dir) $(infodir)
|
||||||
|
$(LIBTOOL) install -c libgdbm.la $(libdir)/libgdbm.la
|
||||||
|
- $(INSTALL_DATA) -o $(BINOWN) -g $(BINGRP) gdbm.h $(includedir)/gdbm.h
|
||||||
|
- $(INSTALL_DATA) -o $(BINOWN) -g $(BINGRP) $(srcdir)/gdbm.3 \
|
||||||
|
- $(man3dir)/gdbm.3
|
||||||
|
- $(INSTALL_DATA) -o $(BINOWN) -g $(BINGRP) $(srcdir)/gdbm.info \
|
||||||
|
- $(infodir)/gdbm.info
|
||||||
|
+ $(INSTALL_DATA) gdbm.h $(includedir)/gdbm.h
|
||||||
|
+ $(INSTALL_DATA) $(srcdir)/gdbm.3 $(man3dir)/gdbm.3
|
||||||
|
+ $(INSTALL_DATA) $(srcdir)/gdbm.info $(infodir)/gdbm.info
|
||||||
|
|
||||||
|
install-compat:
|
||||||
|
$(srcdir)/mkinstalldirs $(includedir)
|
||||||
|
- $(INSTALL_DATA) -o $(BINOWN) -g $(BINGRP) $(srcdir)/dbm.h \
|
||||||
|
- $(includedir)/dbm.h
|
||||||
|
- $(INSTALL_DATA) -o $(BINOWN) -g $(BINGRP) $(srcdir)/ndbm.h \
|
||||||
|
- $(includedir)/ndbm.h
|
||||||
|
+ $(INSTALL_DATA) $(srcdir)/dbm.h $(includedir)/dbm.h
|
||||||
|
+ $(INSTALL_DATA) $(srcdir)/ndbm.h $(includedir)/ndbm.h
|
||||||
|
|
||||||
|
#libgdbm.a: $(OBJS) gdbm.h
|
||||||
|
# rm -f libgdbm.a
|
11
gdbm-1.8.0-jbj.patch
Normal file
11
gdbm-1.8.0-jbj.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- gdbm-1.8.0/gdbmopen.c.jbj Tue Aug 10 10:57:38 1999
|
||||||
|
+++ gdbm-1.8.0/gdbmopen.c Tue Aug 10 10:59:06 1999
|
||||||
|
@@ -214,7 +214,7 @@
|
||||||
|
file_block_size = block_size;
|
||||||
|
|
||||||
|
/* Get space for the file header. */
|
||||||
|
- dbf->header = (gdbm_file_header *) malloc (file_block_size);
|
||||||
|
+ dbf->header = (gdbm_file_header *) calloc (1, file_block_size);
|
||||||
|
if (dbf->header == NULL)
|
||||||
|
{
|
||||||
|
gdbm_close (dbf);
|
127
gdbm.spec
Normal file
127
gdbm.spec
Normal file
@ -0,0 +1,127 @@
|
|||||||
|
%{expand: %%global _includedir %{_includedir}/gdbm}
|
||||||
|
|
||||||
|
Summary: A GNU set of database routines which use extensible hashing.
|
||||||
|
Name: gdbm
|
||||||
|
Version: 1.8.0
|
||||||
|
Release: 5
|
||||||
|
Source: ftp://prep.ai.mit.edu/pub/gnu/gdbm-%{version}.tar.gz
|
||||||
|
Patch0: gdbm-1.8.0-jbj.patch
|
||||||
|
Patch1: gdbm-1.8.0-fhs.patch
|
||||||
|
Copyright: GPL
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
Prefix: %{_prefix}
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Gdbm is a GNU database indexing library, including routines which use
|
||||||
|
extensible hashing. Gdbm works in a similar way to standard UNIX dbm
|
||||||
|
routines. Gdbm is useful for developers who write C applications and
|
||||||
|
need access to a simple and efficient database or who are building C
|
||||||
|
applications which will use such a database.
|
||||||
|
|
||||||
|
If you're a C developer and your programs need access to simple
|
||||||
|
database routines, you should install gdbm. You'll also need to
|
||||||
|
install gdbm-devel.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development libraries and header files for the gdbm library.
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: gdbm
|
||||||
|
Prereq: /sbin/install-info
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Gdbm-devel contains the development libraries and header files for
|
||||||
|
gdbm, the GNU database system. These libraries and header files are
|
||||||
|
necessary if you plan to do development using the gdbm database.
|
||||||
|
|
||||||
|
Install gdbm-devel if you are developing C programs which will use the
|
||||||
|
gdbm database library. You'll also need to install the gdbm package.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p 1 -b .jbj
|
||||||
|
%patch1 -p 1 -b .fhs
|
||||||
|
|
||||||
|
%build
|
||||||
|
|
||||||
|
%configure
|
||||||
|
make
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
|
|
||||||
|
%makeinstall install-compat
|
||||||
|
|
||||||
|
{ cd ${RPM_BUILD_ROOT}
|
||||||
|
ln -sf gdbm/gdbm.h .%{_oldincludedir}/gdbm.h
|
||||||
|
ln -sf libgdbm.so.2.0.0 .%{_libdir}/libgdbm.so
|
||||||
|
gzip -9nf .%{_infodir}/gdbm*
|
||||||
|
rm -f .%{_infodir}/dir
|
||||||
|
}
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%post devel
|
||||||
|
/sbin/install-info %{_infodir}/gdbm.info.gz %{_infodir}/dir --entry="* gdbm: (gdbm). The GNU Database."
|
||||||
|
|
||||||
|
%preun devel
|
||||||
|
if [ $1 = 0 ]; then
|
||||||
|
/sbin/install-info --delete %{_infodir}/gdbm.info.gz %{_infodir}/dir --entry="* gdbm: (gdbm). The GNU Database."
|
||||||
|
fi
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libgdbm.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libgdbm.so
|
||||||
|
%{_libdir}/libgdbm.la
|
||||||
|
%{_libdir}/libgdbm.a
|
||||||
|
%{_oldincludedir}/gdbm.h
|
||||||
|
%{_includedir}
|
||||||
|
%{_infodir}/*.info*
|
||||||
|
%{_mandir}/man3/*
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
|
||||||
|
- automatic rebuild
|
||||||
|
|
||||||
|
* Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
|
||||||
|
- FHS packaging.
|
||||||
|
|
||||||
|
* Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
|
||||||
|
- handle compressed manpages
|
||||||
|
|
||||||
|
* Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com>
|
||||||
|
- make sure created database header is initialized (#4457).
|
||||||
|
|
||||||
|
* Tue Jun 1 1999 Jeff Johnson <jbj@redhat.com>
|
||||||
|
- update to 1.8.0.
|
||||||
|
- repackage to include /usr/include/gdbm/*dbm.h compatibility includes.
|
||||||
|
|
||||||
|
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
|
||||||
|
- auto rebuild in the new build environment (release 19)
|
||||||
|
|
||||||
|
* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
|
||||||
|
- build against glibc 2.1
|
||||||
|
|
||||||
|
* Thu May 07 1998 Prospector System <bugs@redhat.com>
|
||||||
|
- translations modified for de, fr, tr
|
||||||
|
|
||||||
|
* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
|
||||||
|
- gdbm-devel moved to Development/Libraries
|
||||||
|
|
||||||
|
* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
|
||||||
|
- buildroot and built for Manhattan
|
||||||
|
|
||||||
|
* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
|
||||||
|
- spec file cleanups
|
||||||
|
|
||||||
|
* Thu Jun 12 1997 Erik Troan <ewt@redhat.com>
|
||||||
|
- built against glibc
|
Loading…
Reference in New Issue
Block a user