36474ab6e8
http://sourceware.org/gdb/wiki/PythonGdb [catch-syscall] Trap and display syscalls. [delayed-symfile] Improve startup performance by lazily read psymtabs. [exception-rewind] Fix fatal C++ exceptions in an inferior function call. [expr] Expressions, single-quote elimination, C++ input canonicalization. [using-directive] C++ namespaces. [vla] C variable length arrays / DW_FORM_block / Fortran dynamic arrays. [misc] Fix debuginfoless `return' (BZ 365111), fix command-line macros for expected GCC (BZ 479914), new testcase for valgrind (for BZ 483262), implement `info common' for Fortran, fix Fortran logical-kind=8 (BZ 465310), fix static variable in C++ constructors (BZ 445912), fix power7 (BZ 485319). - Upgrade to the FSF GDB gdb-6.8.50 snapshot. - Fix parsing elf64-i386 files for kdump PAE vmcore dumps (BZ 457187). - Turn on 64-bit BFD support, globally enable AC_SYS_LARGEFILE.
424 lines
12 KiB
Diff
424 lines
12 KiB
Diff
gdb/
|
|
2009-03-02 Jan Kratochvil <jan.kratochvil@redhat.com>
|
|
|
|
* configure.ac: Call AC_SYS_LARGEFILE.
|
|
* config.in: Regenerate.
|
|
* configure: Regenerate.
|
|
|
|
diff -up -rup gdb-orig/configure.ac gdb/configure.ac
|
|
--- ./gdb-orig/configure.ac 2009-03-02 23:39:01.000000000 +0100
|
|
+++ ./gdb/configure.ac 2009-03-02 23:40:46.000000000 +0100
|
|
@@ -30,6 +30,7 @@ AC_GNU_SOURCE
|
|
AC_AIX
|
|
AC_ISC_POSIX
|
|
gl_EARLY
|
|
+AC_SYS_LARGEFILE
|
|
AM_PROG_CC_STDC
|
|
|
|
AC_CONFIG_AUX_DIR(..)
|
|
diff -up -rup gdb-orig/config.in gdb/config.in
|
|
--- ./gdb-orig/config.in 2009-03-02 23:39:01.000000000 +0100
|
|
+++ ./gdb/config.in 2009-03-02 23:40:53.000000000 +0100
|
|
@@ -725,6 +725,9 @@
|
|
# undef _ALL_SOURCE
|
|
#endif
|
|
|
|
+/* Number of bits in a file offset, on hosts where this is settable. */
|
|
+#undef _FILE_OFFSET_BITS
|
|
+
|
|
/* Enable GNU extensions on systems that have them. */
|
|
#ifndef _GNU_SOURCE
|
|
# undef _GNU_SOURCE
|
|
@@ -734,6 +737,9 @@
|
|
<sys/proc.h> problem on IRIX 5. */
|
|
#undef _KMEMUSER
|
|
|
|
+/* Define for large files, on AIX-style hosts. */
|
|
+#undef _LARGE_FILES
|
|
+
|
|
/* Define to 1 if on MINIX. */
|
|
#undef _MINIX
|
|
|
|
diff -up -rup gdb-orig/configure gdb/configure
|
|
--- ./gdb-orig/configure 2009-03-02 23:39:01.000000000 +0100
|
|
+++ ./gdb/configure 2009-03-02 23:40:49.000000000 +0100
|
|
@@ -862,6 +862,7 @@ Optional Features:
|
|
--enable-FEATURE[=ARG] include FEATURE [ARG=yes]
|
|
--enable-maintainer-mode enable make rules and dependencies not useful
|
|
(and sometimes confusing) to the casual installer
|
|
+ --disable-largefile omit support for large files
|
|
--disable-dependency-tracking speeds up one-time build
|
|
--enable-dependency-tracking do not reject slow dependency extractors
|
|
--enable-targets alternative target configurations
|
|
@@ -3313,6 +3314,370 @@ _ACEOF
|
|
|
|
|
|
|
|
+# Check whether --enable-largefile or --disable-largefile was given.
|
|
+if test "${enable_largefile+set}" = set; then
|
|
+ enableval="$enable_largefile"
|
|
+
|
|
+fi;
|
|
+if test "$enable_largefile" != no; then
|
|
+
|
|
+ echo "$as_me:$LINENO: checking for special C compiler options needed for large files" >&5
|
|
+echo $ECHO_N "checking for special C compiler options needed for large files... $ECHO_C" >&6
|
|
+if test "${ac_cv_sys_largefile_CC+set}" = set; then
|
|
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
|
+else
|
|
+ ac_cv_sys_largefile_CC=no
|
|
+ if test "$GCC" != yes; then
|
|
+ ac_save_CC=$CC
|
|
+ while :; do
|
|
+ # IRIX 6.2 and later do not support large files by default,
|
|
+ # so use the C compiler's -n32 option if that helps.
|
|
+ cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+#include <sys/types.h>
|
|
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
|
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
|
+ since some C++ compilers masquerading as C compilers
|
|
+ incorrectly reject 9223372036854775807. */
|
|
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
|
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
|
+ && LARGE_OFF_T % 2147483647 == 1)
|
|
+ ? 1 : -1];
|
|
+int
|
|
+main ()
|
|
+{
|
|
+
|
|
+ ;
|
|
+ return 0;
|
|
+}
|
|
+_ACEOF
|
|
+ rm -f conftest.$ac_objext
|
|
+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
|
+ (eval $ac_compile) 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } &&
|
|
+ { ac_try='test -z "$ac_c_werror_flag"
|
|
+ || test ! -s conftest.err'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; } &&
|
|
+ { ac_try='test -s conftest.$ac_objext'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; }; then
|
|
+ break
|
|
+else
|
|
+ echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+fi
|
|
+rm -f conftest.err conftest.$ac_objext
|
|
+ CC="$CC -n32"
|
|
+ rm -f conftest.$ac_objext
|
|
+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
|
+ (eval $ac_compile) 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } &&
|
|
+ { ac_try='test -z "$ac_c_werror_flag"
|
|
+ || test ! -s conftest.err'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; } &&
|
|
+ { ac_try='test -s conftest.$ac_objext'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; }; then
|
|
+ ac_cv_sys_largefile_CC=' -n32'; break
|
|
+else
|
|
+ echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+fi
|
|
+rm -f conftest.err conftest.$ac_objext
|
|
+ break
|
|
+ done
|
|
+ CC=$ac_save_CC
|
|
+ rm -f conftest.$ac_ext
|
|
+ fi
|
|
+fi
|
|
+echo "$as_me:$LINENO: result: $ac_cv_sys_largefile_CC" >&5
|
|
+echo "${ECHO_T}$ac_cv_sys_largefile_CC" >&6
|
|
+ if test "$ac_cv_sys_largefile_CC" != no; then
|
|
+ CC=$CC$ac_cv_sys_largefile_CC
|
|
+ fi
|
|
+
|
|
+ echo "$as_me:$LINENO: checking for _FILE_OFFSET_BITS value needed for large files" >&5
|
|
+echo $ECHO_N "checking for _FILE_OFFSET_BITS value needed for large files... $ECHO_C" >&6
|
|
+if test "${ac_cv_sys_file_offset_bits+set}" = set; then
|
|
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
|
+else
|
|
+ while :; do
|
|
+ ac_cv_sys_file_offset_bits=no
|
|
+ cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+#include <sys/types.h>
|
|
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
|
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
|
+ since some C++ compilers masquerading as C compilers
|
|
+ incorrectly reject 9223372036854775807. */
|
|
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
|
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
|
+ && LARGE_OFF_T % 2147483647 == 1)
|
|
+ ? 1 : -1];
|
|
+int
|
|
+main ()
|
|
+{
|
|
+
|
|
+ ;
|
|
+ return 0;
|
|
+}
|
|
+_ACEOF
|
|
+rm -f conftest.$ac_objext
|
|
+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
|
+ (eval $ac_compile) 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } &&
|
|
+ { ac_try='test -z "$ac_c_werror_flag"
|
|
+ || test ! -s conftest.err'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; } &&
|
|
+ { ac_try='test -s conftest.$ac_objext'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; }; then
|
|
+ break
|
|
+else
|
|
+ echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+fi
|
|
+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
+ cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+#define _FILE_OFFSET_BITS 64
|
|
+#include <sys/types.h>
|
|
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
|
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
|
+ since some C++ compilers masquerading as C compilers
|
|
+ incorrectly reject 9223372036854775807. */
|
|
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
|
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
|
+ && LARGE_OFF_T % 2147483647 == 1)
|
|
+ ? 1 : -1];
|
|
+int
|
|
+main ()
|
|
+{
|
|
+
|
|
+ ;
|
|
+ return 0;
|
|
+}
|
|
+_ACEOF
|
|
+rm -f conftest.$ac_objext
|
|
+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
|
+ (eval $ac_compile) 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } &&
|
|
+ { ac_try='test -z "$ac_c_werror_flag"
|
|
+ || test ! -s conftest.err'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; } &&
|
|
+ { ac_try='test -s conftest.$ac_objext'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; }; then
|
|
+ ac_cv_sys_file_offset_bits=64; break
|
|
+else
|
|
+ echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+fi
|
|
+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
+ break
|
|
+done
|
|
+fi
|
|
+echo "$as_me:$LINENO: result: $ac_cv_sys_file_offset_bits" >&5
|
|
+echo "${ECHO_T}$ac_cv_sys_file_offset_bits" >&6
|
|
+if test "$ac_cv_sys_file_offset_bits" != no; then
|
|
+
|
|
+cat >>confdefs.h <<_ACEOF
|
|
+#define _FILE_OFFSET_BITS $ac_cv_sys_file_offset_bits
|
|
+_ACEOF
|
|
+
|
|
+fi
|
|
+rm -f conftest*
|
|
+ echo "$as_me:$LINENO: checking for _LARGE_FILES value needed for large files" >&5
|
|
+echo $ECHO_N "checking for _LARGE_FILES value needed for large files... $ECHO_C" >&6
|
|
+if test "${ac_cv_sys_large_files+set}" = set; then
|
|
+ echo $ECHO_N "(cached) $ECHO_C" >&6
|
|
+else
|
|
+ while :; do
|
|
+ ac_cv_sys_large_files=no
|
|
+ cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+#include <sys/types.h>
|
|
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
|
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
|
+ since some C++ compilers masquerading as C compilers
|
|
+ incorrectly reject 9223372036854775807. */
|
|
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
|
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
|
+ && LARGE_OFF_T % 2147483647 == 1)
|
|
+ ? 1 : -1];
|
|
+int
|
|
+main ()
|
|
+{
|
|
+
|
|
+ ;
|
|
+ return 0;
|
|
+}
|
|
+_ACEOF
|
|
+rm -f conftest.$ac_objext
|
|
+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
|
+ (eval $ac_compile) 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } &&
|
|
+ { ac_try='test -z "$ac_c_werror_flag"
|
|
+ || test ! -s conftest.err'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; } &&
|
|
+ { ac_try='test -s conftest.$ac_objext'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; }; then
|
|
+ break
|
|
+else
|
|
+ echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+fi
|
|
+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
+ cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+#define _LARGE_FILES 1
|
|
+#include <sys/types.h>
|
|
+ /* Check that off_t can represent 2**63 - 1 correctly.
|
|
+ We can't simply define LARGE_OFF_T to be 9223372036854775807,
|
|
+ since some C++ compilers masquerading as C compilers
|
|
+ incorrectly reject 9223372036854775807. */
|
|
+#define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
|
|
+ int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
|
|
+ && LARGE_OFF_T % 2147483647 == 1)
|
|
+ ? 1 : -1];
|
|
+int
|
|
+main ()
|
|
+{
|
|
+
|
|
+ ;
|
|
+ return 0;
|
|
+}
|
|
+_ACEOF
|
|
+rm -f conftest.$ac_objext
|
|
+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
|
+ (eval $ac_compile) 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } &&
|
|
+ { ac_try='test -z "$ac_c_werror_flag"
|
|
+ || test ! -s conftest.err'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; } &&
|
|
+ { ac_try='test -s conftest.$ac_objext'
|
|
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
|
+ (eval $ac_try) 2>&5
|
|
+ ac_status=$?
|
|
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); }; }; then
|
|
+ ac_cv_sys_large_files=1; break
|
|
+else
|
|
+ echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+fi
|
|
+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
+ break
|
|
+done
|
|
+fi
|
|
+echo "$as_me:$LINENO: result: $ac_cv_sys_large_files" >&5
|
|
+echo "${ECHO_T}$ac_cv_sys_large_files" >&6
|
|
+if test "$ac_cv_sys_large_files" != no; then
|
|
+
|
|
+cat >>confdefs.h <<_ACEOF
|
|
+#define _LARGE_FILES $ac_cv_sys_large_files
|
|
+_ACEOF
|
|
+
|
|
+fi
|
|
+rm -f conftest*
|
|
+fi
|
|
+
|
|
|
|
|
|
|