ebdac5bb6e
Update local patches: gdb-6.5-bz185337-resolve-tls-without-debuginfo-v2.patch gdb-6.6-buildid-locate-rpm.patch gdb-6.6-buildid-locate.patch gdb-container-rh-pkg.patch gdb-core-open-vdso-warning.patch gdb-fedora-libncursesw.patch gdb-linux_perf-bundle.patch Update backported patches which didn't make it into 14.1: gdb-rhbz-2232086-cpp-ify-mapped-symtab.patch gdb-rhbz-2232086-generate-gdb-index-consistently.patch Drop upstreamed local patches: gdb-6.5-sharedlibrary-path.patch Drop gdb-13.2 backports (which are now in gdb-14.1): gdb-binutils29988-read_indexed_address.patch gdb-bz2196395-debuginfod-legacy-openssl-crash.patch gdb-bz2237392-dwarf-obstack-allocation.patch gdb-bz2237515-debuginfod-double-free.patch gdb-rhbz2192105-ftbs-dangling-pointer gdb-rhbz2233961-CVE-2022-4806.patch gdb-rhbz2233965-memory-leak.patch Adjust gdb.spec so that --with-mpfr is no longer passed to configure; doing so, combined with some configury changes triggered a latent build problem.
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
|
From: Fedora GDB patches <invalid@email.com>
|
|
Date: Fri, 27 Oct 2017 21:07:50 +0200
|
|
Subject: gdb-container-rh-pkg.patch
|
|
|
|
;; Add messages suggesting more recent RHEL gdbserver (RH BZ 1321114).
|
|
;;=fedora
|
|
|
|
diff --git a/gdb/remote.c b/gdb/remote.c
|
|
--- a/gdb/remote.c
|
|
+++ b/gdb/remote.c
|
|
@@ -14742,7 +14742,17 @@ remote_target::pid_to_exec_file (int pid)
|
|
char *annex = NULL;
|
|
|
|
if (m_features.packet_support (PACKET_qXfer_exec_file) != PACKET_ENABLE)
|
|
- return NULL;
|
|
+ {
|
|
+ warning (_("Remote gdbserver does not support determining executable "
|
|
+ "automatically.\n"
|
|
+"RHEL <=6.8 and <=7.2 versions of gdbserver do not support such automatic executable detection.\n"
|
|
+"The following versions of gdbserver support it:\n"
|
|
+"- Upstream version of gdbserver (unsupported) 7.10 or later\n"
|
|
+"- Red Hat Developer Toolset (DTS) version of gdbserver from DTS 4.0 or later (only on x86_64)\n"
|
|
+"- RHEL-7.3 versions of gdbserver (on any architecture)"
|
|
+));
|
|
+ return NULL;
|
|
+ }
|
|
|
|
inferior *inf = find_inferior_pid (this, pid);
|
|
if (inf == NULL)
|