8336d588bf
- Fix prelink(8) testcase for non-root $PATH missing `/usr/sbin' (BZ 225783). - Fix debugging GDB itself - the compiled in source files paths (BZ 225783). - Fix harmless GCORE stack buffer overflow, by _FORTIFY_SOURCE=2 (BZ 235753). - Fix XML support - the build was missing `expat-devel'. - Updated the `info' files handling by the spec file. - Building now with the standard Fedora code protections - _FORTIFY_SOURCE=2. - Use multiple CPUs for the build (%{?_smp_mflags}). - Separate testsuite run to its %check section. - Fix (remove) non-ASCII spec file characters. - Remove system tools versions dumping - already present in mock build logs. - Reverts: rhbz#235197 - Related: rhbz#235197 rhbz#225783 - Resolves: rhbz#235753
31 lines
990 B
Diff
31 lines
990 B
Diff
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=225783
|
|
|
|
|
|
--- gdb-6.6-orig/gdb/Makefile.in 2007-04-08 20:49:10.000000000 +0200
|
|
+++ gdb-6.6/gdb/Makefile.in 2007-04-08 23:22:40.000000000 +0200
|
|
@@ -1672,17 +1672,19 @@ po/$(PACKAGE).pot: force
|
|
|
|
.SUFFIXES: .y .l
|
|
.y.c:
|
|
- $(SHELL) $(YLWRAP) $< y.tab.c $@.tmp -- $(YACC) $(YFLAGS)
|
|
- -sed -e '/extern.*malloc/d' \
|
|
+ rm -f $@ $@.tmp
|
|
+ $(SHELL) $(YLWRAP) $< y.tab.c $@ -- $(YACC) $(YFLAGS) && mv $@ $@.tmp \
|
|
+ || (rm -f $@; false)
|
|
+ sed -e '/extern.*malloc/d' \
|
|
-e '/extern.*realloc/d' \
|
|
-e '/extern.*free/d' \
|
|
-e '/include.*malloc.h/d' \
|
|
-e 's/\([^x]\)malloc/\1xmalloc/g' \
|
|
-e 's/\([^x]\)realloc/\1xrealloc/g' \
|
|
-e '/^#line.*y.tab.c/d' \
|
|
- < $@.tmp > $@.new
|
|
- -rm $@.tmp
|
|
- mv $@.new ./$*.c
|
|
+ -e "s/^\(#line.*\)`basename $<`/\1`echo $<|sed 's/\//\\\\\//g'`/" \
|
|
+ < $@.tmp > $@
|
|
+ rm -f $@.tmp
|
|
.l.c:
|
|
if [ "$(FLEX)" ] && $(FLEX) --version >/dev/null 2>&1; then \
|
|
$(FLEX) -o$@ $< && \
|