a8767b37e5
- chmod +x on the generate-*.sh script.s - Remove references to gdb-8.0.1 from 'sources' and '.gitignore'. - Regenerate first line of the patches (remove commit hash). - Fix empty Source line.
58 lines
1.9 KiB
Diff
58 lines
1.9 KiB
Diff
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
|
From: Fedora GDB patches <invalid@email.com>
|
|
Date: Fri, 27 Oct 2017 21:07:50 +0200
|
|
Subject: gdb-jit-reader-multilib.patch
|
|
|
|
FileName: gdb-jit-reader-multilib.patch
|
|
|
|
;; Fix jit-reader.h for multi-lib.
|
|
;;=push+jan
|
|
---
|
|
gdb/configure | 8 +++++---
|
|
gdb/configure.ac | 8 +++++---
|
|
2 files changed, 10 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/gdb/configure b/gdb/configure
|
|
index d99f28b9f2..01210afccc 100755
|
|
--- a/gdb/configure
|
|
+++ b/gdb/configure
|
|
@@ -9528,10 +9528,12 @@ _ACEOF
|
|
|
|
|
|
|
|
-if test "x${ac_cv_sizeof_unsigned_long}" = "x8"; then
|
|
- TARGET_PTR="unsigned long"
|
|
-elif test "x${ac_cv_sizeof_unsigned_long_long}" = "x8"; then
|
|
+# Try to keep TARGET_PTR the same across archs so that jit-reader.h file
|
|
+# content is the same for multilib distributions.
|
|
+if test "x${ac_cv_sizeof_unsigned_long_long}" = "x8"; then
|
|
TARGET_PTR="unsigned long long"
|
|
+elif test "x${ac_cv_sizeof_unsigned_long}" = "x8"; then
|
|
+ TARGET_PTR="unsigned long"
|
|
elif test "x${ac_cv_sizeof_unsigned___int128}" = "x16"; then
|
|
TARGET_PTR="unsigned __int128"
|
|
else
|
|
diff --git a/gdb/configure.ac b/gdb/configure.ac
|
|
index 830618dbe5..8c6a5f7d1e 100644
|
|
--- a/gdb/configure.ac
|
|
+++ b/gdb/configure.ac
|
|
@@ -832,10 +832,12 @@ AC_CHECK_SIZEOF(unsigned long long)
|
|
AC_CHECK_SIZEOF(unsigned long)
|
|
AC_CHECK_SIZEOF(unsigned __int128)
|
|
|
|
-if test "x${ac_cv_sizeof_unsigned_long}" = "x8"; then
|
|
- TARGET_PTR="unsigned long"
|
|
-elif test "x${ac_cv_sizeof_unsigned_long_long}" = "x8"; then
|
|
+# Try to keep TARGET_PTR the same across archs so that jit-reader.h file
|
|
+# content is the same for multilib distributions.
|
|
+if test "x${ac_cv_sizeof_unsigned_long_long}" = "x8"; then
|
|
TARGET_PTR="unsigned long long"
|
|
+elif test "x${ac_cv_sizeof_unsigned_long}" = "x8"; then
|
|
+ TARGET_PTR="unsigned long"
|
|
elif test "x${ac_cv_sizeof_unsigned___int128}" = "x16"; then
|
|
TARGET_PTR="unsigned __int128"
|
|
else
|
|
--
|
|
2.14.3
|
|
|