Reapply self test patch to 6.3.
This commit is contained in:
parent
84cb84b0ba
commit
f5d570986d
93
gdb-6.3-test-self-20050110.patch
Normal file
93
gdb-6.3-test-self-20050110.patch
Normal file
@ -0,0 +1,93 @@
|
|||||||
|
2004-02-23 Elena Zannoni <ezannoni@redhat.com>
|
||||||
|
|
||||||
|
* gdb.gdb/selftest.exp: Make sure that the debug directory is
|
||||||
|
set up properly.
|
||||||
|
* gdb.gdb/complaints.exp: Ditto.
|
||||||
|
* gdb.gdb/xfullpath.exp: Ditto.
|
||||||
|
* gdb.gdb/observer.exp: Ditto.
|
||||||
|
|
||||||
|
--- gdb-6.3/gdb/testsuite/gdb.gdb/complaints.exp.fix Mon Jan 10 19:21:20 2005
|
||||||
|
+++ gdb-6.3/gdb/testsuite/gdb.gdb/complaints.exp Mon Jan 10 19:24:38 2005
|
||||||
|
@@ -304,13 +304,13 @@ proc find_gdb { arg } {
|
||||||
|
set GDB_FULLPATH [find_gdb $GDB]
|
||||||
|
|
||||||
|
# Remove any old copy lying around.
|
||||||
|
-remote_file host delete x$tool
|
||||||
|
+#remote_file host delete x$tool
|
||||||
|
|
||||||
|
gdb_start
|
||||||
|
|
||||||
|
-set file [remote_download host $GDB_FULLPATH x$tool]
|
||||||
|
+#set file [remote_download host $GDB_FULLPATH x$tool]
|
||||||
|
|
||||||
|
-set setup_result [setup_test $file ]
|
||||||
|
+set setup_result [setup_test $GDB_FULLPATH ]
|
||||||
|
if {$setup_result <0} then {
|
||||||
|
return -1
|
||||||
|
}
|
||||||
|
@@ -321,4 +321,4 @@ test_short_complaints
|
||||||
|
test_empty_complaints
|
||||||
|
|
||||||
|
gdb_exit;
|
||||||
|
-catch "remote_file host delete $file";
|
||||||
|
+#catch "remote_file host delete $file";
|
||||||
|
--- gdb-6.3/gdb/testsuite/gdb.gdb/observer.exp.fix Mon Jan 10 19:21:27 2005
|
||||||
|
+++ gdb-6.3/gdb/testsuite/gdb.gdb/observer.exp Mon Jan 10 19:24:38 2005
|
||||||
|
@@ -259,13 +259,13 @@ proc find_gdb { arg } {
|
||||||
|
set GDB_FULLPATH [find_gdb $GDB]
|
||||||
|
|
||||||
|
# Remove any old copy lying around.
|
||||||
|
-remote_file host delete x$tool
|
||||||
|
+#remote_file host delete x$tool
|
||||||
|
|
||||||
|
gdb_start
|
||||||
|
-set file [remote_download host $GDB_FULLPATH x$tool]
|
||||||
|
-set result [test_observer_normal_stop $file];
|
||||||
|
+#set file [remote_download host $GDB_FULLPATH x$tool]
|
||||||
|
+set result [test_observer_normal_stop $GDB_FULLPATH];
|
||||||
|
gdb_exit;
|
||||||
|
-catch "remote_file host delete $file";
|
||||||
|
+#catch "remote_file host delete $file";
|
||||||
|
|
||||||
|
if {$result <0} then {
|
||||||
|
warning "Couldn't test self"
|
||||||
|
--- gdb-6.3/gdb/testsuite/gdb.gdb/selftest.exp.fix Mon Jan 10 19:21:33 2005
|
||||||
|
+++ gdb-6.3/gdb/testsuite/gdb.gdb/selftest.exp Mon Jan 10 19:24:38 2005
|
||||||
|
@@ -512,13 +512,13 @@ proc find_gdb { arg } {
|
||||||
|
set GDB_FULLPATH [find_gdb $GDB]
|
||||||
|
|
||||||
|
# Remove any old copy lying around.
|
||||||
|
-remote_file host delete x$tool
|
||||||
|
+#remote_file host delete x$tool
|
||||||
|
|
||||||
|
gdb_start
|
||||||
|
-set file [remote_download host $GDB_FULLPATH x$tool]
|
||||||
|
-set result [test_with_self $file];
|
||||||
|
+#set file [remote_download host $GDB_FULLPATH x$tool]
|
||||||
|
+set result [test_with_self $GDB_FULLPATH];
|
||||||
|
gdb_exit;
|
||||||
|
-catch "remote_file host delete $file";
|
||||||
|
+#catch "remote_file host delete $file";
|
||||||
|
|
||||||
|
if {$result <0} then {
|
||||||
|
warning "Couldn't test self"
|
||||||
|
--- gdb-6.3/gdb/testsuite/gdb.gdb/xfullpath.exp.fix Mon Jan 10 19:21:40 2005
|
||||||
|
+++ gdb-6.3/gdb/testsuite/gdb.gdb/xfullpath.exp Mon Jan 10 19:24:38 2005
|
||||||
|
@@ -181,13 +181,13 @@ proc find_gdb { arg } {
|
||||||
|
set GDB_FULLPATH [find_gdb $GDB]
|
||||||
|
|
||||||
|
# Remove any old copy lying around.
|
||||||
|
-remote_file host delete x$tool
|
||||||
|
+#remote_file host delete x$tool
|
||||||
|
|
||||||
|
gdb_start
|
||||||
|
-set file [remote_download host $GDB_FULLPATH x$tool]
|
||||||
|
-set result [test_with_self $file];
|
||||||
|
+#set file [remote_download host $GDB_FULLPATH x$tool]
|
||||||
|
+set result [test_with_self $GDB_FULLPATH];
|
||||||
|
gdb_exit;
|
||||||
|
-catch "remote_file host delete $file";
|
||||||
|
+#catch "remote_file host delete $file";
|
||||||
|
|
||||||
|
if {$result <0} then {
|
||||||
|
warning "Couldn't test self"
|
9
gdb.spec
9
gdb.spec
@ -51,10 +51,6 @@ Patch4: gdb-6.3-rh-testlibunwind1fix-20041202.patch
|
|||||||
#Broken: Patch19: gdb-6.1post-abi-ppccfi-nov2004.patch
|
#Broken: Patch19: gdb-6.1post-abi-ppccfi-nov2004.patch
|
||||||
#Broken: Patch23: gdb-6.1post-abi-ppc64main-aug2004.patch
|
#Broken: Patch23: gdb-6.1post-abi-ppc64main-aug2004.patch
|
||||||
###### Testsuite merge, fixes, and local RH hack
|
###### Testsuite merge, fixes, and local RH hack
|
||||||
# Get selftest working with sep-debug-info
|
|
||||||
#Broken: Patch33: gdb-6.1post-test-self-jul2004.patch
|
|
||||||
# Add --readnever hack, and gstack script
|
|
||||||
#Broken: Patch82: gdb-6.1post-readnever-nov2004.patch
|
|
||||||
# No longer a need to set .malloc on ppc64.
|
# No longer a need to set .malloc on ppc64.
|
||||||
#Broken: Patch85: gdb-6.1post-abi-ppcmalloc-nov2004.patch
|
#Broken: Patch85: gdb-6.1post-abi-ppcmalloc-nov2004.patch
|
||||||
|
|
||||||
@ -147,6 +143,9 @@ Patch123: gdb-6.3-test-pie-20050107.patch
|
|||||||
# Pie support
|
# Pie support
|
||||||
Patch124: gdb-6.3-pie-20050110.patch
|
Patch124: gdb-6.3-pie-20050110.patch
|
||||||
|
|
||||||
|
# Get selftest working with sep-debug-info
|
||||||
|
Patch125: gdb-6.3-test-self-20050110.patch
|
||||||
|
|
||||||
%ifarch ia64
|
%ifarch ia64
|
||||||
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu libunwind >= 0.96-3
|
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu libunwind >= 0.96-3
|
||||||
%else
|
%else
|
||||||
@ -208,6 +207,8 @@ and printing their data.
|
|||||||
%patch123 -p1
|
%patch123 -p1
|
||||||
%patch124 -p1
|
%patch124 -p1
|
||||||
|
|
||||||
|
%patch125 -p1
|
||||||
|
|
||||||
# Change the version that gets printed at GDB startup, so it is RedHat
|
# Change the version that gets printed at GDB startup, so it is RedHat
|
||||||
# specific.
|
# specific.
|
||||||
cat > gdb/version.in << _FOO
|
cat > gdb/version.in << _FOO
|
||||||
|
Loading…
Reference in New Issue
Block a user