Rebase to FSF GDB 8.1.50.20180618 (8.2pre).
This commit is contained in:
parent
4f2cb1818a
commit
f3cfd8cd2d
@ -1 +1 @@
|
||||
1840d81a201932a2d5ad5b089aad85943a5a0a82
|
||||
7010835a6c5fd3679feae7e6345f2f10d4d761b4
|
||||
|
@ -19,7 +19,7 @@ FileName: gdb-6.3-test-self-20050110.patch
|
||||
diff --git a/gdb/testsuite/lib/selftest-support.exp b/gdb/testsuite/lib/selftest-support.exp
|
||||
--- a/gdb/testsuite/lib/selftest-support.exp
|
||||
+++ b/gdb/testsuite/lib/selftest-support.exp
|
||||
@@ -156,18 +156,18 @@ proc do_self_tests {function body} {
|
||||
@@ -151,18 +151,18 @@ proc do_self_tests {function body} {
|
||||
}
|
||||
|
||||
# Remove any old copy lying around.
|
||||
|
@ -981,7 +981,7 @@ diff --git a/gdb/corelow.c b/gdb/corelow.c
|
||||
diff --git a/gdb/doc/gdb.texinfo b/gdb/doc/gdb.texinfo
|
||||
--- a/gdb/doc/gdb.texinfo
|
||||
+++ b/gdb/doc/gdb.texinfo
|
||||
@@ -19561,6 +19561,27 @@ information files.
|
||||
@@ -19562,6 +19562,27 @@ information files.
|
||||
|
||||
@end table
|
||||
|
||||
|
@ -155,7 +155,7 @@ diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
|
||||
if (resume_many)
|
||||
iterate_over_lwps (ptid, linux_nat_resume_callback, lp);
|
||||
|
||||
@@ -3754,6 +3796,10 @@ linux_nat_target::mourn_inferior ()
|
||||
@@ -3760,6 +3802,10 @@ linux_nat_target::mourn_inferior ()
|
||||
|
||||
/* Let the arch-specific native code know this process is gone. */
|
||||
linux_target->low_forget_process (pid);
|
||||
|
@ -17,7 +17,7 @@ https://bugzilla.redhat.com/show_bug.cgi?id=1301175
|
||||
diff --git a/gdb/testsuite/gdb.gdb/selftest.exp b/gdb/testsuite/gdb.gdb/selftest.exp
|
||||
--- a/gdb/testsuite/gdb.gdb/selftest.exp
|
||||
+++ b/gdb/testsuite/gdb.gdb/selftest.exp
|
||||
@@ -104,9 +104,25 @@ proc test_with_self { } {
|
||||
@@ -113,9 +113,25 @@ proc test_with_self { } {
|
||||
}
|
||||
|
||||
set description "send SIGINT signal to child process"
|
||||
|
7
gdb.spec
7
gdb.spec
@ -18,7 +18,7 @@
|
||||
Name: %{?scl_prefix}gdb
|
||||
|
||||
# Freeze it when GDB gets branched
|
||||
%global snapsrc 20180613
|
||||
%global snapsrc 20180618
|
||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||
%global snapgnulib 20161115
|
||||
%global tarname gdb-%{version}
|
||||
@ -26,7 +26,7 @@ Version: 8.1.50.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 22%{?dist}
|
||||
Release: 23%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -1037,6 +1037,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jun 18 2018 Sergio Durigan Junior <sergiodj@redhat.com> - 8.1.50.20180618-23.fc29
|
||||
- Rebase to FSF GDB 8.1.50.20180618 (8.2pre).
|
||||
|
||||
* Mon Jun 18 2018 Sergio Durigan Junior <sergiodj@fedoraproject.org> - 8.1.50.20180613-22.fc29
|
||||
- Do not run /sbin/install-info when installing the documentation
|
||||
(except for DTS).
|
||||
|
Loading…
Reference in New Issue
Block a user