[rhel6] Fix T-stopping of processes after their detachment (RH BZ 1486223).
This commit is contained in:
parent
d4a557a0ab
commit
f318b4ab7b
15
gdb-rhbz1486223-rhel6-stop.patch
Normal file
15
gdb-rhbz1486223-rhel6-stop.patch
Normal file
@ -0,0 +1,15 @@
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1486223
|
||||
|
||||
diff --git a/gdb/nat/linux-procfs.c b/gdb/nat/linux-procfs.c
|
||||
index a12f6228cb..2bf496c97b 100644
|
||||
--- a/gdb/nat/linux-procfs.c
|
||||
+++ b/gdb/nat/linux-procfs.c
|
||||
@@ -104,7 +104,7 @@ parse_proc_status_state (const char *state)
|
||||
return PROC_STATE_TRACING_STOP;
|
||||
case 'T':
|
||||
/* Before Linux 2.6.33, tracing stop used uppercase T. */
|
||||
- if (strcmp (state, "T (tracing stop)") == 0)
|
||||
+ if (strcmp (state, "T (tracing stop)\n") == 0)
|
||||
return PROC_STATE_TRACING_STOP;
|
||||
else
|
||||
return PROC_STATE_STOPPED;
|
9
gdb.spec
9
gdb.spec
@ -26,7 +26,7 @@ Version: 8.0
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 24%{?dist}
|
||||
Release: 25%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -726,6 +726,9 @@ Patch1242: gdb-rhbz1420304-s390x-33of35.patch
|
||||
Patch1243: gdb-rhbz1420304-s390x-34of35.patch
|
||||
Patch1244: gdb-rhbz1420304-s390x-35of35.patch
|
||||
|
||||
# [rhel6] Fix T-stopping of processes after their detachment (RH BZ 1486223).
|
||||
Patch1254: gdb-rhbz1486223-rhel6-stop.patch
|
||||
|
||||
%if 0%{!?rhel:1} || 0%{?rhel} > 6
|
||||
# RL_STATE_FEDORA_GDB would not be found for:
|
||||
# Patch642: gdb-readline62-ask-more-rh.patch
|
||||
@ -1133,6 +1136,7 @@ done
|
||||
%patch1152 -p1
|
||||
%patch1153 -p1
|
||||
%patch1155 -p1
|
||||
%patch1254 -p1
|
||||
|
||||
%patch1075 -p1
|
||||
%if 0%{?rhel:1} && 0%{?rhel} <= 7
|
||||
@ -1715,6 +1719,9 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Wed Aug 30 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 8.0-25.fc26
|
||||
- [rhel6] Fix T-stopping of processes after their detachment (RH BZ 1486223).
|
||||
|
||||
* Thu Aug 24 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 8.0-24.fc26
|
||||
- Backport DWARF-5 and breakpoint fixes from upstream stable branch 8.0.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user