[dts] Fix build by removing a patch for already removed pahole.py .
[dts rhel6] Fix build by updating gdb-gnat-dwarf-crash-3of3.patch .
This commit is contained in:
parent
2ef085ccae
commit
f21bb2353c
@ -94,7 +94,7 @@ diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
|
||||
fprintf_unfiltered (gdb_stdlog,
|
||||
"LNPAW: Attaching to a stopped process\n");
|
||||
+#ifdef NEED_DETACH_SIGSTOP
|
||||
+ pid_was_stopped = ptid_get_pid (ptid);
|
||||
+ pid_was_stopped = ptid.pid ();
|
||||
+#endif
|
||||
|
||||
/* The process is definitely stopped. It is in a job control
|
||||
@ -106,12 +106,12 @@ diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
|
||||
+#ifdef NEED_DETACH_SIGSTOP
|
||||
+ /* Workaround RHEL-5 kernel which has unreliable PTRACE_DETACH, SIGSTOP (that
|
||||
+ many TIDs are left unstopped). See RH Bug 496732. */
|
||||
+ if (ptid_get_pid (lp->ptid) == pid_was_stopped)
|
||||
+ if (lp->ptid.pid () == pid_was_stopped)
|
||||
+ {
|
||||
+ int err;
|
||||
+
|
||||
+ errno = 0;
|
||||
+ err = kill_lwp (ptid_get_lwp (lp->ptid), SIGSTOP);
|
||||
+ err = kill_lwp (lp->ptid.lwp (), SIGSTOP);
|
||||
+ if (debug_linux_nat)
|
||||
+ {
|
||||
+ fprintf_unfiltered (gdb_stdlog,
|
||||
@ -146,7 +146,7 @@ diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
|
||||
+ it as stopped if the user detaches. PTID variable has PID set to LWP
|
||||
+ while we need to check the real PID here. */
|
||||
+
|
||||
+ if (!step && lp && pid_was_stopped == ptid_get_pid (lp->ptid))
|
||||
+ if (!step && lp && pid_was_stopped == lp->ptid.pid ())
|
||||
+ pid_was_stopped = 0;
|
||||
+
|
||||
+#endif
|
||||
|
@ -1,36 +0,0 @@
|
||||
diff --git a/gdb/python/lib/gdb/command/pahole.py b/gdb/python/lib/gdb/command/pahole.py
|
||||
index e08eaf5..56c1737 100644
|
||||
--- a/gdb/python/lib/gdb/command/pahole.py
|
||||
+++ b/gdb/python/lib/gdb/command/pahole.py
|
||||
@@ -55,19 +55,19 @@ It prints the type and displays comments showing where holes are."""
|
||||
fieldsize = 8 * ftype.sizeof
|
||||
|
||||
# TARGET_CHAR_BIT
|
||||
- print (' /* %3d %3d */' % (int (bitpos / 8), int (fieldsize / 8)), end = "")
|
||||
+ print (' /* %3d %3d */' % (int (bitpos / 8), int (fieldsize / 8))),
|
||||
bitpos = bitpos + fieldsize
|
||||
|
||||
if ftype.code == gdb.TYPE_CODE_STRUCT:
|
||||
self.pahole (ftype, level + 1, field.name)
|
||||
else:
|
||||
- print (' ' * (2 + 2 * level), end = "")
|
||||
+ print (' ' * (2 + 2 * level)),
|
||||
print ('%s %s' % (str (ftype), field.name))
|
||||
|
||||
if level == 0:
|
||||
self.maybe_print_hole(bitpos, 8 * type.sizeof)
|
||||
|
||||
- print (' ' * (14 + 2 * level), end = "")
|
||||
+ print (' ' * (14 + 2 * level)),
|
||||
print ('} %s' % name)
|
||||
|
||||
def invoke (self, arg, from_tty):
|
||||
@@ -75,7 +75,7 @@ It prints the type and displays comments showing where holes are."""
|
||||
type = type.strip_typedefs ()
|
||||
if type.code != gdb.TYPE_CODE_STRUCT:
|
||||
raise (TypeError, '%s is not a struct type' % arg)
|
||||
- print (' ' * 14, end = "")
|
||||
+ print (' ' * 14),
|
||||
self.pahole (type, 0, '')
|
||||
|
||||
Pahole()
|
10
gdb.spec
10
gdb.spec
@ -26,7 +26,7 @@ Version: 8.1.90.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 38%{?dist}
|
||||
Release: 39%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -178,9 +178,6 @@ Patch1142: v1.5-libipt-static.patch
|
||||
#=push+jan
|
||||
Patch1171: v1.6.1-implicit-fallthrough.patch
|
||||
|
||||
## Fix the pahole command breakage due to its Python3 port (RH BZ 1264532).
|
||||
##=fedora
|
||||
Patch1044: gdb-pahole-python2.patch
|
||||
## [testsuite] Fix false selftest.exp FAIL from system readline-6.3+ (Patrick Palka).
|
||||
##=fedoratest
|
||||
#Patch1075: gdb-testsuite-readline63-sigint.patch
|
||||
@ -448,7 +445,6 @@ done
|
||||
|
||||
%if 0%{?rhel:1} && 0%{?rhel} <= 7
|
||||
%patch1119 -p1
|
||||
%patch1044 -p1
|
||||
%endif
|
||||
|
||||
find -name "*.orig" | xargs rm -f
|
||||
@ -1030,6 +1026,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Aug 8 2018 Jan Kratochvil <jan.kratochvil@redhat.com> - 8.1.90.20180727-39.fc29
|
||||
- [dts] Fix build by removing a patch for already removed pahole.py .
|
||||
- [dts rhel6] Fix build by updating gdb-gnat-dwarf-crash-3of3.patch .
|
||||
|
||||
* Mon Jul 30 2018 Sergio Durigan Junior <sergiodj@redhat.com> - 8.1.90.20180727-38.fc29
|
||||
- Recompile to fix RH BZ 1609504 (due to RH BZ 1609577).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user