Fix to ensure types are visible by gdb's ptype command.
This commit is contained in:
parent
e8aabd66a7
commit
eb9da9d18d
27
gdb-6.3-type-fix-20041213.patch
Normal file
27
gdb-6.3-type-fix-20041213.patch
Normal file
@ -0,0 +1,27 @@
|
||||
2004-12-13 Jeff Johnston <jjohnstn@redhat.com>
|
||||
|
||||
* dwarf2read.c (read_type_die): Ensure that structures, unions,
|
||||
enumerations, and base types create symbols.
|
||||
|
||||
--- gdb-6.3/gdb/dwarf2read.c.fix2 Mon Dec 13 19:44:08 2004
|
||||
+++ gdb-6.3/gdb/dwarf2read.c Mon Dec 13 20:00:42 2004
|
||||
@@ -7178,9 +7178,11 @@ read_type_die (struct die_info *die, str
|
||||
case DW_TAG_structure_type:
|
||||
case DW_TAG_union_type:
|
||||
read_structure_type (die, cu);
|
||||
+ process_structure_scope (die, cu);
|
||||
break;
|
||||
case DW_TAG_enumeration_type:
|
||||
read_enumeration_type (die, cu);
|
||||
+ process_enumeration_scope (die, cu);
|
||||
break;
|
||||
case DW_TAG_subprogram:
|
||||
case DW_TAG_subroutine_type:
|
||||
@@ -7215,6 +7217,7 @@ read_type_die (struct die_info *die, str
|
||||
break;
|
||||
case DW_TAG_base_type:
|
||||
read_base_type (die, cu);
|
||||
+ new_symbol (die, die->type, cu);
|
||||
break;
|
||||
default:
|
||||
complaint (&symfile_complaints, "unexepected tag in read_type_die: '%s'",
|
4
gdb.spec
4
gdb.spec
@ -131,6 +131,9 @@ Patch113: gdb-6.3-threaded-watchpoints-20041213.patch
|
||||
# Multiple patches to ia64 backtrace
|
||||
Patch114: gdb-6.3-ia64-backtrace-20041213.patch
|
||||
|
||||
# Fix to ensure types are visible
|
||||
Patch115: gdb-6.3-type-fix-20041213.patch
|
||||
|
||||
%ifarch ia64
|
||||
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu libunwind >= 0.96-3
|
||||
%else
|
||||
@ -178,6 +181,7 @@ and printing their data.
|
||||
%patch112 -p1
|
||||
%patch113 -p1
|
||||
%patch114 -p1
|
||||
%patch115 -p1
|
||||
|
||||
%patch50 -p1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user