- Improve `gdb-6.6-buildid-locate-rpm.patch' by dlopen() (+pkg-config
compat.).
This commit is contained in:
parent
09c22fd5fb
commit
eb11e3c0e6
File diff suppressed because it is too large
Load Diff
@ -1,5 +1,7 @@
|
|||||||
--- ./gdb/corelow.c 2009-03-07 01:45:51.000000000 +0100
|
Index: gdb-6.8.50.20090302/gdb/corelow.c
|
||||||
+++ ./gdb/corelow.c 2009-03-07 02:29:31.000000000 +0100
|
===================================================================
|
||||||
|
--- gdb-6.8.50.20090302.orig/gdb/corelow.c 2009-02-23 01:03:48.000000000 +0100
|
||||||
|
+++ gdb-6.8.50.20090302/gdb/corelow.c 2009-03-07 17:04:57.000000000 +0100
|
||||||
@@ -45,6 +45,10 @@
|
@@ -45,6 +45,10 @@
|
||||||
#include "exceptions.h"
|
#include "exceptions.h"
|
||||||
#include "solib.h"
|
#include "solib.h"
|
||||||
@ -93,8 +95,10 @@
|
|||||||
+ NULL, NULL, NULL,
|
+ NULL, NULL, NULL,
|
||||||
+ &setlist, &showlist);
|
+ &setlist, &showlist);
|
||||||
}
|
}
|
||||||
--- ./gdb/doc/gdb.texinfo 2009-03-07 01:45:51.000000000 +0100
|
Index: gdb-6.8.50.20090302/gdb/doc/gdb.texinfo
|
||||||
+++ ./gdb/doc/gdb.texinfo 2009-03-07 02:10:11.000000000 +0100
|
===================================================================
|
||||||
|
--- gdb-6.8.50.20090302.orig/gdb/doc/gdb.texinfo 2009-03-07 17:04:56.000000000 +0100
|
||||||
|
+++ gdb-6.8.50.20090302/gdb/doc/gdb.texinfo 2009-03-07 17:04:57.000000000 +0100
|
||||||
@@ -13294,6 +13294,27 @@ information files.
|
@@ -13294,6 +13294,27 @@ information files.
|
||||||
|
|
||||||
@end table
|
@end table
|
||||||
@ -123,8 +127,10 @@
|
|||||||
@cindex @code{.gnu_debuglink} sections
|
@cindex @code{.gnu_debuglink} sections
|
||||||
@cindex debug link sections
|
@cindex debug link sections
|
||||||
A debug link is a special section of the executable file named
|
A debug link is a special section of the executable file named
|
||||||
--- ./gdb/solib-svr4.c 2009-03-07 01:45:51.000000000 +0100
|
Index: gdb-6.8.50.20090302/gdb/solib-svr4.c
|
||||||
+++ ./gdb/solib-svr4.c 2009-03-07 02:10:11.000000000 +0100
|
===================================================================
|
||||||
|
--- gdb-6.8.50.20090302.orig/gdb/solib-svr4.c 2009-03-07 17:04:52.000000000 +0100
|
||||||
|
+++ gdb-6.8.50.20090302/gdb/solib-svr4.c 2009-03-07 17:04:57.000000000 +0100
|
||||||
@@ -1000,9 +1000,33 @@ svr4_current_sos (void)
|
@@ -1000,9 +1000,33 @@ svr4_current_sos (void)
|
||||||
safe_strerror (errcode));
|
safe_strerror (errcode));
|
||||||
else
|
else
|
||||||
@ -162,8 +168,10 @@
|
|||||||
}
|
}
|
||||||
xfree (buffer);
|
xfree (buffer);
|
||||||
|
|
||||||
--- ./gdb/symfile.c 2009-03-07 01:45:51.000000000 +0100
|
Index: gdb-6.8.50.20090302/gdb/symfile.c
|
||||||
+++ ./gdb/symfile.c 2009-03-07 02:30:20.000000000 +0100
|
===================================================================
|
||||||
|
--- gdb-6.8.50.20090302.orig/gdb/symfile.c 2009-03-07 17:04:53.000000000 +0100
|
||||||
|
+++ gdb-6.8.50.20090302/gdb/symfile.c 2009-03-07 17:22:21.000000000 +0100
|
||||||
@@ -54,6 +54,7 @@
|
@@ -54,6 +54,7 @@
|
||||||
#include "elf-bfd.h"
|
#include "elf-bfd.h"
|
||||||
#include "solib.h"
|
#include "solib.h"
|
||||||
@ -651,7 +659,7 @@
|
|||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
+/* This MISSING_FILEPAIR_HASH tracker is used only for the duplicite messages
|
+/* This MISSING_FILEPAIR_HASH tracker is used only for the duplicite messages
|
||||||
+ yum --enablerepo='*-debuginfo' install ...
|
+ Try to install the hash file ...
|
||||||
+ avoidance. */
|
+ avoidance. */
|
||||||
+
|
+
|
||||||
+struct missing_filepair
|
+struct missing_filepair
|
||||||
@ -774,8 +782,8 @@
|
|||||||
+ fprintf_unfiltered (gdb_stdlog,
|
+ fprintf_unfiltered (gdb_stdlog,
|
||||||
+ _("Missing separate debuginfo for %s\n"), binary);
|
+ _("Missing separate debuginfo for %s\n"), binary);
|
||||||
+ if (debug != NULL)
|
+ if (debug != NULL)
|
||||||
+ fprintf_unfiltered (gdb_stdlog, _("Try: %s %s\n"),
|
+ fprintf_unfiltered (gdb_stdlog, _("Try to install the hash file %s\n"),
|
||||||
+ "yum --enablerepo='*-debuginfo' install", debug);
|
+ debug);
|
||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
static char *
|
static char *
|
||||||
@ -938,8 +946,10 @@
|
|||||||
+
|
+
|
||||||
+ observer_attach_executable_changed (debug_print_executable_changed);
|
+ observer_attach_executable_changed (debug_print_executable_changed);
|
||||||
}
|
}
|
||||||
--- ./gdb/symfile.h 2009-03-07 01:45:51.000000000 +0100
|
Index: gdb-6.8.50.20090302/gdb/symfile.h
|
||||||
+++ ./gdb/symfile.h 2009-03-07 02:16:18.000000000 +0100
|
===================================================================
|
||||||
|
--- gdb-6.8.50.20090302.orig/gdb/symfile.h 2009-03-07 17:04:52.000000000 +0100
|
||||||
|
+++ gdb-6.8.50.20090302/gdb/symfile.h 2009-03-07 17:13:33.000000000 +0100
|
||||||
@@ -372,6 +372,13 @@ extern int symfile_map_offsets_to_segmen
|
@@ -372,6 +372,13 @@ extern int symfile_map_offsets_to_segmen
|
||||||
struct symfile_segment_data *get_symfile_segment_data (bfd *abfd);
|
struct symfile_segment_data *get_symfile_segment_data (bfd *abfd);
|
||||||
void free_symfile_segment_data (struct symfile_segment_data *data);
|
void free_symfile_segment_data (struct symfile_segment_data *data);
|
||||||
@ -954,8 +964,10 @@
|
|||||||
/* From dwarf2read.c */
|
/* From dwarf2read.c */
|
||||||
|
|
||||||
extern int dwarf2_has_info (struct objfile *);
|
extern int dwarf2_has_info (struct objfile *);
|
||||||
--- ./gdb/testsuite/lib/gdb.exp 2009-03-07 01:45:51.000000000 +0100
|
Index: gdb-6.8.50.20090302/gdb/testsuite/lib/gdb.exp
|
||||||
+++ ./gdb/testsuite/lib/gdb.exp 2009-03-07 02:10:11.000000000 +0100
|
===================================================================
|
||||||
|
--- gdb-6.8.50.20090302.orig/gdb/testsuite/lib/gdb.exp 2009-03-07 17:04:52.000000000 +0100
|
||||||
|
+++ gdb-6.8.50.20090302/gdb/testsuite/lib/gdb.exp 2009-03-07 17:13:33.000000000 +0100
|
||||||
@@ -1230,6 +1230,16 @@ proc default_gdb_start { } {
|
@@ -1230,6 +1230,16 @@ proc default_gdb_start { } {
|
||||||
warning "Couldn't set the width to 0."
|
warning "Couldn't set the width to 0."
|
||||||
}
|
}
|
||||||
|
9
gdb.spec
9
gdb.spec
@ -13,7 +13,7 @@ Version: 6.8.50.20090302
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 4%{?_with_upstream:.upstream}%{?dist}
|
Release: 5%{?_with_upstream:.upstream}%{?dist}
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -378,7 +378,8 @@ Patch352: gdb-6.8-bz457187-largefile.patch
|
|||||||
BuildRequires: ncurses-devel texinfo gettext flex bison expat-devel
|
BuildRequires: ncurses-devel texinfo gettext flex bison expat-devel
|
||||||
Requires: readline
|
Requires: readline
|
||||||
BuildRequires: readline-devel
|
BuildRequires: readline-devel
|
||||||
Requires: rpm-libs
|
# dlopen() no longer makes rpm-libs a mandatory dependency.
|
||||||
|
#Requires: rpm-libs
|
||||||
BuildRequires: rpm-devel
|
BuildRequires: rpm-devel
|
||||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
Requires: python-libs
|
Requires: python-libs
|
||||||
@ -635,6 +636,7 @@ CFLAGS="$CFLAGS -O0 -ggdb2"
|
|||||||
--with-expat \
|
--with-expat \
|
||||||
--enable-tui \
|
--enable-tui \
|
||||||
--with-python \
|
--with-python \
|
||||||
|
--with-rpm=librpm.so \
|
||||||
%ifarch ia64
|
%ifarch ia64
|
||||||
--with-libunwind \
|
--with-libunwind \
|
||||||
%else
|
%else
|
||||||
@ -838,6 +840,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Mar 7 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090302-5
|
||||||
|
- Improve `gdb-6.6-buildid-locate-rpm.patch' by dlopen() (+pkg-config compat.).
|
||||||
|
|
||||||
* Sat Mar 7 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090302-4
|
* Sat Mar 7 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090302-4
|
||||||
- Split `gdb-6.6-buildid-locate.patch' to `gdb-6.6-buildid-locate-rpm.patch'.
|
- Split `gdb-6.6-buildid-locate.patch' to `gdb-6.6-buildid-locate-rpm.patch'.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user