Rebase to FSF GDB 8.1.90.20180708 (8.2pre).
This commit is contained in:
parent
9d054c36c2
commit
e95ed4b7b3
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,3 +1,3 @@
|
|||||||
/gdb-libstdc++-v3-python-7.1.1-20170526.tar.xz
|
/gdb-libstdc++-v3-python-7.1.1-20170526.tar.xz
|
||||||
/v1.6.1.tar.gz
|
/v1.6.1.tar.gz
|
||||||
/gdb-8.1.50.20180704.tar.xz
|
/gdb-8.1.90.20180708.tar.xz
|
||||||
|
@ -1 +1 @@
|
|||||||
9b960ba18c83e3f9aad16fe8bf845f5c469712bd
|
0bad166b920254974ad2e35f087e14aa913afe44
|
||||||
|
@ -62,7 +62,7 @@ diff --git a/gdb/breakpoint.c b/gdb/breakpoint.c
|
|||||||
diff --git a/gdb/breakpoint.h b/gdb/breakpoint.h
|
diff --git a/gdb/breakpoint.h b/gdb/breakpoint.h
|
||||||
--- a/gdb/breakpoint.h
|
--- a/gdb/breakpoint.h
|
||||||
+++ b/gdb/breakpoint.h
|
+++ b/gdb/breakpoint.h
|
||||||
@@ -1684,6 +1684,9 @@ extern const char *ep_parse_optional_if_clause (const char **arg);
|
@@ -1679,6 +1679,9 @@ extern const char *ep_parse_optional_if_clause (const char **arg);
|
||||||
UIOUT iff debugging multiple threads. */
|
UIOUT iff debugging multiple threads. */
|
||||||
extern void maybe_print_thread_hit_breakpoint (struct ui_out *uiout);
|
extern void maybe_print_thread_hit_breakpoint (struct ui_out *uiout);
|
||||||
|
|
||||||
|
@ -276,7 +276,7 @@ diff --git a/gdb/gdbserver/linux-low.c b/gdb/gdbserver/linux-low.c
|
|||||||
diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
|
diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
|
||||||
--- a/gdb/linux-nat.c
|
--- a/gdb/linux-nat.c
|
||||||
+++ b/gdb/linux-nat.c
|
+++ b/gdb/linux-nat.c
|
||||||
@@ -1088,7 +1088,17 @@ linux_nat_target::create_inferior (const char *exec_file,
|
@@ -1089,7 +1089,17 @@ linux_nat_target::create_inferior (const char *exec_file,
|
||||||
/* Make sure we report all signals during startup. */
|
/* Make sure we report all signals during startup. */
|
||||||
pass_signals (0, NULL);
|
pass_signals (0, NULL);
|
||||||
|
|
||||||
|
@ -9,7 +9,7 @@ Subject: gdb-glibc-strstr-workaround.patch
|
|||||||
diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
||||||
--- a/gdb/dwarf2read.c
|
--- a/gdb/dwarf2read.c
|
||||||
+++ b/gdb/dwarf2read.c
|
+++ b/gdb/dwarf2read.c
|
||||||
@@ -21255,6 +21255,26 @@ new_symbol (struct die_info *die, struct type *type, struct dwarf2_cu *cu,
|
@@ -21254,6 +21254,26 @@ new_symbol (struct die_info *die, struct type *type, struct dwarf2_cu *cu,
|
||||||
/* Cache this symbol's name and the name's demangled form (if any). */
|
/* Cache this symbol's name and the name's demangled form (if any). */
|
||||||
SYMBOL_SET_LANGUAGE (sym, cu->language, &objfile->objfile_obstack);
|
SYMBOL_SET_LANGUAGE (sym, cu->language, &objfile->objfile_obstack);
|
||||||
linkagename = dwarf2_physname (name, die, cu);
|
linkagename = dwarf2_physname (name, die, cu);
|
||||||
|
@ -42,7 +42,7 @@ gdb/
|
|||||||
diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
||||||
--- a/gdb/dwarf2read.c
|
--- a/gdb/dwarf2read.c
|
||||||
+++ b/gdb/dwarf2read.c
|
+++ b/gdb/dwarf2read.c
|
||||||
@@ -10483,6 +10483,13 @@ private:
|
@@ -10482,6 +10482,13 @@ private:
|
||||||
static void
|
static void
|
||||||
process_die (struct die_info *die, struct dwarf2_cu *cu)
|
process_die (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
{
|
{
|
||||||
@ -89,7 +89,7 @@ diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
|
|||||||
/* The saved to_close method, inherited from inf-ptrace.c.
|
/* The saved to_close method, inherited from inf-ptrace.c.
|
||||||
Called by our to_close. */
|
Called by our to_close. */
|
||||||
static void (*super_close) (struct target_ops *);
|
static void (*super_close) (struct target_ops *);
|
||||||
@@ -1026,6 +1032,9 @@ linux_nat_post_attach_wait (ptid_t ptid, int *signalled)
|
@@ -1027,6 +1033,9 @@ linux_nat_post_attach_wait (ptid_t ptid, int *signalled)
|
||||||
if (debug_linux_nat)
|
if (debug_linux_nat)
|
||||||
fprintf_unfiltered (gdb_stdlog,
|
fprintf_unfiltered (gdb_stdlog,
|
||||||
"LNPAW: Attaching to a stopped process\n");
|
"LNPAW: Attaching to a stopped process\n");
|
||||||
@ -99,7 +99,7 @@ diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
|
|||||||
|
|
||||||
/* The process is definitely stopped. It is in a job control
|
/* The process is definitely stopped. It is in a job control
|
||||||
stop, unless the kernel predates the TASK_STOPPED /
|
stop, unless the kernel predates the TASK_STOPPED /
|
||||||
@@ -1358,6 +1367,25 @@ get_detach_signal (struct lwp_info *lp)
|
@@ -1359,6 +1368,25 @@ get_detach_signal (struct lwp_info *lp)
|
||||||
return gdb_signal_to_host (signo);
|
return gdb_signal_to_host (signo);
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -125,7 +125,7 @@ diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
|
|||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -1506,6 +1534,10 @@ linux_nat_target::detach (inferior *inf, int from_tty)
|
@@ -1507,6 +1535,10 @@ linux_nat_target::detach (inferior *inf, int from_tty)
|
||||||
detach_one_lwp (main_lwp, &signo);
|
detach_one_lwp (main_lwp, &signo);
|
||||||
|
|
||||||
detach_success (inf);
|
detach_success (inf);
|
||||||
@ -136,7 +136,7 @@ diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -1764,6 +1796,16 @@ linux_nat_target::resume (ptid_t ptid, int step, enum gdb_signal signo)
|
@@ -1765,6 +1797,16 @@ linux_nat_target::resume (ptid_t ptid, int step, enum gdb_signal signo)
|
||||||
return;
|
return;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -153,7 +153,7 @@ diff --git a/gdb/linux-nat.c b/gdb/linux-nat.c
|
|||||||
if (resume_many)
|
if (resume_many)
|
||||||
iterate_over_lwps (ptid, linux_nat_resume_callback, lp);
|
iterate_over_lwps (ptid, linux_nat_resume_callback, lp);
|
||||||
|
|
||||||
@@ -3760,6 +3802,10 @@ linux_nat_target::mourn_inferior ()
|
@@ -3761,6 +3803,10 @@ linux_nat_target::mourn_inferior ()
|
||||||
|
|
||||||
/* Let the arch-specific native code know this process is gone. */
|
/* Let the arch-specific native code know this process is gone. */
|
||||||
linux_target->low_forget_process (pid);
|
linux_target->low_forget_process (pid);
|
||||||
|
@ -20,4 +20,4 @@ diff --git a/gdb/contrib/gdb-add-index.sh b/gdb/contrib/gdb-add-index.sh
|
|||||||
+
|
+
|
||||||
myname="${0##*/}"
|
myname="${0##*/}"
|
||||||
|
|
||||||
if test $# != 1; then
|
dwarf5=""
|
||||||
|
@ -1650,7 +1650,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void
|
static void
|
||||||
@@ -14934,8 +14934,8 @@ dwarf2_add_field (struct field_info *fip, struct die_info *die,
|
@@ -14933,8 +14933,8 @@ dwarf2_add_field (struct field_info *fip, struct die_info *die,
|
||||||
object, and then subtract off the number of bits of
|
object, and then subtract off the number of bits of
|
||||||
the field itself. The result is the bit offset of
|
the field itself. The result is the bit offset of
|
||||||
the LSB of the field. */
|
the LSB of the field. */
|
||||||
@ -3039,7 +3039,7 @@ diff --git a/gdb/tracepoint.c b/gdb/tracepoint.c
|
|||||||
paddress (gdbarch, offset), reg);
|
paddress (gdbarch, offset), reg);
|
||||||
}
|
}
|
||||||
add_memrange (gdbarch, reg, offset, len);
|
add_memrange (gdbarch, reg, offset, len);
|
||||||
@@ -2475,7 +2475,8 @@ info_scope_command (const char *args_in, int from_tty)
|
@@ -2447,7 +2447,8 @@ info_scope_command (const char *args_in, int from_tty)
|
||||||
const char *symname;
|
const char *symname;
|
||||||
const char *save_args = args_in;
|
const char *save_args = args_in;
|
||||||
struct block_iterator iter;
|
struct block_iterator iter;
|
||||||
@ -3049,7 +3049,7 @@ diff --git a/gdb/tracepoint.c b/gdb/tracepoint.c
|
|||||||
struct gdbarch *gdbarch;
|
struct gdbarch *gdbarch;
|
||||||
int regno;
|
int regno;
|
||||||
const char *args = args_in;
|
const char *args = args_in;
|
||||||
@@ -2619,8 +2620,11 @@ info_scope_command (const char *args_in, int from_tty)
|
@@ -2591,8 +2592,11 @@ info_scope_command (const char *args_in, int from_tty)
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
if (SYMBOL_TYPE (sym))
|
if (SYMBOL_TYPE (sym))
|
||||||
|
@ -143,7 +143,7 @@ diff --git a/gdb/dwarf2loc.h b/gdb/dwarf2loc.h
|
|||||||
diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
||||||
--- a/gdb/dwarf2read.c
|
--- a/gdb/dwarf2read.c
|
||||||
+++ b/gdb/dwarf2read.c
|
+++ b/gdb/dwarf2read.c
|
||||||
@@ -17535,7 +17535,7 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
@@ -17534,7 +17534,7 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
struct type *base_type, *orig_base_type;
|
struct type *base_type, *orig_base_type;
|
||||||
struct type *range_type;
|
struct type *range_type;
|
||||||
struct attribute *attr;
|
struct attribute *attr;
|
||||||
@ -152,7 +152,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
int low_default_is_valid;
|
int low_default_is_valid;
|
||||||
int high_bound_is_count = 0;
|
int high_bound_is_count = 0;
|
||||||
const char *name;
|
const char *name;
|
||||||
@@ -17555,7 +17555,9 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
@@ -17554,7 +17554,9 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
|
|
||||||
low.kind = PROP_CONST;
|
low.kind = PROP_CONST;
|
||||||
high.kind = PROP_CONST;
|
high.kind = PROP_CONST;
|
||||||
@ -162,7 +162,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
|
|
||||||
/* Set LOW_DEFAULT_IS_VALID if current language and DWARF version allow
|
/* Set LOW_DEFAULT_IS_VALID if current language and DWARF version allow
|
||||||
omitting DW_AT_lower_bound. */
|
omitting DW_AT_lower_bound. */
|
||||||
@@ -17588,6 +17590,14 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
@@ -17587,6 +17589,14 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
break;
|
break;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -177,7 +177,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
attr = dwarf2_attr (die, DW_AT_lower_bound, cu);
|
attr = dwarf2_attr (die, DW_AT_lower_bound, cu);
|
||||||
if (attr)
|
if (attr)
|
||||||
attr_to_dynamic_prop (attr, die, cu, &low);
|
attr_to_dynamic_prop (attr, die, cu, &low);
|
||||||
@@ -17665,7 +17675,7 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
@@ -17664,7 +17674,7 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
&& !TYPE_UNSIGNED (base_type) && (high.data.const_val & negative_mask))
|
&& !TYPE_UNSIGNED (base_type) && (high.data.const_val & negative_mask))
|
||||||
high.data.const_val |= negative_mask;
|
high.data.const_val |= negative_mask;
|
||||||
|
|
||||||
|
@ -87,7 +87,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
|
|
||||||
/* memory allocation interface */
|
/* memory allocation interface */
|
||||||
|
|
||||||
@@ -13633,7 +13634,7 @@ read_func_scope (struct die_info *die, struct dwarf2_cu *cu)
|
@@ -13632,7 +13633,7 @@ read_func_scope (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
{
|
{
|
||||||
newobj->static_link
|
newobj->static_link
|
||||||
= XOBNEW (&objfile->objfile_obstack, struct dynamic_prop);
|
= XOBNEW (&objfile->objfile_obstack, struct dynamic_prop);
|
||||||
@ -96,7 +96,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
cu->list_in_scope = &local_symbols;
|
cu->list_in_scope = &local_symbols;
|
||||||
@@ -16298,7 +16299,8 @@ read_array_type (struct die_info *die, struct dwarf2_cu *cu)
|
@@ -16297,7 +16298,8 @@ read_array_type (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
|
|
||||||
byte_stride_prop
|
byte_stride_prop
|
||||||
= (struct dynamic_prop *) alloca (sizeof (struct dynamic_prop));
|
= (struct dynamic_prop *) alloca (sizeof (struct dynamic_prop));
|
||||||
@ -106,7 +106,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
if (!stride_ok)
|
if (!stride_ok)
|
||||||
{
|
{
|
||||||
complaint (_("unable to read array DW_AT_byte_stride "
|
complaint (_("unable to read array DW_AT_byte_stride "
|
||||||
@@ -17059,29 +17061,90 @@ read_tag_string_type (struct die_info *die, struct dwarf2_cu *cu)
|
@@ -17058,29 +17060,90 @@ read_tag_string_type (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
struct gdbarch *gdbarch = get_objfile_arch (objfile);
|
struct gdbarch *gdbarch = get_objfile_arch (objfile);
|
||||||
struct type *type, *range_type, *index_type, *char_type;
|
struct type *type, *range_type, *index_type, *char_type;
|
||||||
struct attribute *attr;
|
struct attribute *attr;
|
||||||
@ -208,7 +208,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
char_type = language_string_char_type (cu->language_defn, gdbarch);
|
char_type = language_string_char_type (cu->language_defn, gdbarch);
|
||||||
type = create_string_type (NULL, char_type, range_type);
|
type = create_string_type (NULL, char_type, range_type);
|
||||||
|
|
||||||
@@ -17429,7 +17492,8 @@ read_base_type (struct die_info *die, struct dwarf2_cu *cu)
|
@@ -17428,7 +17491,8 @@ read_base_type (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
|
|
||||||
static int
|
static int
|
||||||
attr_to_dynamic_prop (const struct attribute *attr, struct die_info *die,
|
attr_to_dynamic_prop (const struct attribute *attr, struct die_info *die,
|
||||||
@ -218,7 +218,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
{
|
{
|
||||||
struct dwarf2_property_baton *baton;
|
struct dwarf2_property_baton *baton;
|
||||||
struct obstack *obstack
|
struct obstack *obstack
|
||||||
@@ -17440,14 +17504,33 @@ attr_to_dynamic_prop (const struct attribute *attr, struct die_info *die,
|
@@ -17439,14 +17503,33 @@ attr_to_dynamic_prop (const struct attribute *attr, struct die_info *die,
|
||||||
|
|
||||||
if (attr_form_is_block (attr))
|
if (attr_form_is_block (attr))
|
||||||
{
|
{
|
||||||
@ -256,7 +256,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
}
|
}
|
||||||
else if (attr_form_is_ref (attr))
|
else if (attr_form_is_ref (attr))
|
||||||
{
|
{
|
||||||
@@ -17480,8 +17563,28 @@ attr_to_dynamic_prop (const struct attribute *attr, struct die_info *die,
|
@@ -17479,8 +17562,28 @@ attr_to_dynamic_prop (const struct attribute *attr, struct die_info *die,
|
||||||
baton = XOBNEW (obstack, struct dwarf2_property_baton);
|
baton = XOBNEW (obstack, struct dwarf2_property_baton);
|
||||||
baton->referenced_type = die_type (target_die, target_cu);
|
baton->referenced_type = die_type (target_die, target_cu);
|
||||||
baton->locexpr.per_cu = cu->per_cu;
|
baton->locexpr.per_cu = cu->per_cu;
|
||||||
@ -287,7 +287,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
prop->data.baton = baton;
|
prop->data.baton = baton;
|
||||||
prop->kind = PROP_LOCEXPR;
|
prop->kind = PROP_LOCEXPR;
|
||||||
gdb_assert (prop->data.baton != NULL);
|
gdb_assert (prop->data.baton != NULL);
|
||||||
@@ -17592,7 +17695,7 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
@@ -17591,7 +17694,7 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
|
|
||||||
attr = dwarf2_attr (die, DW_AT_byte_stride, cu);
|
attr = dwarf2_attr (die, DW_AT_byte_stride, cu);
|
||||||
if (attr)
|
if (attr)
|
||||||
@ -296,7 +296,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
complaint (_("Missing DW_AT_byte_stride "
|
complaint (_("Missing DW_AT_byte_stride "
|
||||||
"- DIE at 0x%s [in module %s]"),
|
"- DIE at 0x%s [in module %s]"),
|
||||||
sect_offset_str (die->sect_off),
|
sect_offset_str (die->sect_off),
|
||||||
@@ -17600,7 +17703,7 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
@@ -17599,7 +17702,7 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
|
|
||||||
attr = dwarf2_attr (die, DW_AT_lower_bound, cu);
|
attr = dwarf2_attr (die, DW_AT_lower_bound, cu);
|
||||||
if (attr)
|
if (attr)
|
||||||
@ -305,7 +305,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
else if (!low_default_is_valid)
|
else if (!low_default_is_valid)
|
||||||
complaint (_("Missing DW_AT_lower_bound "
|
complaint (_("Missing DW_AT_lower_bound "
|
||||||
"- DIE at %s [in module %s]"),
|
"- DIE at %s [in module %s]"),
|
||||||
@@ -17608,10 +17711,10 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
@@ -17607,10 +17710,10 @@ read_subrange_type (struct die_info *die, struct dwarf2_cu *cu)
|
||||||
objfile_name (cu->per_cu->dwarf2_per_objfile->objfile));
|
objfile_name (cu->per_cu->dwarf2_per_objfile->objfile));
|
||||||
|
|
||||||
attr = dwarf2_attr (die, DW_AT_upper_bound, cu);
|
attr = dwarf2_attr (die, DW_AT_upper_bound, cu);
|
||||||
@ -318,7 +318,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
{
|
{
|
||||||
/* If bounds are constant do the final calculation here. */
|
/* If bounds are constant do the final calculation here. */
|
||||||
if (low.kind == PROP_CONST && high.kind == PROP_CONST)
|
if (low.kind == PROP_CONST && high.kind == PROP_CONST)
|
||||||
@@ -25112,7 +25215,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
@@ -25111,7 +25214,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
||||||
attr = dwarf2_attr (die, DW_AT_allocated, cu);
|
attr = dwarf2_attr (die, DW_AT_allocated, cu);
|
||||||
if (attr_form_is_block (attr))
|
if (attr_form_is_block (attr))
|
||||||
{
|
{
|
||||||
@ -327,7 +327,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
add_dyn_prop (DYN_PROP_ALLOCATED, prop, type);
|
add_dyn_prop (DYN_PROP_ALLOCATED, prop, type);
|
||||||
}
|
}
|
||||||
else if (attr != NULL)
|
else if (attr != NULL)
|
||||||
@@ -25126,7 +25229,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
@@ -25125,7 +25228,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
||||||
attr = dwarf2_attr (die, DW_AT_associated, cu);
|
attr = dwarf2_attr (die, DW_AT_associated, cu);
|
||||||
if (attr_form_is_block (attr))
|
if (attr_form_is_block (attr))
|
||||||
{
|
{
|
||||||
@ -336,7 +336,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
|||||||
add_dyn_prop (DYN_PROP_ASSOCIATED, prop, type);
|
add_dyn_prop (DYN_PROP_ASSOCIATED, prop, type);
|
||||||
}
|
}
|
||||||
else if (attr != NULL)
|
else if (attr != NULL)
|
||||||
@@ -25138,7 +25241,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
@@ -25137,7 +25240,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
||||||
|
|
||||||
/* Read DW_AT_data_location and set in type. */
|
/* Read DW_AT_data_location and set in type. */
|
||||||
attr = dwarf2_attr (die, DW_AT_data_location, cu);
|
attr = dwarf2_attr (die, DW_AT_data_location, cu);
|
||||||
|
9
gdb.spec
9
gdb.spec
@ -18,15 +18,15 @@
|
|||||||
Name: %{?scl_prefix}gdb
|
Name: %{?scl_prefix}gdb
|
||||||
|
|
||||||
# Freeze it when GDB gets branched
|
# Freeze it when GDB gets branched
|
||||||
%global snapsrc 20180704
|
%global snapsrc 20180708
|
||||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||||
%global snapgnulib 20161115
|
%global snapgnulib 20161115
|
||||||
%global tarname gdb-%{version}
|
%global tarname gdb-%{version}
|
||||||
Version: 8.1.50.%{snapsrc}
|
Version: 8.1.90.%{snapsrc}
|
||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 28%{?dist}
|
Release: 29%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -1036,6 +1036,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jul 8 2018 Sergio Durigan Junior <sergiodj@redhat.com> - 8.1.90.20180708-29.fc29
|
||||||
|
- Rebase to FSF GDB 8.1.90.20180708 (8.2pre).
|
||||||
|
|
||||||
* Wed Jul 4 2018 Sergio Durigan Junior <sergiodj@redhat.com> - 8.1.50.20180704-28.fc29
|
* Wed Jul 4 2018 Sergio Durigan Junior <sergiodj@redhat.com> - 8.1.50.20180704-28.fc29
|
||||||
- Rebase to FSF GDB 8.1.50.20180704 (8.2pre).
|
- Rebase to FSF GDB 8.1.50.20180704 (8.2pre).
|
||||||
- Remove defattr directives from specfile.
|
- Remove defattr directives from specfile.
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (gdb-libstdc++-v3-python-7.1.1-20170526.tar.xz) = 3d540b99581ffa4cf2810bec979c9a01a1f8ce782b7c8efb46b40dd2421d60cdb0e52b53c5477c3e86a57957a2a14489f5c29dc53868738a1ef79e79cf76d0a1
|
SHA512 (gdb-libstdc++-v3-python-7.1.1-20170526.tar.xz) = 3d540b99581ffa4cf2810bec979c9a01a1f8ce782b7c8efb46b40dd2421d60cdb0e52b53c5477c3e86a57957a2a14489f5c29dc53868738a1ef79e79cf76d0a1
|
||||||
SHA512 (v1.6.1.tar.gz) = c7c9c8ba78021fff3fde12a216f5729c6031114e5a727f49b7ff1a31c53b5ddba24d1b3aee252d8278ecd1fafe78a44ed059c12b9eb29eca33093e0720673468
|
SHA512 (v1.6.1.tar.gz) = c7c9c8ba78021fff3fde12a216f5729c6031114e5a727f49b7ff1a31c53b5ddba24d1b3aee252d8278ecd1fafe78a44ed059c12b9eb29eca33093e0720673468
|
||||||
SHA512 (gdb-8.1.50.20180704.tar.xz) = de107599477ba885db7604dd7da9762e88fc7543c115291dedaf9917832fb2b809c6d853bdc2eeb748938c67199ae672d15b9da0be25e9bf7993a3ee35284bdc
|
SHA512 (gdb-8.1.90.20180708.tar.xz) = 95e0a841327536df7ba25e970e9696ebdbe8454203ac5fdb060a408ce6021ab353dc98ba292100f2c7d60f382f08d9972dcf35221c256f907f5af12b656a94bd
|
||||||
|
Loading…
Reference in New Issue
Block a user