Rebase to FSF GDB 11.2.
This commit is contained in:
parent
45ae8fcd2b
commit
e6e68cd22d
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,4 +1,4 @@
|
|||||||
/new-fedora-release
|
/new-fedora-release
|
||||||
/gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz
|
/gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz
|
||||||
/gdb-11.1.tar.xz
|
/gdb-11.2.tar.xz
|
||||||
/v2.0.5.tar.gz
|
/v2.0.5.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
8cdd8568bfe4ea86a93e4b80bf2fc6e6f9cad84c
|
ef6ec3333e80e39ce207c6c5d5628bdd5402111d
|
||||||
|
@ -696,7 +696,7 @@ diff --git a/gdb/config.in b/gdb/config.in
|
|||||||
/* Define to 1 if translation of program messages to the user's native
|
/* Define to 1 if translation of program messages to the user's native
|
||||||
language is requested. */
|
language is requested. */
|
||||||
#undef ENABLE_NLS
|
#undef ENABLE_NLS
|
||||||
@@ -246,6 +249,9 @@
|
@@ -250,6 +253,9 @@
|
||||||
/* Define if you have the mpfr library. */
|
/* Define if you have the mpfr library. */
|
||||||
#undef HAVE_LIBMPFR
|
#undef HAVE_LIBMPFR
|
||||||
|
|
||||||
@ -756,7 +756,7 @@ diff --git a/gdb/configure b/gdb/configure
|
|||||||
YACC The `Yet Another Compiler Compiler' implementation to use.
|
YACC The `Yet Another Compiler Compiler' implementation to use.
|
||||||
Defaults to the first program found out of: `bison -y', `byacc',
|
Defaults to the first program found out of: `bison -y', `byacc',
|
||||||
`yacc'.
|
`yacc'.
|
||||||
@@ -6616,6 +6628,494 @@ _ACEOF
|
@@ -6624,6 +6636,494 @@ _ACEOF
|
||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $with_auto_load_safe_path" >&5
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $with_auto_load_safe_path" >&5
|
||||||
$as_echo "$with_auto_load_safe_path" >&6; }
|
$as_echo "$with_auto_load_safe_path" >&6; }
|
||||||
|
|
||||||
|
@ -9,7 +9,7 @@ Subject: gdb-container-rh-pkg.patch
|
|||||||
diff --git a/gdb/remote.c b/gdb/remote.c
|
diff --git a/gdb/remote.c b/gdb/remote.c
|
||||||
--- a/gdb/remote.c
|
--- a/gdb/remote.c
|
||||||
+++ b/gdb/remote.c
|
+++ b/gdb/remote.c
|
||||||
@@ -14290,7 +14290,17 @@ remote_target::pid_to_exec_file (int pid)
|
@@ -14291,7 +14291,17 @@ remote_target::pid_to_exec_file (int pid)
|
||||||
char *annex = NULL;
|
char *annex = NULL;
|
||||||
|
|
||||||
if (packet_support (PACKET_qXfer_exec_file) != PACKET_ENABLE)
|
if (packet_support (PACKET_qXfer_exec_file) != PACKET_ENABLE)
|
||||||
|
@ -12,7 +12,7 @@ https://bugzilla.redhat.com/show_bug.cgi?id=1270534
|
|||||||
diff --git a/gdb/configure b/gdb/configure
|
diff --git a/gdb/configure b/gdb/configure
|
||||||
--- a/gdb/configure
|
--- a/gdb/configure
|
||||||
+++ b/gdb/configure
|
+++ b/gdb/configure
|
||||||
@@ -9544,6 +9544,7 @@ if test x"$prefer_curses" = xyes; then
|
@@ -9552,6 +9552,7 @@ if test x"$prefer_curses" = xyes; then
|
||||||
# search /usr/local/include, if ncurses is installed in /usr/local. A
|
# search /usr/local/include, if ncurses is installed in /usr/local. A
|
||||||
# default installation of ncurses on alpha*-dec-osf* will lead to such
|
# default installation of ncurses on alpha*-dec-osf* will lead to such
|
||||||
# a situation.
|
# a situation.
|
||||||
@ -20,7 +20,7 @@ diff --git a/gdb/configure b/gdb/configure
|
|||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing waddstr" >&5
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing waddstr" >&5
|
||||||
$as_echo_n "checking for library containing waddstr... " >&6; }
|
$as_echo_n "checking for library containing waddstr... " >&6; }
|
||||||
if ${ac_cv_search_waddstr+:} false; then :
|
if ${ac_cv_search_waddstr+:} false; then :
|
||||||
@@ -9568,7 +9569,7 @@ return waddstr ();
|
@@ -9576,7 +9577,7 @@ return waddstr ();
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
_ACEOF
|
_ACEOF
|
||||||
@ -29,7 +29,7 @@ diff --git a/gdb/configure b/gdb/configure
|
|||||||
if test -z "$ac_lib"; then
|
if test -z "$ac_lib"; then
|
||||||
ac_res="none required"
|
ac_res="none required"
|
||||||
else
|
else
|
||||||
@@ -9642,6 +9643,7 @@ case $host_os in
|
@@ -9650,6 +9651,7 @@ case $host_os in
|
||||||
esac
|
esac
|
||||||
|
|
||||||
# These are the libraries checked by Readline.
|
# These are the libraries checked by Readline.
|
||||||
@ -37,7 +37,7 @@ diff --git a/gdb/configure b/gdb/configure
|
|||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing tgetent" >&5
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing tgetent" >&5
|
||||||
$as_echo_n "checking for library containing tgetent... " >&6; }
|
$as_echo_n "checking for library containing tgetent... " >&6; }
|
||||||
if ${ac_cv_search_tgetent+:} false; then :
|
if ${ac_cv_search_tgetent+:} false; then :
|
||||||
@@ -9666,7 +9668,7 @@ return tgetent ();
|
@@ -9674,7 +9676,7 @@ return tgetent ();
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
_ACEOF
|
_ACEOF
|
||||||
|
@ -213,7 +213,7 @@ diff --git a/gdb/nat/linux-btrace.h b/gdb/nat/linux-btrace.h
|
|||||||
diff --git a/gdbsupport/common.m4 b/gdbsupport/common.m4
|
diff --git a/gdbsupport/common.m4 b/gdbsupport/common.m4
|
||||||
--- a/gdbsupport/common.m4
|
--- a/gdbsupport/common.m4
|
||||||
+++ b/gdbsupport/common.m4
|
+++ b/gdbsupport/common.m4
|
||||||
@@ -135,7 +135,7 @@ AC_DEFUN([GDB_AC_COMMON], [
|
@@ -140,7 +140,7 @@ AC_DEFUN([GDB_AC_COMMON], [
|
||||||
AC_PREPROC_IFELSE([AC_LANG_SOURCE([[
|
AC_PREPROC_IFELSE([AC_LANG_SOURCE([[
|
||||||
#include <linux/perf_event.h>
|
#include <linux/perf_event.h>
|
||||||
#ifndef PERF_ATTR_SIZE_VER5
|
#ifndef PERF_ATTR_SIZE_VER5
|
||||||
|
7
gdb.spec
7
gdb.spec
@ -33,11 +33,11 @@ Name: %{?scl_prefix}gdb
|
|||||||
# See timestamp of source gnulib installed into gnulib/ .
|
# See timestamp of source gnulib installed into gnulib/ .
|
||||||
%global snapgnulib 20210105
|
%global snapgnulib 20210105
|
||||||
%global tarname gdb-%{version}
|
%global tarname gdb-%{version}
|
||||||
Version: 11.1
|
Version: 11.2
|
||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 12%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||||
# Do not provide URL for snapshots as the file lasts there only for 2 days.
|
# Do not provide URL for snapshots as the file lasts there only for 2 days.
|
||||||
@ -1144,6 +1144,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 9 2022 Kevin Buettner - 11.2-1
|
||||||
|
- Rebase to FSF GDB 11.2.
|
||||||
|
|
||||||
* Mon Jan 31 2022 Kevin Buettner <kevinb@redhat.com> - 11.1-12
|
* Mon Jan 31 2022 Kevin Buettner <kevinb@redhat.com> - 11.1-12
|
||||||
- Fix "sect_index_data not initialized" internal error. (RHBZ 2042664,
|
- Fix "sect_index_data not initialized" internal error. (RHBZ 2042664,
|
||||||
Kevin Buettner).
|
Kevin Buettner).
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz) = a8b1c54dd348cfeb37da73f968742896be3dd13a4215f8d8519870c2abea915f5176c3fa6989ddd10f20020a16f0fab20cbae68ee8d58a82234d8778023520f8
|
SHA512 (gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz) = a8b1c54dd348cfeb37da73f968742896be3dd13a4215f8d8519870c2abea915f5176c3fa6989ddd10f20020a16f0fab20cbae68ee8d58a82234d8778023520f8
|
||||||
SHA512 (gdb-11.1.tar.xz) = c40bf970e2f7c2107b29c5aa6a7150daa709d75ddadb73ac20742419d4637d158e3063a4c6ff6e47fae8ca8e1d36253973f85ea15445d004be6d5d7a2dd9bd46
|
|
||||||
SHA512 (v2.0.5.tar.gz) = 2e7ac2aede84671b15597d9c56dbe077a81357bbf44b6684802592246fb7729b4a5743238ddf02f6ea143b4d29872f581408135f9c1ea1ccc99dab905916d98d
|
SHA512 (v2.0.5.tar.gz) = 2e7ac2aede84671b15597d9c56dbe077a81357bbf44b6684802592246fb7729b4a5743238ddf02f6ea143b4d29872f581408135f9c1ea1ccc99dab905916d98d
|
||||||
|
SHA512 (gdb-11.2.tar.xz) = 07e9026423438049b11f4f784d57401ece4e940570f613bd6958b3714fe7fbc2c048470bcce3e7d7d9f93331cdf3881d30dcc964cb113a071143a02b28e5b127
|
||||||
|
Loading…
Reference in New Issue
Block a user