Temporarily add gdb-temporary-fix-arm-build-error.patch.
This commit is contained in:
parent
96770ac25f
commit
d1a098601d
@ -466,3 +466,7 @@ Patch113: gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
# Author: Sergio Durigan Junior.
|
||||
Patch114: gdb-rhbz795424-bitpos-arrayview.patch
|
||||
|
||||
# Temporary patch to fix ARM build error.
|
||||
# https://kojipkgs.fedoraproject.org//work/tasks/9012/33639012/build.log
|
||||
Patch115: gdb-temporary-fix-arm-build-error.patch
|
||||
|
||||
|
@ -112,3 +112,4 @@
|
||||
%patch112 -p1
|
||||
%patch113 -p1
|
||||
%patch114 -p1
|
||||
%patch115 -p1
|
||||
|
@ -112,3 +112,4 @@ gdb-archer.patch
|
||||
gdb-vla-intel-fix-print-char-array.patch
|
||||
gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
gdb-rhbz795424-bitpos-arrayview.patch
|
||||
gdb-temporary-fix-arm-build-error.patch
|
||||
|
75
gdb-temporary-fix-arm-build-error.patch
Normal file
75
gdb-temporary-fix-arm-build-error.patch
Normal file
@ -0,0 +1,75 @@
|
||||
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||
From: Alan Hayward <alan.hayward@arm.com>
|
||||
Date: Mon, 18 Mar 2019 16:13:12 +0000
|
||||
Subject: gdb-temporary-fix-arm-build-error.patch
|
||||
|
||||
;; Temporary patch to fix ARM build error.
|
||||
;; https://kojipkgs.fedoraproject.org//work/tasks/9012/33639012/build.log
|
||||
|
||||
Fix Arm build error
|
||||
|
||||
The following commit broke the build for Arm:
|
||||
d3a70e03cf51c8fb6bc183eaff7559edffec2045
|
||||
Change iterate_over_lwps to take a gdb::function_view
|
||||
|
||||
Correct the changes made to arm_linux_insert_hw_breakpoint1 and make
|
||||
similar changes to arm_linux_remove_hw_breakpoint1.
|
||||
|
||||
2019-03-18 Alan Hayward <alan.hayward@arm.com>
|
||||
|
||||
* arm-linux-nat.c (arm_linux_insert_hw_breakpoint1): Fix
|
||||
variable names.
|
||||
(arm_linux_remove_hw_breakpoint1): Use a gdb::function_view.
|
||||
|
||||
diff --git a/gdb/ChangeLog b/gdb/ChangeLog
|
||||
--- a/gdb/ChangeLog
|
||||
+++ b/gdb/ChangeLog
|
||||
@@ -1,3 +1,9 @@
|
||||
+2019-03-18 Alan Hayward <alan.hayward@arm.com>
|
||||
+
|
||||
+ * arm-linux-nat.c (arm_linux_insert_hw_breakpoint1): Fix
|
||||
+ variable names.
|
||||
+ (arm_linux_remove_hw_breakpoint1): Use a gdb::function_view.
|
||||
+
|
||||
2019-03-18 Pedro Alves <palves@redhat.com>
|
||||
Eli Zaretskii <eliz@gnu.org>
|
||||
|
||||
diff --git a/gdb/arm-linux-nat.c b/gdb/arm-linux-nat.c
|
||||
--- a/gdb/arm-linux-nat.c
|
||||
+++ b/gdb/arm-linux-nat.c
|
||||
@@ -1005,8 +1005,8 @@ arm_linux_insert_hw_breakpoint1 (const struct arm_linux_hw_breakpoint* bpt,
|
||||
iterate_over_lwps (pid_ptid,
|
||||
[=] (struct lwp_info *info)
|
||||
{
|
||||
- return update_registers_callback (info, watch,
|
||||
- index);
|
||||
+ return update_registers_callback (info, watchpoint,
|
||||
+ i);
|
||||
});
|
||||
break;
|
||||
}
|
||||
@@ -1024,7 +1024,6 @@ arm_linux_remove_hw_breakpoint1 (const struct arm_linux_hw_breakpoint *bpt,
|
||||
gdb_byte count, i;
|
||||
ptid_t pid_ptid;
|
||||
struct arm_linux_hw_breakpoint* bpts;
|
||||
- struct update_registers_data data;
|
||||
|
||||
pid = inferior_ptid.pid ();
|
||||
pid_ptid = ptid_t (pid);
|
||||
@@ -1043,10 +1042,13 @@ arm_linux_remove_hw_breakpoint1 (const struct arm_linux_hw_breakpoint *bpt,
|
||||
for (i = 0; i < count; ++i)
|
||||
if (arm_linux_hw_breakpoint_equal (bpt, bpts + i))
|
||||
{
|
||||
- data.watch = watchpoint;
|
||||
- data.index = i;
|
||||
bpts[i].control = arm_hwbp_control_disable (bpts[i].control);
|
||||
- iterate_over_lwps (pid_ptid, update_registers_callback, &data);
|
||||
+ iterate_over_lwps (pid_ptid,
|
||||
+ [=] (struct lwp_info *info)
|
||||
+ {
|
||||
+ return update_registers_callback (info, watchpoint,
|
||||
+ i);
|
||||
+ });
|
||||
break;
|
||||
}
|
||||
|
1
gdb.spec
1
gdb.spec
@ -1027,6 +1027,7 @@ fi
|
||||
%changelog
|
||||
* Tue Mar 19 2019 Sergio Durigan Junior <sergiodj@redhat.com> - 8.3.50.20190319-2
|
||||
- Rebase to FSF GDB 8.3.50.20190319 (8.4pre).
|
||||
- Temporarily add gdb-temporary-fix-arm-build-error.patch.
|
||||
|
||||
* Mon Mar 4 2019 Sergio Durigan Junior <sergiodj@redhat.com> - 8.3.50.20190304-1
|
||||
- Rebase to FSF GDB 8.3.50.20190304 (8.4pre).
|
||||
|
Loading…
Reference in New Issue
Block a user