- Fix hiding unexpected breakpoints on intentional step/next commands.
- Fix s390 compilation warning/failure due to a wrongly sized type-cast.
This commit is contained in:
parent
e42a86f6e6
commit
cc171577b7
@ -497,7 +497,7 @@ diff -u -rup gdb-6.6-orig/gdb/symfile.c gdb-6.6/gdb/symfile.c
|
||||
+ if (build_id_debug)
|
||||
+ warning (_("build-id: Error reading "
|
||||
+ "ELF program headers at address 0x%lx"),
|
||||
+ (unsigned long) ehdr_vma + i_ehdr.e_phoff);
|
||||
+ (unsigned long) (ehdr_vma + i_ehdr.e_phoff));
|
||||
+ return NULL;
|
||||
+ }
|
||||
+
|
||||
|
@ -12,6 +12,11 @@
|
||||
the software watchpoint events.
|
||||
* linux-nat.h (struct lwp_info): Redeclare STEP as ENUM RESUME_STEP.
|
||||
|
||||
2007-10-19 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* infrun.c (proceed): RESUME_STEP initialized for non-stepping.
|
||||
RESUME_STEP set according to STEP only at the end of the function.
|
||||
|
||||
--- ./gdb/inferior.h 15 Jun 2007 22:44:55 -0000 1.83
|
||||
+++ ./gdb/inferior.h 25 Jun 2007 20:33:02 -0000
|
||||
@@ -194,7 +194,15 @@ extern void reopen_exec_file (void);
|
||||
@ -78,13 +83,12 @@
|
||||
{
|
||||
/* User-settable 'scheduler' mode requires solo thread resume. */
|
||||
resume_ptid = inferior_ptid;
|
||||
@@ -711,7 +716,8 @@ static CORE_ADDR prev_pc;
|
||||
@@ -711,7 +716,7 @@ static CORE_ADDR prev_pc;
|
||||
void
|
||||
proceed (CORE_ADDR addr, enum target_signal siggnal, int step)
|
||||
{
|
||||
- int oneproc = 0;
|
||||
+ enum resume_step resume_step = (step ? RESUME_STEP_USER
|
||||
+ : RESUME_STEP_CONTINUE);
|
||||
+ enum resume_step resume_step = RESUME_STEP_CONTINUE;
|
||||
|
||||
if (step > 0)
|
||||
step_start_function = find_pc_function (read_pc ());
|
||||
@ -116,10 +120,12 @@
|
||||
/* We will get a trace trap after one instruction.
|
||||
Continue it automatically and insert breakpoints then. */
|
||||
trap_expected = 1;
|
||||
@@ -806,8 +812,11 @@ proceed (CORE_ADDR addr, enum target_sig
|
||||
@@ -806,8 +812,13 @@ proceed (CORE_ADDR addr, enum target_sig
|
||||
updated correctly when the inferior is stopped. */
|
||||
prev_pc = read_pc ();
|
||||
|
||||
+ if (step)
|
||||
+ resume_step = RESUME_STEP_USER;
|
||||
+ if (resume_step == RESUME_STEP_CONTINUE && bpstat_should_step ())
|
||||
+ resume_step = RESUME_STEP_NEEDED;
|
||||
+
|
||||
|
6
gdb.spec
6
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
||||
Version: 6.6
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
Release: 36%{?dist}
|
||||
Release: 37%{?dist}
|
||||
|
||||
License: GPL
|
||||
Group: Development/Debuggers
|
||||
@ -701,6 +701,10 @@ fi
|
||||
# don't include the files in include, they are part of binutils
|
||||
|
||||
%changelog
|
||||
* Fri Oct 19 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.6-37
|
||||
- Fix hiding unexpected breakpoints on intentional step/next commands.
|
||||
- Fix s390 compilation warning/failure due to a wrongly sized type-cast.
|
||||
|
||||
* Sun Oct 14 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.6-36
|
||||
- Fix hardware watchpoints after inferior forks-off some process.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user