Backport upstream patch "Add support for readline 8.2". (Andreas Schwab)
This commit is contained in:
parent
267b55ff0e
commit
c5ab349836
@ -310,3 +310,6 @@ Patch073: gdb-rhbz1398387-tab-crash-test.patch
|
|||||||
# =fedoratest
|
# =fedoratest
|
||||||
Patch074: gdb-rhbz1553104-s390x-arch12-test.patch
|
Patch074: gdb-rhbz1553104-s390x-arch12-test.patch
|
||||||
|
|
||||||
|
|
||||||
|
Patch075: gdb-backport-readline_support.patch
|
||||||
|
|
||||||
|
@ -72,3 +72,4 @@
|
|||||||
%patch072 -p1
|
%patch072 -p1
|
||||||
%patch073 -p1
|
%patch073 -p1
|
||||||
%patch074 -p1
|
%patch074 -p1
|
||||||
|
%patch075 -p1
|
||||||
|
@ -72,3 +72,4 @@ gdb-linux_perf-bundle.patch
|
|||||||
gdb-libexec-add-index.patch
|
gdb-libexec-add-index.patch
|
||||||
gdb-rhbz1398387-tab-crash-test.patch
|
gdb-rhbz1398387-tab-crash-test.patch
|
||||||
gdb-rhbz1553104-s390x-arch12-test.patch
|
gdb-rhbz1553104-s390x-arch12-test.patch
|
||||||
|
gdb-backport-readline_support.patch
|
||||||
|
31
gdb-backport-readline_support.patch
Normal file
31
gdb-backport-readline_support.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Alexandra=20H=C3=A1jkov=C3=A1?= <ahajkova@redhat.com>
|
||||||
|
Date: Mon, 10 Oct 2022 15:44:52 +0200
|
||||||
|
Subject: gdb-backport-readline_support.patch
|
||||||
|
|
||||||
|
Add support for readline 8.2
|
||||||
|
|
||||||
|
In readline 8.2 the type of rl_completer_word_break_characters changed to
|
||||||
|
include const.
|
||||||
|
|
||||||
|
diff --git a/gdb/completer.c b/gdb/completer.c
|
||||||
|
--- a/gdb/completer.c
|
||||||
|
+++ b/gdb/completer.c
|
||||||
|
@@ -36,7 +36,7 @@
|
||||||
|
calling a hook instead so we eliminate the CLI dependency. */
|
||||||
|
#include "gdbcmd.h"
|
||||||
|
|
||||||
|
-/* Needed for rl_completer_word_break_characters() and for
|
||||||
|
+/* Needed for rl_completer_word_break_characters and for
|
||||||
|
rl_filename_completion_function. */
|
||||||
|
#include "readline/readline.h"
|
||||||
|
|
||||||
|
@@ -2011,7 +2011,7 @@ gdb_completion_word_break_characters_throw ()
|
||||||
|
rl_basic_quote_characters = NULL;
|
||||||
|
}
|
||||||
|
|
||||||
|
- return rl_completer_word_break_characters;
|
||||||
|
+ return (char *) rl_completer_word_break_characters;
|
||||||
|
}
|
||||||
|
|
||||||
|
char *
|
3
gdb.spec
3
gdb.spec
@ -1189,6 +1189,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 13 2022 Alexandra Hájková - 12.1-6
|
||||||
|
- Backport upstream patch "Add support for readline 8.2". (Andreas Schwab)
|
||||||
|
|
||||||
* Fri Oct 7 2022 Alexandra Hájková - 12.1-6
|
* Fri Oct 7 2022 Alexandra Hájková - 12.1-6
|
||||||
- Update gdb-6.6-buildid-locate.patch to fix RHBZ 2122947.
|
- Update gdb-6.6-buildid-locate.patch to fix RHBZ 2122947.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user