Fix build breakage when compiling bfd/elf.c with gcc 10. (RHBZ 1818011,
H.J. Lu)
This commit is contained in:
parent
03ff51b230
commit
c3e0b255c8
@ -394,3 +394,6 @@ Patch096: gdb-vla-intel-fix-print-char-array.patch
|
||||
# =fedoratest
|
||||
Patch097: gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
|
||||
# Fix int conversion error from bfd/elf.c when compiling with gcc 10
|
||||
Patch098: gdb-rhbz1818011-bfd-gcc10-error.patch
|
||||
|
||||
|
@ -95,3 +95,4 @@
|
||||
%patch095 -p1
|
||||
%patch096 -p1
|
||||
%patch097 -p1
|
||||
%patch098 -p1
|
||||
|
@ -95,3 +95,4 @@ gdb-rhbz1398387-tab-crash-test.patch
|
||||
gdb-archer.patch
|
||||
gdb-vla-intel-fix-print-char-array.patch
|
||||
gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
gdb-rhbz1818011-bfd-gcc10-error.patch
|
||||
|
49
gdb-rhbz1818011-bfd-gcc10-error.patch
Normal file
49
gdb-rhbz1818011-bfd-gcc10-error.patch
Normal file
@ -0,0 +1,49 @@
|
||||
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Buettner <kevinb@redhat.com>
|
||||
Date: Wed, 8 Apr 2020 16:15:52 -0400
|
||||
Subject: gdb-rhbz1818011-bfd-gcc10-error.patch
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
;; Fix int conversion error from bfd/elf.c when compiling with gcc 10
|
||||
|
||||
Original commit message from H.J. Lu <hjl.tools@gmail.com> is below:
|
||||
|
||||
bfd: Change num_group to unsigned int
|
||||
|
||||
elf.c failed with to with GCC 10 as of
|
||||
|
||||
commit 906b3eb9df6c577d3f6e9c3ea5c9d7e4d1e90536
|
||||
Author: Martin Liska <mliska@suse.cz>
|
||||
Date: Tue Mar 24 11:40:10 2020 +0100
|
||||
|
||||
Improve endianess detection.
|
||||
|
||||
PR lto/94249
|
||||
* plugin-api.h: Add more robust endianess detection.
|
||||
|
||||
binutils-gdb/bfd/elf.c: In function ‘setup_group’:
|
||||
binutils-gdb/bfd/elf.c:740:35: error: overflow in conversion from ‘unsigned int’ to ‘int’ changes value from ‘num_group = 4294967295’ to ‘-1’ [-Werror=overflow]
|
||||
740 | elf_tdata (abfd)->num_group = num_group = -1;
|
||||
| ^~~~~~~~~
|
||||
cc1: all warnings being treated as errors
|
||||
make[2]: *** [Makefile:1608: elf.lo] Error 1
|
||||
|
||||
Change num_group in elf_obj_tdata to unsigned int to compile with GCC 10.
|
||||
|
||||
PR binutils/25717
|
||||
* elf-bfd.h (elf_obj_tdata): Change num_group to unsigned int.
|
||||
|
||||
diff --git a/bfd/elf-bfd.h b/bfd/elf-bfd.h
|
||||
--- a/bfd/elf-bfd.h
|
||||
+++ b/bfd/elf-bfd.h
|
||||
@@ -1937,7 +1937,7 @@ struct elf_obj_tdata
|
||||
struct sdt_note *sdt_note_head;
|
||||
|
||||
Elf_Internal_Shdr **group_sect_ptr;
|
||||
- int num_group;
|
||||
+ unsigned int num_group;
|
||||
|
||||
/* Index into group_sect_ptr, updated by setup_group when finding a
|
||||
section's group. Used to optimize subsequent group searches. */
|
6
gdb.spec
6
gdb.spec
@ -35,7 +35,7 @@ Version: 9.1
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
# Do not provide URL for snapshots as the file lasts there only for 2 days.
|
||||
@ -1155,6 +1155,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Apr 08 2020 Kevin Buettner <kevinb@redhat.com> - 9.1-5
|
||||
- Fix build breakage when compiling bfd/elf.c with gcc 10. (RHBZ 1818011,
|
||||
H.J. Lu)
|
||||
|
||||
* Mon Mar 2 2020 Sergio Durigan Junior <sergiodj@redhat.com> - 9.1-4
|
||||
- Add '--without-guile' to GDB_MINIMAL_CONFIGURE_FLAGS.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user