- Fix `errno' resolving on recent glibc with broken
DW_AT_MIPS_linkage_name. - Imported new test for 6.7 PPC hiding of call-volatile parameter register.
This commit is contained in:
parent
27c2469e2f
commit
b0ab3a801f
@ -1,7 +1,7 @@
|
|||||||
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=185337
|
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=185337
|
||||||
|
|
||||||
|
|
||||||
currently for trivia nonthreaded helloworld with no debug info up to -ggdb2 you
|
currently for trivial nonthreaded helloworld with no debug info up to -ggdb2 you
|
||||||
will get:
|
will get:
|
||||||
(gdb) p errno
|
(gdb) p errno
|
||||||
[some error]
|
[some error]
|
||||||
@ -17,17 +17,150 @@ Attached suggestion patch how to deal with the most common "errno" symbol
|
|||||||
for the most common under-ggdb3 compiled programs.
|
for the most common under-ggdb3 compiled programs.
|
||||||
|
|
||||||
|
|
||||||
2006-08-25 Jan Kratochvil <jan.kratochvil@redhat.com>
|
|
||||||
|
|
||||||
* target.c (target_translate_tls_address): Provided warnings for TLS
|
2007-11-03 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||||
`errno' on non-TLS targets.
|
|
||||||
|
* ./gdb/dwarf2read.c (read_partial_die, dwarf2_linkage_name): Prefer
|
||||||
|
DW_AT_MIPS_linkage_name over DW_AT_name now only for non-C.
|
||||||
|
|
||||||
|
glibc-debuginfo-2.7-2.x86_64: /usr/lib/debug/lib64/libc.so.6.debug:
|
||||||
|
<81a2> DW_AT_name : (indirect string, offset: 0x280e): __errno_location
|
||||||
|
<81a8> DW_AT_MIPS_linkage_name: (indirect string, offset: 0x2808): *__GI___errno_location
|
||||||
|
|
||||||
|
--- ./gdb/dwarf2read.c 25 Oct 2007 20:54:27 -0000 1.236
|
||||||
|
+++ ./gdb/dwarf2read.c 3 Nov 2007 21:03:43 -0000
|
||||||
|
@@ -5550,8 +5550,8 @@ read_partial_die (struct partial_die_inf
|
||||||
|
{
|
||||||
|
case DW_AT_name:
|
||||||
|
|
||||||
|
- /* Prefer DW_AT_MIPS_linkage_name over DW_AT_name. */
|
||||||
|
- if (part_die->name == NULL)
|
||||||
|
+ /* Prefer DW_AT_MIPS_linkage_name over DW_AT_name for non-C. */
|
||||||
|
+ if (cu->language == language_c || part_die->name == NULL)
|
||||||
|
part_die->name = DW_STRING (&attr);
|
||||||
|
break;
|
||||||
|
case DW_AT_comp_dir:
|
||||||
|
@@ -5559,7 +5559,9 @@ read_partial_die (struct partial_die_inf
|
||||||
|
part_die->dirname = DW_STRING (&attr);
|
||||||
|
break;
|
||||||
|
case DW_AT_MIPS_linkage_name:
|
||||||
|
- part_die->name = DW_STRING (&attr);
|
||||||
|
+ /* Prefer DW_AT_MIPS_linkage_name over DW_AT_name for non-C. */
|
||||||
|
+ if (cu->language != language_c || part_die->name == NULL)
|
||||||
|
+ part_die->name = DW_STRING (&attr);
|
||||||
|
break;
|
||||||
|
case DW_AT_low_pc:
|
||||||
|
has_low_pc_attr = 1;
|
||||||
|
@@ -7871,9 +7873,13 @@ dwarf2_linkage_name (struct die_info *di
|
||||||
|
{
|
||||||
|
struct attribute *attr;
|
||||||
|
|
||||||
|
- attr = dwarf2_attr (die, DW_AT_MIPS_linkage_name, cu);
|
||||||
|
- if (attr && DW_STRING (attr))
|
||||||
|
- return DW_STRING (attr);
|
||||||
|
+ /* Prefer DW_AT_MIPS_linkage_name over DW_AT_name for non-C. */
|
||||||
|
+ if (cu->language != language_c)
|
||||||
|
+ {
|
||||||
|
+ attr = dwarf2_attr (die, DW_AT_MIPS_linkage_name, cu);
|
||||||
|
+ if (attr && DW_STRING (attr))
|
||||||
|
+ return DW_STRING (attr);
|
||||||
|
+ }
|
||||||
|
attr = dwarf2_attr (die, DW_AT_name, cu);
|
||||||
|
if (attr && DW_STRING (attr))
|
||||||
|
return DW_STRING (attr);
|
||||||
|
|
||||||
|
|
||||||
Index: gdb-6.6/gdb/target.c
|
|
||||||
===================================================================
|
diff -u -X /home/jkratoch/.diffi.list -rup gdb-6.7.1/gdb/gdbtypes.c gdb-6.7.1-patched/gdb/gdbtypes.c
|
||||||
--- gdb-6.6.orig/gdb/target.c 2007-01-17 01:25:31.000000000 +0100
|
--- gdb-6.7.1/gdb/gdbtypes.c 2007-11-04 01:43:03.000000000 +0100
|
||||||
+++ gdb-6.6/gdb/target.c 2007-01-20 06:31:36.000000000 +0100
|
+++ gdb-6.7.1-patched/gdb/gdbtypes.c 2007-11-04 01:09:31.000000000 +0100
|
||||||
@@ -898,7 +898,18 @@
|
@@ -3465,6 +3465,8 @@ gdbtypes_post_init (struct gdbarch *gdba
|
||||||
|
init_type (TYPE_CODE_INT,
|
||||||
|
gdbarch_int_bit (current_gdbarch) / TARGET_CHAR_BIT,
|
||||||
|
0, "int", (struct objfile *) NULL);
|
||||||
|
+ builtin_type->builtin_int_ptr =
|
||||||
|
+ make_pointer_type (builtin_type->builtin_int, NULL);
|
||||||
|
builtin_type->builtin_unsigned_int =
|
||||||
|
init_type (TYPE_CODE_INT,
|
||||||
|
gdbarch_int_bit (current_gdbarch) / TARGET_CHAR_BIT,
|
||||||
|
@@ -3559,6 +3561,11 @@ gdbtypes_post_init (struct gdbarch *gdba
|
||||||
|
"<text variable, no debug info>", NULL);
|
||||||
|
TYPE_TARGET_TYPE (builtin_type->nodebug_text_symbol) =
|
||||||
|
builtin_type->builtin_int;
|
||||||
|
+ builtin_type->nodebug_text_symbol_errno_location =
|
||||||
|
+ init_type (TYPE_CODE_FUNC, 1, 0,
|
||||||
|
+ "<text variable for __errno_location, no debug info>", NULL);
|
||||||
|
+ TYPE_TARGET_TYPE (builtin_type->nodebug_text_symbol_errno_location) =
|
||||||
|
+ builtin_type->builtin_int_ptr;
|
||||||
|
builtin_type->nodebug_data_symbol =
|
||||||
|
init_type (TYPE_CODE_INT,
|
||||||
|
gdbarch_int_bit (gdbarch) / HOST_CHAR_BIT, 0,
|
||||||
|
diff -u -X /home/jkratoch/.diffi.list -rup gdb-6.7.1/gdb/gdbtypes.h gdb-6.7.1-patched/gdb/gdbtypes.h
|
||||||
|
--- gdb-6.7.1/gdb/gdbtypes.h 2007-11-04 01:43:03.000000000 +0100
|
||||||
|
+++ gdb-6.7.1-patched/gdb/gdbtypes.h 2007-11-04 01:07:50.000000000 +0100
|
||||||
|
@@ -1008,6 +1008,7 @@ struct builtin_type
|
||||||
|
|
||||||
|
/* Types used for symbols with no debug information. */
|
||||||
|
struct type *nodebug_text_symbol;
|
||||||
|
+ struct type *nodebug_text_symbol_errno_location;
|
||||||
|
struct type *nodebug_data_symbol;
|
||||||
|
struct type *nodebug_unknown_symbol;
|
||||||
|
struct type *nodebug_tls_symbol;
|
||||||
|
@@ -1026,6 +1027,7 @@ struct builtin_type
|
||||||
|
struct type *builtin_char;
|
||||||
|
struct type *builtin_short;
|
||||||
|
struct type *builtin_int;
|
||||||
|
+ struct type *builtin_int_ptr;
|
||||||
|
struct type *builtin_long;
|
||||||
|
struct type *builtin_signed_char;
|
||||||
|
struct type *builtin_unsigned_char;
|
||||||
|
diff -u -X /home/jkratoch/.diffi.list -rup gdb-6.7.1/gdb/parse.c gdb-6.7.1-patched/gdb/parse.c
|
||||||
|
--- gdb-6.7.1/gdb/parse.c 2007-08-23 20:08:36.000000000 +0200
|
||||||
|
+++ gdb-6.7.1-patched/gdb/parse.c 2007-11-04 01:06:59.000000000 +0100
|
||||||
|
@@ -424,7 +424,12 @@ write_exp_msymbol (struct minimal_symbol
|
||||||
|
case mst_text:
|
||||||
|
case mst_file_text:
|
||||||
|
case mst_solib_trampoline:
|
||||||
|
- write_exp_elt_type (builtin_type (gdbarch)->nodebug_text_symbol);
|
||||||
|
+ if (builtin_type (gdbarch)->nodebug_text_symbol_errno_location != NULL
|
||||||
|
+ && strcmp (SYMBOL_LINKAGE_NAME (msymbol), "__errno_location") == 0)
|
||||||
|
+ write_exp_elt_type (builtin_type (gdbarch)
|
||||||
|
+ ->nodebug_text_symbol_errno_location);
|
||||||
|
+ else
|
||||||
|
+ write_exp_elt_type (builtin_type (gdbarch)->nodebug_text_symbol);
|
||||||
|
break;
|
||||||
|
|
||||||
|
case mst_data:
|
||||||
|
diff -u -X /home/jkratoch/.diffi.list -rup gdb-6.7.1/gdb/target.c gdb-6.7.1-patched/gdb/target.c
|
||||||
|
--- gdb-6.7.1/gdb/target.c 2007-11-04 01:43:03.000000000 +0100
|
||||||
|
+++ gdb-6.7.1-patched/gdb/target.c 2007-11-04 01:37:45.000000000 +0100
|
||||||
|
@@ -819,6 +819,25 @@ pop_target (void)
|
||||||
|
internal_error (__FILE__, __LINE__, _("failed internal consistency check"));
|
||||||
|
}
|
||||||
|
|
||||||
|
+static int
|
||||||
|
+resolve_errno (void *arg)
|
||||||
|
+{
|
||||||
|
+ CORE_ADDR *arg_addr = arg;
|
||||||
|
+ struct expression *expr;
|
||||||
|
+ struct cleanup *old_chain = 0;
|
||||||
|
+ struct value *val;
|
||||||
|
+
|
||||||
|
+ expr = parse_expression ("__errno_location()");
|
||||||
|
+ old_chain = make_cleanup (free_current_contents, &expr);
|
||||||
|
+ val = evaluate_expression (expr);
|
||||||
|
+ *arg_addr = value_as_address (val);
|
||||||
|
+ release_value (val);
|
||||||
|
+ value_free (val);
|
||||||
|
+ do_cleanups (old_chain);
|
||||||
|
+
|
||||||
|
+ return 1;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
/* Using the objfile specified in BATON, find the address for the
|
||||||
|
current thread's thread-local storage with offset OFFSET. */
|
||||||
|
CORE_ADDR
|
||||||
|
@@ -906,7 +925,22 @@ target_translate_tls_address (struct obj
|
||||||
/* It wouldn't be wrong here to try a gdbarch method, too; finding
|
/* It wouldn't be wrong here to try a gdbarch method, too; finding
|
||||||
TLS is an ABI-specific thing. But we don't do that yet. */
|
TLS is an ABI-specific thing. But we don't do that yet. */
|
||||||
else
|
else
|
||||||
@ -39,11 +172,118 @@ Index: gdb-6.6/gdb/target.c
|
|||||||
+ if (msymbol != NULL
|
+ if (msymbol != NULL
|
||||||
+ && SYMBOL_VALUE_ADDRESS (msymbol) == offset
|
+ && SYMBOL_VALUE_ADDRESS (msymbol) == offset
|
||||||
+ && SYMBOL_BFD_SECTION (msymbol)->owner == objfile->obfd)
|
+ && SYMBOL_BFD_SECTION (msymbol)->owner == objfile->obfd)
|
||||||
+ error (_("TLS symbol `errno' not resolved for non-TLS program."
|
+ {
|
||||||
+ " You should use symbol \"(*__errno_location ())\" or"
|
+ if (!catch_errors (resolve_errno, (void *) &addr, "",
|
||||||
+ " compile the program with `gcc -ggdb3' or `gcc -pthread'."));
|
+ RETURN_MASK_ALL))
|
||||||
+ error (_("Cannot find thread-local variables on this target"));
|
+ error (_("TLS symbol `errno' not resolved for non-TLS program."
|
||||||
|
+ " You should compile the program with `gcc -pthread'."));
|
||||||
|
+ }
|
||||||
|
+ else
|
||||||
|
+ error (_("Cannot find thread-local variables on this target"));
|
||||||
+ }
|
+ }
|
||||||
|
|
||||||
return addr;
|
return addr;
|
||||||
}
|
}
|
||||||
|
diff -u -X /home/jkratoch/.diffi.list -rup gdb-6.7.1/gdb/testsuite/gdb.dwarf2/dw2-errno.c gdb-6.7.1-patched/gdb/testsuite/gdb.dwarf2/dw2-errno.c
|
||||||
|
--- gdb-6.7.1/gdb/testsuite/gdb.dwarf2/dw2-errno.c 2007-11-04 01:43:41.000000000 +0100
|
||||||
|
+++ gdb-6.7.1-patched/gdb/testsuite/gdb.dwarf2/dw2-errno.c 2007-11-03 23:29:02.000000000 +0100
|
||||||
|
@@ -0,0 +1,28 @@
|
||||||
|
+/* This testcase is part of GDB, the GNU debugger.
|
||||||
|
+
|
||||||
|
+ Copyright 2005, 2007 Free Software Foundation, Inc.
|
||||||
|
+
|
||||||
|
+ This program is free software; you can redistribute it and/or modify
|
||||||
|
+ it under the terms of the GNU General Public License as published by
|
||||||
|
+ the Free Software Foundation; either version 3 of the License, or
|
||||||
|
+ (at your option) any later version.
|
||||||
|
+
|
||||||
|
+ This program is distributed in the hope that it will be useful,
|
||||||
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+ GNU General Public License for more details.
|
||||||
|
+
|
||||||
|
+ You should have received a copy of the GNU General Public License
|
||||||
|
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||||
|
+
|
||||||
|
+ Please email any bugs, comments, and/or additions to this file to:
|
||||||
|
+ bug-gdb@prep.ai.mit.edu */
|
||||||
|
+
|
||||||
|
+#include <errno.h>
|
||||||
|
+
|
||||||
|
+int main()
|
||||||
|
+{
|
||||||
|
+ errno = 42;
|
||||||
|
+
|
||||||
|
+ return 0; /* breakpoint */
|
||||||
|
+}
|
||||||
|
diff -u -X /home/jkratoch/.diffi.list -rup gdb-6.7.1/gdb/testsuite/gdb.dwarf2/dw2-errno.exp gdb-6.7.1-patched/gdb/testsuite/gdb.dwarf2/dw2-errno.exp
|
||||||
|
--- gdb-6.7.1/gdb/testsuite/gdb.dwarf2/dw2-errno.exp 2007-11-04 01:43:39.000000000 +0100
|
||||||
|
+++ gdb-6.7.1-patched/gdb/testsuite/gdb.dwarf2/dw2-errno.exp 2007-11-04 01:41:46.000000000 +0100
|
||||||
|
@@ -0,0 +1,67 @@
|
||||||
|
+# Copyright 2007 Free Software Foundation, Inc.
|
||||||
|
+
|
||||||
|
+# This program is free software; you can redistribute it and/or modify
|
||||||
|
+# it under the terms of the GNU General Public License as published by
|
||||||
|
+# the Free Software Foundation; either version 3 of the License, or
|
||||||
|
+# (at your option) any later version.
|
||||||
|
+#
|
||||||
|
+# This program is distributed in the hope that it will be useful,
|
||||||
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+# GNU General Public License for more details.
|
||||||
|
+#
|
||||||
|
+# You should have received a copy of the GNU General Public License
|
||||||
|
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||||
|
+
|
||||||
|
+if $tracelevel then {
|
||||||
|
+ strace $tracelevel
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+set prms_id 0
|
||||||
|
+set bug_id 0
|
||||||
|
+
|
||||||
|
+set testfile dw2-errno
|
||||||
|
+set srcfile ${testfile}.c
|
||||||
|
+set binfile ${objdir}/${subdir}/${testfile}
|
||||||
|
+
|
||||||
|
+proc prep {} {
|
||||||
|
+ global srcdir subdir binfile
|
||||||
|
+ gdb_exit
|
||||||
|
+ gdb_start
|
||||||
|
+ gdb_reinitialize_dir $srcdir/$subdir
|
||||||
|
+ gdb_load ${binfile}
|
||||||
|
+
|
||||||
|
+ runto_main
|
||||||
|
+
|
||||||
|
+ gdb_breakpoint [gdb_get_line_number "breakpoint"]
|
||||||
|
+ gdb_continue_to_breakpoint "breakpoint"
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+if { [gdb_compile "${srcdir}/${subdir}/${srcfile}" "${binfile}" executable "additional_flags=-g2"] != "" } {
|
||||||
|
+ untested "Couldn't compile test program"
|
||||||
|
+ return -1
|
||||||
|
+}
|
||||||
|
+prep
|
||||||
|
+gdb_test "print errno" ".* = 42" "errno with macros=N threads=N"
|
||||||
|
+
|
||||||
|
+if { [gdb_compile "${srcdir}/${subdir}/${srcfile}" "${binfile}" executable "additional_flags=-g3"] != "" } {
|
||||||
|
+ untested "Couldn't compile test program"
|
||||||
|
+ return -1
|
||||||
|
+}
|
||||||
|
+prep
|
||||||
|
+gdb_test "print errno" ".* = 42" "errno with macros=Y threads=N"
|
||||||
|
+
|
||||||
|
+if {[gdb_compile_pthreads "${srcdir}/${subdir}/${srcfile}" "${binfile}" executable "additional_flags=-g2"] != "" } {
|
||||||
|
+ return -1
|
||||||
|
+}
|
||||||
|
+prep
|
||||||
|
+gdb_test "print errno" ".* = 42" "errno with macros=N threads=Y"
|
||||||
|
+
|
||||||
|
+if {[gdb_compile_pthreads "${srcdir}/${subdir}/${srcfile}" "${binfile}" executable "additional_flags=-g3"] != "" } {
|
||||||
|
+ return -1
|
||||||
|
+}
|
||||||
|
+prep
|
||||||
|
+gdb_test "print errno" ".* = 42" "errno with macros=Y threads=Y"
|
||||||
|
+
|
||||||
|
+# TODO: Test the error on resolving ERRNO with only libc loaded.
|
||||||
|
+# Just how to find the current libc filename?
|
||||||
|
103
gdb-6.7-ppc-clobbered-registers-O2-test.patch
Normal file
103
gdb-6.7-ppc-clobbered-registers-O2-test.patch
Normal file
@ -0,0 +1,103 @@
|
|||||||
|
2007-11-04 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||||
|
|
||||||
|
* gdb.arch/ppc-clobbered-registers-O2.exp: `powerpc64' changed to
|
||||||
|
`powerpc*'.
|
||||||
|
|
||||||
|
Testcase for:
|
||||||
|
|
||||||
|
http://sourceware.org/ml/gdb-patches/2007-09/msg00228.html
|
||||||
|
|
||||||
|
2007-10-21 Luis Machado <luisgpm@br.ibm.com>
|
||||||
|
|
||||||
|
* rs6000-tdep.c (ppc_dwarf2_frame_init_reg): New function.
|
||||||
|
* (rs6000_gdbarch_init): Install ppc_dwarf2_frame_init_reg as
|
||||||
|
default dwarf2_frame_set_init_reg function.
|
||||||
|
|
||||||
|
--- /dev/null 1 Jan 1970 00:00:00 -0000
|
||||||
|
+++ ./gdb/testsuite/gdb.arch/ppc-clobbered-registers-O2.c 3 Nov 2007 22:22:28 -0000
|
||||||
|
@@ -0,0 +1,21 @@
|
||||||
|
+
|
||||||
|
+unsigned * __attribute__((noinline))
|
||||||
|
+start_sequence (unsigned * x, unsigned * y)
|
||||||
|
+{
|
||||||
|
+ return (unsigned *)0xdeadbeef;
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+unsigned __attribute__((noinline))
|
||||||
|
+gen_movsd (unsigned * operand0, unsigned * operand1)
|
||||||
|
+{
|
||||||
|
+ return *start_sequence(operand0, operand1);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+int main(void)
|
||||||
|
+{
|
||||||
|
+ unsigned x, y;
|
||||||
|
+
|
||||||
|
+ x = 13;
|
||||||
|
+ y = 14;
|
||||||
|
+ return (int)gen_movsd (&x, &y);
|
||||||
|
+}
|
||||||
|
--- /dev/null 1 Jan 1970 00:00:00 -0000
|
||||||
|
+++ ./gdb/testsuite/gdb.arch/ppc-clobbered-registers-O2.exp 3 Nov 2007 22:22:28 -0000
|
||||||
|
@@ -0,0 +1,61 @@
|
||||||
|
+# Copyright 2006 Free Software Foundation, Inc.
|
||||||
|
+#
|
||||||
|
+# This program is free software; you can redistribute it and/or modify
|
||||||
|
+# it under the terms of the GNU General Public License as published by
|
||||||
|
+# the Free Software Foundation; either version 2 of the License, or
|
||||||
|
+# (at your option) any later version.
|
||||||
|
+#
|
||||||
|
+# This program is distributed in the hope that it will be useful,
|
||||||
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+# GNU General Public License for more details.
|
||||||
|
+#
|
||||||
|
+# You should have received a copy of the GNU General Public License
|
||||||
|
+# along with this program; if not, write to the Free Software
|
||||||
|
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||||
|
+#
|
||||||
|
+# This file is part of the gdb testsuite.
|
||||||
|
+
|
||||||
|
+if $tracelevel {
|
||||||
|
+ strace $tracelevel
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+# Test displaying call clobbered registers in optimized binaries for ppc.
|
||||||
|
+# GDB should not show incorrect values.
|
||||||
|
+
|
||||||
|
+set prms_id 0
|
||||||
|
+set bug_id 0
|
||||||
|
+
|
||||||
|
+if ![istarget "powerpc*-*"] then {
|
||||||
|
+ verbose "Skipping powerpc* call clobbered registers testing."
|
||||||
|
+ return
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+set testfile "ppc-clobbered-registers-O2"
|
||||||
|
+set srcfile ${testfile}.c
|
||||||
|
+set binfile ${objdir}/${subdir}/${testfile}
|
||||||
|
+set compile_flags "debug additional_flags=-O2"
|
||||||
|
+
|
||||||
|
+if { [gdb_compile "${srcdir}/${subdir}/${srcfile}" "${binfile}" executable ${compile_flags}] != "" } {
|
||||||
|
+ unsupported "Testcase compile failed."
|
||||||
|
+ return -1
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+gdb_exit
|
||||||
|
+gdb_start
|
||||||
|
+gdb_reinitialize_dir $srcdir/$subdir
|
||||||
|
+gdb_load ${binfile}
|
||||||
|
+
|
||||||
|
+if ![runto_main] then {
|
||||||
|
+ perror "Couldn't run to breakpoint"
|
||||||
|
+ continue
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+gdb_test "b start_sequence" ".*Breakpoint 2 at.*line 6.*" \
|
||||||
|
+ "Insert breakpoint at problematic function"
|
||||||
|
+
|
||||||
|
+gdb_test continue ".*Breakpoint 2.*in start_sequence.*" \
|
||||||
|
+ "Run until problematic function"
|
||||||
|
+
|
||||||
|
+gdb_test backtrace ".*operand0=<value optimized out>.*operand1=<value optimized out>.*" \
|
||||||
|
+ "Check value of call clobbered registers"
|
11
gdb.spec
11
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
|||||||
Version: 6.7.1
|
Version: 6.7.1
|
||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
|
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -201,7 +201,6 @@ Patch188: gdb-6.5-bz203661-emit-relocs.patch
|
|||||||
Patch190: gdb-6.5-dwarf-stack-overflow.patch
|
Patch190: gdb-6.5-dwarf-stack-overflow.patch
|
||||||
|
|
||||||
# Support TLS symbols (+`errno' suggestion if no pthread is found) (BZ 185337).
|
# Support TLS symbols (+`errno' suggestion if no pthread is found) (BZ 185337).
|
||||||
# FIXME: Still to be updated.
|
|
||||||
Patch194: gdb-6.5-bz185337-resolve-tls-without-debuginfo-v2.patch
|
Patch194: gdb-6.5-bz185337-resolve-tls-without-debuginfo-v2.patch
|
||||||
|
|
||||||
# Fix TLS symbols resolving for objects with separate .debug file (-debuginfo).
|
# Fix TLS symbols resolving for objects with separate .debug file (-debuginfo).
|
||||||
@ -324,6 +323,9 @@ Patch282: gdb-6.7-charsign-test.patch
|
|||||||
# Fix rereading of the main executable on its change.
|
# Fix rereading of the main executable on its change.
|
||||||
Patch283: gdb-6.7-reread-exec_bfd.patch
|
Patch283: gdb-6.7-reread-exec_bfd.patch
|
||||||
|
|
||||||
|
# Test PPC hiding of call-volatile parameter register.
|
||||||
|
Patch284: gdb-6.7-ppc-clobbered-registers-O2-test.patch
|
||||||
|
|
||||||
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu gettext
|
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu gettext
|
||||||
BuildRequires: flex bison sharutils expat-devel
|
BuildRequires: flex bison sharutils expat-devel
|
||||||
Requires: readline
|
Requires: readline
|
||||||
@ -458,6 +460,7 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
|||||||
%patch280 -p1
|
%patch280 -p1
|
||||||
%patch282 -p1
|
%patch282 -p1
|
||||||
%patch283 -p1
|
%patch283 -p1
|
||||||
|
%patch284 -p1
|
||||||
|
|
||||||
# Change the version that gets printed at GDB startup, so it is RedHat
|
# Change the version that gets printed at GDB startup, so it is RedHat
|
||||||
# specific.
|
# specific.
|
||||||
@ -612,6 +615,10 @@ fi
|
|||||||
# don't include the files in include, they are part of binutils
|
# don't include the files in include, they are part of binutils
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Nov 4 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.7.1-3
|
||||||
|
- Fix `errno' resolving on recent glibc with broken DW_AT_MIPS_linkage_name.
|
||||||
|
- Imported new test for 6.7 PPC hiding of call-volatile parameter register.
|
||||||
|
|
||||||
* Sat Nov 3 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.7.1-2
|
* Sat Nov 3 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.7.1-2
|
||||||
- Backport `Breakpoints at multiple locations' patch primarily for C++.
|
- Backport `Breakpoints at multiple locations' patch primarily for C++.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user