Rebase to FSF GDB 8.1.50.20180704 (8.2pre).
Remove defattr directives from specfile.
This commit is contained in:
parent
57c3c609d3
commit
af046d7244
@ -1 +1 @@
|
||||
fd1ae9058720aa2738cc4852647097dd89c2bb88
|
||||
9b960ba18c83e3f9aad16fe8bf845f5c469712bd
|
||||
|
@ -115,7 +115,7 @@ diff --git a/gdb/amd64-linux-tdep.c b/gdb/amd64-linux-tdep.c
|
||||
static void
|
||||
amd64_linux_write_pc (struct regcache *regcache, CORE_ADDR pc)
|
||||
{
|
||||
@@ -1807,6 +1881,8 @@ amd64_linux_init_abi_common(struct gdbarch_info info, struct gdbarch *gdbarch)
|
||||
@@ -1808,6 +1882,8 @@ amd64_linux_init_abi_common(struct gdbarch_info info, struct gdbarch *gdbarch)
|
||||
|
||||
tdep->xsave_xcr0_offset = I386_LINUX_XSAVE_XCR0_OFFSET;
|
||||
|
||||
|
@ -8,7 +8,7 @@ Subject: gdb-archer-pie-addons-keep-disabled.patch
|
||||
diff --git a/gdb/breakpoint.c b/gdb/breakpoint.c
|
||||
--- a/gdb/breakpoint.c
|
||||
+++ b/gdb/breakpoint.c
|
||||
@@ -15519,6 +15519,50 @@ initialize_breakpoint_ops (void)
|
||||
@@ -15516,6 +15516,50 @@ initialize_breakpoint_ops (void)
|
||||
|
||||
static struct cmd_list_element *enablebreaklist = NULL;
|
||||
|
||||
|
@ -10,7 +10,7 @@ Subject: gdb-bz541866-rwatch-before-run.patch
|
||||
diff --git a/gdb/breakpoint.c b/gdb/breakpoint.c
|
||||
--- a/gdb/breakpoint.c
|
||||
+++ b/gdb/breakpoint.c
|
||||
@@ -8804,7 +8804,7 @@ init_breakpoint_sal (struct breakpoint *b, struct gdbarch *gdbarch,
|
||||
@@ -8801,7 +8801,7 @@ init_breakpoint_sal (struct breakpoint *b, struct gdbarch *gdbarch,
|
||||
int enabled, int internal, unsigned flags,
|
||||
int display_canonical)
|
||||
{
|
||||
@ -19,7 +19,7 @@ diff --git a/gdb/breakpoint.c b/gdb/breakpoint.c
|
||||
|
||||
if (type == bp_hardware_breakpoint)
|
||||
{
|
||||
@@ -14353,7 +14353,7 @@ enable_breakpoint_disp (struct breakpoint *bpt, enum bpdisp disposition,
|
||||
@@ -14350,7 +14350,7 @@ enable_breakpoint_disp (struct breakpoint *bpt, enum bpdisp disposition,
|
||||
|
||||
if (bpt->type == bp_hardware_breakpoint)
|
||||
{
|
||||
|
@ -9,7 +9,7 @@ Subject: gdb-container-rh-pkg.patch
|
||||
diff --git a/gdb/remote.c b/gdb/remote.c
|
||||
--- a/gdb/remote.c
|
||||
+++ b/gdb/remote.c
|
||||
@@ -13904,7 +13904,17 @@ remote_target::pid_to_exec_file (int pid)
|
||||
@@ -13901,7 +13901,17 @@ remote_target::pid_to_exec_file (int pid)
|
||||
char *annex = NULL;
|
||||
|
||||
if (packet_support (PACKET_qXfer_exec_file) != PACKET_ENABLE)
|
||||
|
@ -14,7 +14,7 @@ Bug in FSF GDB exploited by the ptrace-on-utrace interaction.
|
||||
diff --git a/gdb/breakpoint.c b/gdb/breakpoint.c
|
||||
--- a/gdb/breakpoint.c
|
||||
+++ b/gdb/breakpoint.c
|
||||
@@ -12013,6 +12013,8 @@ update_global_location_list (enum ugll_insert_mode insert_mode)
|
||||
@@ -12010,6 +12010,8 @@ update_global_location_list (enum ugll_insert_mode insert_mode)
|
||||
traps we can no longer explain. */
|
||||
|
||||
old_loc->events_till_retirement = 3 * (thread_count () + 1);
|
||||
|
@ -1311,7 +1311,7 @@ diff --git a/gdb/breakpoint.c b/gdb/breakpoint.c
|
||||
}
|
||||
return 0;
|
||||
}
|
||||
@@ -6819,7 +6819,7 @@ breakpoint_address_match (const address_space *aspace1, CORE_ADDR addr1,
|
||||
@@ -6816,7 +6816,7 @@ breakpoint_address_match (const address_space *aspace1, CORE_ADDR addr1,
|
||||
static int
|
||||
breakpoint_address_match_range (const address_space *aspace1,
|
||||
CORE_ADDR addr1,
|
||||
@ -1320,7 +1320,7 @@ diff --git a/gdb/breakpoint.c b/gdb/breakpoint.c
|
||||
CORE_ADDR addr2)
|
||||
{
|
||||
return ((gdbarch_has_global_breakpoints (target_gdbarch ())
|
||||
@@ -10902,7 +10902,7 @@ can_use_hardware_watchpoint (const std::vector<value_ref_ptr> &vals)
|
||||
@@ -10899,7 +10899,7 @@ can_use_hardware_watchpoint (const std::vector<value_ref_ptr> &vals)
|
||||
&& TYPE_CODE (vtype) != TYPE_CODE_ARRAY))
|
||||
{
|
||||
CORE_ADDR vaddr = value_address (v);
|
||||
@ -1865,7 +1865,7 @@ diff --git a/gdb/frame.h b/gdb/frame.h
|
||||
diff --git a/gdb/gdbarch.c b/gdb/gdbarch.c
|
||||
--- a/gdb/gdbarch.c
|
||||
+++ b/gdb/gdbarch.c
|
||||
@@ -1794,7 +1794,7 @@ set_gdbarch_wchar_signed (struct gdbarch *gdbarch,
|
||||
@@ -1799,7 +1799,7 @@ set_gdbarch_wchar_signed (struct gdbarch *gdbarch,
|
||||
}
|
||||
|
||||
const struct floatformat **
|
||||
@ -2758,7 +2758,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
|
||||
|
||||
int insert_watchpoint (CORE_ADDR, int, enum target_hw_bp_type,
|
||||
struct expression *) override;
|
||||
@@ -10408,7 +10408,7 @@ int remote_hw_watchpoint_length_limit = -1;
|
||||
@@ -10405,7 +10405,7 @@ int remote_hw_watchpoint_length_limit = -1;
|
||||
int remote_hw_breakpoint_limit = -1;
|
||||
|
||||
int
|
||||
@ -3430,7 +3430,7 @@ diff --git a/gdb/x86-nat.c b/gdb/x86-nat.c
|
||||
+x86_region_ok_for_hw_watchpoint (CORE_ADDR addr, LONGEST len)
|
||||
{
|
||||
struct x86_debug_reg_state *state
|
||||
= x86_debug_reg_state (ptid_get_pid (inferior_ptid));
|
||||
= x86_debug_reg_state (inferior_ptid.pid ());
|
||||
diff --git a/gdb/x86-nat.h b/gdb/x86-nat.h
|
||||
--- a/gdb/x86-nat.h
|
||||
+++ b/gdb/x86-nat.h
|
||||
|
@ -384,7 +384,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
|
||||
|
||||
int can_use_hw_breakpoint (enum bptype, int, int) override;
|
||||
|
||||
@@ -10337,7 +10337,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
|
||||
@@ -10334,7 +10334,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
|
||||
p = strchr (rs->buf, '\0');
|
||||
addr = remote_address_masked (addr);
|
||||
p += hexnumstr (p, (ULONGEST) addr);
|
||||
@ -393,7 +393,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
|
||||
|
||||
putpkt (rs->buf);
|
||||
getpkt (&rs->buf, &rs->buf_size, 0);
|
||||
@@ -10357,7 +10357,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
|
||||
@@ -10354,7 +10354,7 @@ remote_target::insert_watchpoint (CORE_ADDR addr, int len,
|
||||
|
||||
bool
|
||||
remote_target::watchpoint_addr_within_range (CORE_ADDR addr,
|
||||
@ -402,7 +402,7 @@ diff --git a/gdb/remote.c b/gdb/remote.c
|
||||
{
|
||||
CORE_ADDR diff = remote_address_masked (addr - start);
|
||||
|
||||
@@ -10386,7 +10386,7 @@ remote_target::remove_watchpoint (CORE_ADDR addr, int len,
|
||||
@@ -10383,7 +10383,7 @@ remote_target::remove_watchpoint (CORE_ADDR addr, int len,
|
||||
p = strchr (rs->buf, '\0');
|
||||
addr = remote_address_masked (addr);
|
||||
p += hexnumstr (p, (ULONGEST) addr);
|
||||
|
@ -600,7 +600,7 @@ diff --git a/gdb/mep-tdep.c b/gdb/mep-tdep.c
|
||||
diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
--- a/gdb/mips-tdep.c
|
||||
+++ b/gdb/mips-tdep.c
|
||||
@@ -477,7 +477,7 @@ static void
|
||||
@@ -489,7 +489,7 @@ static void
|
||||
mips_xfer_register (struct gdbarch *gdbarch, struct regcache *regcache,
|
||||
int reg_num, int length,
|
||||
enum bfd_endian endian, gdb_byte *in,
|
||||
@ -609,7 +609,7 @@ diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
{
|
||||
int reg_offset = 0;
|
||||
|
||||
@@ -500,8 +500,8 @@ mips_xfer_register (struct gdbarch *gdbarch, struct regcache *regcache,
|
||||
@@ -512,8 +512,8 @@ mips_xfer_register (struct gdbarch *gdbarch, struct regcache *regcache,
|
||||
}
|
||||
if (mips_debug)
|
||||
fprintf_unfiltered (gdb_stderr,
|
||||
@ -620,7 +620,7 @@ diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
if (mips_debug && out != NULL)
|
||||
{
|
||||
int i;
|
||||
@@ -4531,13 +4531,13 @@ mips_eabi_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
@@ -4543,13 +4543,13 @@ mips_eabi_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
gdb_byte ref_valbuf[MAX_MIPS_ABI_REGSIZE];
|
||||
struct value *arg = args[argnum];
|
||||
struct type *arg_type = check_typedef (value_type (arg));
|
||||
@ -637,7 +637,7 @@ diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
|
||||
/* The EABI passes structures that do not fit in a register by
|
||||
reference. */
|
||||
@@ -4807,7 +4807,7 @@ mips_eabi_return_value (struct gdbarch *gdbarch, struct value *function,
|
||||
@@ -4819,7 +4819,7 @@ mips_eabi_return_value (struct gdbarch *gdbarch, struct value *function,
|
||||
|
||||
static int
|
||||
mips_n32n64_fp_arg_chunk_p (struct gdbarch *gdbarch, struct type *arg_type,
|
||||
@ -646,7 +646,7 @@ diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
{
|
||||
int i;
|
||||
|
||||
@@ -4822,7 +4822,7 @@ mips_n32n64_fp_arg_chunk_p (struct gdbarch *gdbarch, struct type *arg_type,
|
||||
@@ -4834,7 +4834,7 @@ mips_n32n64_fp_arg_chunk_p (struct gdbarch *gdbarch, struct type *arg_type,
|
||||
|
||||
for (i = 0; i < TYPE_NFIELDS (arg_type); i++)
|
||||
{
|
||||
@ -655,7 +655,7 @@ diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
struct type *field_type;
|
||||
|
||||
/* We're only looking at normal fields. */
|
||||
@@ -4864,7 +4864,7 @@ mips_n32n64_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
@@ -4876,7 +4876,7 @@ mips_n32n64_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
int argreg;
|
||||
int float_argreg;
|
||||
int argnum;
|
||||
@ -664,7 +664,7 @@ diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
int stack_offset = 0;
|
||||
enum bfd_endian byte_order = gdbarch_byte_order (gdbarch);
|
||||
CORE_ADDR func_addr = find_function_addr (function, NULL);
|
||||
@@ -5215,11 +5215,11 @@ mips_n32n64_return_value (struct gdbarch *gdbarch, struct value *function,
|
||||
@@ -5227,11 +5227,11 @@ mips_n32n64_return_value (struct gdbarch *gdbarch, struct value *function,
|
||||
: MIPS_V0_REGNUM);
|
||||
field < TYPE_NFIELDS (type); field++, regnum += 2)
|
||||
{
|
||||
@ -680,7 +680,7 @@ diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
if (TYPE_LENGTH (TYPE_FIELD_TYPE (type, field)) == 16)
|
||||
{
|
||||
/* A 16-byte long double field goes in two consecutive
|
||||
@@ -5261,8 +5261,8 @@ mips_n32n64_return_value (struct gdbarch *gdbarch, struct value *function,
|
||||
@@ -5273,8 +5273,8 @@ mips_n32n64_return_value (struct gdbarch *gdbarch, struct value *function,
|
||||
if (offset + xfer > TYPE_LENGTH (type))
|
||||
xfer = TYPE_LENGTH (type) - offset;
|
||||
if (mips_debug)
|
||||
@ -691,7 +691,7 @@ diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
mips_xfer_register (gdbarch, regcache,
|
||||
gdbarch_num_regs (gdbarch) + regnum,
|
||||
xfer, BFD_ENDIAN_UNKNOWN, readbuf, writebuf,
|
||||
@@ -5320,7 +5320,7 @@ mips_o32_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
@@ -5332,7 +5332,7 @@ mips_o32_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
int argreg;
|
||||
int float_argreg;
|
||||
int argnum;
|
||||
@ -700,7 +700,7 @@ diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
int stack_offset = 0;
|
||||
enum bfd_endian byte_order = gdbarch_byte_order (gdbarch);
|
||||
CORE_ADDR func_addr = find_function_addr (function, NULL);
|
||||
@@ -5384,13 +5384,13 @@ mips_o32_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
@@ -5396,13 +5396,13 @@ mips_o32_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
const gdb_byte *val;
|
||||
struct value *arg = args[argnum];
|
||||
struct type *arg_type = check_typedef (value_type (arg));
|
||||
@ -717,7 +717,7 @@ diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
|
||||
val = value_contents (arg);
|
||||
|
||||
@@ -5844,8 +5844,8 @@ mips_o64_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
@@ -5856,8 +5856,8 @@ mips_o64_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
int argreg;
|
||||
int float_argreg;
|
||||
int argnum;
|
||||
@ -728,7 +728,7 @@ diff --git a/gdb/mips-tdep.c b/gdb/mips-tdep.c
|
||||
enum bfd_endian byte_order = gdbarch_byte_order (gdbarch);
|
||||
CORE_ADDR func_addr = find_function_addr (function, NULL);
|
||||
|
||||
@@ -5905,13 +5905,13 @@ mips_o64_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
@@ -5917,13 +5917,13 @@ mips_o64_push_dummy_call (struct gdbarch *gdbarch, struct value *function,
|
||||
const gdb_byte *val;
|
||||
struct value *arg = args[argnum];
|
||||
struct type *arg_type = check_typedef (value_type (arg));
|
||||
|
@ -33,7 +33,7 @@ git diff --stat -p gdb/master...gdb/users/bheckel/fortran-vla-strings
|
||||
diff --git a/gdb/NEWS b/gdb/NEWS
|
||||
--- a/gdb/NEWS
|
||||
+++ b/gdb/NEWS
|
||||
@@ -103,6 +103,8 @@ SH-5/SH64 running OpenBSD SH-5/SH64 support in sh*-*-openbsd*
|
||||
@@ -106,6 +106,8 @@ SH-5/SH64 running OpenBSD SH-5/SH64 support in sh*-*-openbsd*
|
||||
|
||||
*** Changes in GDB 8.1
|
||||
|
||||
|
12
gdb.spec
12
gdb.spec
@ -18,7 +18,7 @@
|
||||
Name: %{?scl_prefix}gdb
|
||||
|
||||
# Freeze it when GDB gets branched
|
||||
%global snapsrc 20180629
|
||||
%global snapsrc 20180704
|
||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||
%global snapgnulib 20161115
|
||||
%global tarname gdb-%{version}
|
||||
@ -26,7 +26,7 @@ Version: 8.1.50.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 27%{?dist}
|
||||
Release: 28%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -937,7 +937,6 @@ rm -f $RPM_BUILD_ROOT%{_datadir}/gdb/python/gdb/command/backtrace.py
|
||||
%endif
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
# File must begin with "/": {GFDL,COPYING3,COPYING,COPYING.LIB,COPYING3.LIB}
|
||||
%if 0%{!?el6:1}
|
||||
%license COPYING3 COPYING COPYING.LIB COPYING3.LIB
|
||||
@ -957,7 +956,6 @@ rm -f $RPM_BUILD_ROOT%{_datadir}/gdb/python/gdb/command/backtrace.py
|
||||
%{_includedir}/gdb
|
||||
%if 0%{!?scl:1}
|
||||
%files headless
|
||||
%defattr(-,root,root)
|
||||
%{_prefix}/libexec/gdb
|
||||
%endif
|
||||
%config(noreplace) %{_sysconfdir}/gdbinit
|
||||
@ -980,7 +978,6 @@ rm -f $RPM_BUILD_ROOT%{_datadir}/gdb/python/gdb/command/backtrace.py
|
||||
|
||||
%ifnarch sparc sparcv9
|
||||
%files gdbserver
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/gdbserver
|
||||
%{_mandir}/*/gdbserver.1*
|
||||
%if %{have_inproctrace}
|
||||
@ -1007,7 +1004,6 @@ done
|
||||
|
||||
%files doc
|
||||
%doc %{gdb_build}/gdb/doc/{gdb,annotate}.{html,pdf}
|
||||
%defattr(-,root,root)
|
||||
%{_infodir}/annotate.info*
|
||||
%{_infodir}/gdb.info*
|
||||
|
||||
@ -1040,6 +1036,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jul 4 2018 Sergio Durigan Junior <sergiodj@redhat.com> - 8.1.50.20180704-28.fc29
|
||||
- Rebase to FSF GDB 8.1.50.20180704 (8.2pre).
|
||||
- Remove defattr directives from specfile.
|
||||
|
||||
* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com>
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user